Software de ligação ao ambiente de trabalho remoto pode causar uma violação de acesso se FilterQueueType está definido

Traduções de Artigos Traduções de Artigos
Artigo: 329756 - Ver produtos para os quais este artigo se aplica.
Este artigo foi arquivado. Este artigo é oferecido "tal como está" e deixará de ser actualizado.
Expandir tudo | Reduzir tudo

Nesta página

Sintomas

O software de Terminal Services Advanced Client (ou o Microsoft Internet Explorer se está a hospedar o controlo ActiveX Terminal Services Advanced cliente) poderá detectar um erro de protecção geral se definiu a chave de registo
FilterQueueType
7 conforme descrito o seguinte artigo da base de dados de conhecimento da Microsoft:
302361Impressoras multifunção que utilizam portas DOT4 não são redireccionadas utilizando o ambiente de trabalho remoto

Causa

Embora um valor nulo seja válido para um nome de porta de rede, o software de cliente não processa esta condição correctamente.

Resolução

Informações sobre Service Packs

Para resolver este problema, obtenha o service pack mais recente para o Microsoft Windows XP. Para obter informações adicionais, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
322389Como obter o Windows XP service pack mais recente

Informações sobre a correcção

Está disponível a partir da Microsoft uma correcção suportada. No entanto, esta correcção destina-se a corrigir o problema descrito neste artigo. Aplique esta correcção apenas em sistemas que tenham este problema específico. Esta correcção poderá submetida a testes adicionais. Por conseguinte, se não estiver a ser gravemente afectado por este problema, recomendamos que aguarde pela próxima actualização de software que contenha esta correcção.

Se a correcção está disponível para transferência, existe uma secção "denominada transferência de correcção disponível" na parte superior deste artigo da base de dados de conhecimento. Se esta secção não for apresentado, contacte o serviço de cliente do Microsoft e suporte para obter a correcção.

Nota Se ocorram problemas adicionais ou se for necessária qualquer resolução de problemas, poderá ter de criar um pedido de assistência separado. Os custos normais do suporte serão aplicados a problemas adicionais e questões de suporte que não se enquadrem esta correcção específica. Para obter uma lista completa dos números de telefone do suporte de cliente do Microsoft ou para criar um pedido serviço separado, visite o seguinte Web site da Microsoft:
http://support.microsoft.com/contactus/?ws=support
Nota O formulário "Transferência de correcção disponível" apresenta os idiomas para a qual a correcção está disponível. Se não vir o idioma, é porque uma correcção não está disponível para esse idioma.A versão inglesa desta correcção tem os atributos de ficheiro (ou posteriores) listados na seguinte tabela. As datas e horas destes ficheiros são indicadas no formato de universal hora (UTC) coordenada Coordinated. Quando visualiza as informações do ficheiro, é convertido para a hora local. Para determinar a diferença entre a UTC e a hora local, utilize o separador fuso horário na ferramenta Data e hora no painel de controlo.
   Date         Time   Version        Size     File name    Service pack
   ---------------------------------------------------------------------
   07-Nov-2002  17:14  5.1.2600.105   503,808  Mstscax.dll  none
   07-Nov-2002  20:34  5.1.2600.1137  599,552  Mstscax.dll  SP1

Ponto Da Situação

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na secção "Aplica-se a".Este problema foi corrigido pela primeira vez no Microsoft Windows XP Service Pack 2.

Mais Informação

Se símbolos compatíveis com o Dr. Watson estiverem instalados no computador, o estado de registo e a pilha de chamadas a Drwtsn32.log ficheiros ou no depurador são semelhante para:
   0:008> r
   eax=00000000 ebx=00000007 ecx=00000000 edx=5fdd855c esi=5fdfb470 edi=00000000
   eip=5fdeff8c esp=010afc84 ebp=010afc90 iopl=0         nv up ei pl zr na po nc
   cs=001b  ss=0023  ds=0023  es=0023  fs=0038  gs=0000             efl=00010246
   mstscax!_wcsnicmp+35:
   5fdeff8c 668b01           mov     ax,[ecx]              ds:0023:00000000=????

   ChildEBP RetAddr  
   010afc90 5fdd85ac mstscax!_wcsnicmp+0x35
   010afcb0 5fdd9067 mstscax!W32DrAutoPrn::ShouldAddThisPrinter+0x32
   010aff34 5fdd95f6 mstscax!W32DrAutoPrn::Enumerate+0x1d5
   010aff54 5fdd97f7 mstscax!W32ProcObj::AnnounceDevicesToServerFunc+0x46
   010aff5c 5fdd9815 mstscax!W32ProcObj::_AnnounceDevicesToServerFunc+0xd
   010aff74 5fdd99c1 mstscax!W32ProcObj::DispatchAsyncIORequest_Private+0x19
   010aff80 5fdd970c mstscax!W32ProcObj::_DispatchAsyncIORequest_Private+0x11
   010aff98 5fdd997a mstscax!W32ProcObj::CheckForQueuedOperations+0x12
   010affb0 5fdd99ad mstscax!W32ProcObj::ObjectWorkerThread+0x62
   010affb4 77e802ed mstscax!W32ProcObj::_ObjectWorkerThread+0x9
   010affec 00000000 kernel32!BaseThreadStart+0x37

Propriedades

Artigo: 329756 - Última revisão: 27 de fevereiro de 2014 - Revisão: 2.7
A informação contida neste artigo aplica-se a:
  • Microsoft Windows XP Professional Edition
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Home Edition SP1
  • Microsoft Windows XP Professional SP1
Palavras-chave: 
kbnosurvey kbarchive kbmt kbautohotfix kbhotfixserver kbqfe kbwinxpsp2fix kbqfe kbwinxppresp2fix kbfix kbbug KB329756 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine translation ou MT), não tendo sido portanto revisto ou traduzido por humanos. A Microsoft tem artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais. O objectivo é simples: oferecer em Português a totalidade dos artigos existentes na base de dados do suporte. Sabemos no entanto que a tradução automática não é sempre perfeita. Esta pode conter erros de vocabulário, sintaxe ou gramática? erros semelhantes aos que um estrangeiro realiza ao falar em Português. A Microsoft não é responsável por incoerências, erros ou estragos realizados na sequência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza actualizações frequentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 329756

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com