HTTP ファイルのアップロードの操作が完了するまでに時間がかかる

文書翻訳 文書翻訳
文書番号: 329781 - 対象製品
重要 : この資料には、レジストリの編集方法が記載されています。万一に備えて、編集の前には必ずレジストリをバックアップし、レジストリの復元方法を理解しておいてください。バックアップ、復元、および編集方法の詳細を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
256986 Microsoft Windows レジストリの説明
すべて展開する | すべて折りたたむ

現象

HTTP ファイルのアップロード機能を使用して MB 単位のファイルをアップロードすると、アップロード操作が完了するまでに時間がかかる場合があります。

: この問題は、RFC (Request For Comment) 1867 の「Form-based File Upload in HTML」に記載されています。

原因

この問題は、デフォルトの Winsock 送信バッファが 8 KB で、Internet Explorer が 8 KB のチャンクでデータを提供するために発生します。これは、平均的なネットワークでネットワークの帯域幅に関係なく約 80 Kbps に相当します。

関連情報を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
214397 設計上の問題 - Winsock と TCP 経由で小さなデータ セグメントを送信する

解決方法

この問題を解決するには、Winsock での通信時に送信バッファが増えるように Internet Explorer を構成します。これにより、HTTP ファイルのアップロードを使用する場合のネットワーク パフォーマンスが向上します。これを行うには、以下の手順を実行します。

警告 : レジストリ エディタの使い方を誤ると、深刻な問題が発生することがあります。最悪の場合、オペレーティング システムの再インストールが必要になることがあります。マイクロソフトは、レジストリ エディタの誤用により発生した問題に関しては、一切責任を負わないものとします。レジストリ エディタは、自己の責任においてご使用ください。
  1. レジストリ エディタ (Regedt32.exe) を起動します。
  2. 次のレジストリ キーを見つけてクリックします。
    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings
  3. [編集] メニューの [値の追加] をクリックし、次のレジストリ値を追加します。
    値の名前 : SocketSendBufferLength
    データ型 : REG_DWORD
    基数 : 10 進
    値のデータ : 必要なバッファのサイズ (バイト単位)
    バッファ サイズの値オプション :
    16 KB = 16384
    24 KB = 24576
    32 KB = 32768
    40 KB = 40960
    48 KB = 49152
    56 KB = 57344
    64 KB = 65536
  4. レジストリ エディタを終了します。
16 KB のバッファから開始して、それぞれの値を試してください。アップロードのパフォーマンスが適切になったら、対応するバッファの値を選択します。

状況

この動作は仕様です。

詳細

この資料の「解決方法」に記載されている手順を実行すると、以下の Microsoft Developer Network (MSDN) Web サイトで説明されている WININETAPI HTTPSendRequest 関数を使用するプログラムは、レジストリ キーの定義に従って Winsock 送信バッファの割り当て、および要求を行います。

HTTPSendRequest 関数の詳細については、以下の MSDN Web サイトを参照してください。
http://msdn2.microsoft.com/en-us/library/aa384247.aspx
Winsock 送信バッファの動作の関連情報を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
214397 設計上の問題 - Winsock と TCP 経由で小さなデータ セグメントを送信する

プロパティ

文書番号: 329781 - 最終更新日: 2007年3月5日 - リビジョン: 3.3
この資料は以下の製品について記述したものです。
  • Microsoft Internet Explorer 5.5
  • Microsoft Internet Explorer 5.5
  • Microsoft Internet Explorer 5.5
  • Microsoft Internet Explorer 5.5
  • Microsoft Internet Explorer 5.01
  • Microsoft Internet Explorer 6.0?を以下の環境でお使いの場合
    • Microsoft Windows 98 Second Edition
    • Microsoft Windows 98 Standard Edition
    • Microsoft Windows Millennium Edition
    • Microsoft Windows NT Workstation 4.0 Developer Edition
    • Microsoft Windows NT Server 4.0, Terminal Server Edition
    • Microsoft Windows NT Server 4.0 Standard Edition
    • Microsoft Windows XP Home Edition
    • Microsoft Windows XP Media Center Edition
    • Microsoft Windows XP Professional
    • Microsoft Windows XP Tablet PC Edition
    • Microsoft Windows 2000 Advanced Server
    • Microsoft Windows 2000 Datacenter Server
    • Microsoft Windows 2000 Professional Edition
    • Microsoft Windows 2000 Server
キーワード:?
kbprb KB329781
"Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。"

フィードバック

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com