Debido a un error de seguridad, el cliente no puede conectarse al servidor Terminal Server

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Síntomas

Después de actualizar un dominio de Microsoft Windows NT a Microsoft Windows 2000 o a Microsoft Windows Server 2003, se puede denegar repetidamente el acceso a Terminal Server a los clientes de Servicios de Windows 2000 Terminal Server. Si está utilizando un cliente de Servicios de Terminal Server para iniciar sesión en Terminal Server, puede aparecer uno de los mensajes de error siguientes:
Debido a un error de seguridad, el cliente no se puede conectar con Terminal Server. Después de asegurarse de haber iniciado sesión en la red, pruebe a conectarse de nuevo con el servidor.
O bien
Escritorio remoto desconectado. Debido a un error de seguridad, el cliente no puede conectarse al equipo remoto. Después de comprobar que inició la sesión en la red, intente volver a conectarse.
Además, se pueden grabar los siguientes mensajes de Id. de suceso en el Visor de sucesos de Terminal Server:
Id. del suceso: 50
Origen del suceso: TermDD
Descripción del suceso: El componente de protocolo RDP X.224 detectó un error en el flujo de protocolos y ha desconectado el cliente.
y
Id. del suceso: 1008
Origen del suceso: TermService
Descripción del suceso: Ha caducado el periodo de gracia de Licencias de Terminal Server y el servicio no se ha registrado con una licencia de servidor con las licencias instaladas. Se requiere un servidor de licencias de Terminal Server para continuar esta operación. Un servidor Terminal Server puede operar sin un servidor de licencias durante 90 días después del primer inicio.
y
Id. del suceso: 1004
Origen del evento: TermService
Descripción del suceso: Terminal Server no puede emitir una licencia de cliente.
y
Id. del suceso: 1010
Origen del evento: TermService
Descripción del suceso: Terminal Server no puede localizar un servidor de licencias. Asegúrese de que todos los servidores de licencias de la red están registrados en WINS\DNS, aceptando peticiones de red, y de que está ejecutando Licencias de Terminal Server.
y
Id. de evento: 28
Origen del suceso: TermServLicensing
Descripción del suceso: Las licencias de Terminal Server sólo se puede ejecutar en un controlador de dominio o un servidor de un grupo de trabajo. Para obtener más información consulte el tema de Ayuda Licencias de Servidor de Terminal Server.

Causa

Este problema puede producirse si un certificado de Terminal Server está dañado.

Solución

Importante Esta sección, método o tarea contiene pasos que le indican cómo modificar el Registro. Sin embargo, la modificación incorrecta del Registro puede producir graves problemas. Por tanto, compruebe que sigue estos pasos cuidadosamente. Para obtener mayor protección, realice una copia de seguridad del Registro antes de modificarlo. De esta manera, puede restaurar el Registro si se produce algún problema. Para obtener más información acerca de cómo realizar una copia de seguridad del Registro y restaurarlo, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
322756 Cómo realizar una copia de seguridad del Registro y restaurarlo en Windows


Para resolver este problema, haga copia de seguridad de las claves X509 Certificate del Registro y quítelas, reinicie el equipo y vuelva a activar el servidor de Licencias de Servicios de Terminal Server. Para ello, siga estos pasos.

NOTA: Realice el procedimiento siguiente en cada equipo con Terminal Server.
  1. Asegúrese de que se ha hecho copia de seguridad correctamente del Registro de Terminal Server.
  2. Inicie el Editor del Registro.
  3. Busque la siguiente subclave del Registro y haga clic en ella:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\TermService\Parameters
  4. En el menú Registro, haga clic en Exportar archivo del Registro.
  5. Escriba parámetros exportados en el cuadro Nombre de archivo y haga clic en Guardar.

    NOTA: si tiene que restaurar esta subclave del Registro en el futuro, haga doble clic en el archivo Parámetros exportados.reg que guardó en este paso.
  6. En la subclave Parameters del Registro, haga clic con el botón secundario del mouse (ratón) en cada uno de los valores siguientes, haga clic en Eliminar y, después, haga clic en para confirmar la eliminación:
    Certificado
    X509 Certificate
    X509 Certificate ID
  7. Cierre el Editor del Registro y reinicie el servidor.
  8. Vuelva a activar el servidor de Licencias de Terminal Server con el método de conexión telefónica del Asistente para licencias.

    NOTA: si activa el servidor de Licencias de Terminal Server con la opción Teléfono, el servidor de licencias usará otro tipo diferente de certificado.

Más información

Para obtener más información al respecto, haga clic en los números de artículo siguientes para verlos en Microsoft Knowledge Base:
306578 Cómo desactivar o reactivar un servidor de licencias mediante la Administración de licencias de Terminal Services
323597 Los clientes de Windows XP no pueden conectarse a un servidor de Terminal Services de Windows 2000
Nota: es un artículo de "PUBLICACIÓN RÁPIDA" creado directamente por la organización de soporte técnico de Microsoft. La información aquí contenida se proporciona como está, como respuesta a problemas que han surgido. Como consecuencia de la rapidez con la que lo hemos puesto disponible, los materiales podrían incluir errores tipográficos y pueden ser revisados en cualquier momento sin previo aviso. Vea las Condiciones de uso para otras consideraciones

Propiedades

Id. de artículo: 329896 - Última revisión: viernes, 31 de enero de 2014 - Versión: 1.0
La información de este artículo se refiere a:
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
Palabras clave: 
kbprb KB329896

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