Debido a un error de seguridad, el cliente no pudo conectarse al servidor terminal

En este artículo se proporciona una solución a un problema por el que a los clientes de Terminal Services se les deniega repetidamente el acceso al servidor terminal después de actualizar Windows.

Se aplica a: Windows Server 2012 R2
Número de KB original: 329896

Síntomas

Después de actualizar un dominio de Microsoft Windows NT a Windows 2000 o Windows Server 2003, es posible que se deniegue repetidamente el acceso a los clientes de Windows 2000 Terminal Services al servidor terminal. Si usa un cliente de Terminal Services para iniciar sesión en el servidor terminal, puede recibir uno de los siguientes mensajes de error:

Debido a un error de seguridad, el cliente no pudo conectarse al servidor de Terminal Server. Después de asegurarse de que haya iniciado sesión en la red, intente conectarse al servidor de nuevo.

o

Remote desktop desconectado. Debido a un error de seguridad, el cliente no pudo conectarse al equipo remoto. Compruebe que haya iniciado sesión en la red y vuelva a intentar conectarse.

Además, es posible que los siguientes mensajes de identificador de evento se registren en Visor de eventos en el servidor terminal:

Identificador de evento: 50
Origen del evento: TermDD
Descripción del evento: el componente de protocolo RDP X.224 ha detectado un error en la secuencia de protocolo y ha desconectado el cliente.

y

Identificador de evento: 1008
Origen del evento: TermService
Descripción del evento: el período de gracia de licencias de terminal Services ha expirado y el servicio no se ha registrado con un servidor de licencias. Se requiere un servidor de licencias de terminal Services para el funcionamiento continuo. Un servidor terminal puede funcionar sin un servidor de licencias durante 90 días después del inicio inicial.

y

Identificador de evento: 1004
Origen del evento: TermService
Descripción del evento: el servidor terminal no puede emitir una licencia de cliente.

y

Identificador de evento: 1010
Origen del evento: TermService
Descripción del evento: los servicios de terminal no pudieron encontrar un servidor de licencias. Confirme que todos los servidores de licencias de la red están registrados en WINS\DNS, aceptando solicitudes de red y que el servicio de licencias de Terminal Services se está ejecutando.

y

Id. de evento: 28
Origen de eventos: Licencias de TermServ
Descripción del evento: las licencias de Terminal Services solo se pueden ejecutar en controladores de dominio o servidor en un grupo de trabajo. Para obtener más información, consulte el tema de ayuda sobre licencias de Terminal Server.

Causa

Este problema puede producirse si un certificado en el servidor terminal está dañado.

Solución

Importante

Esta sección, método o tarea contiene pasos que le indican cómo modificar el Registro. No obstante, pueden producirse problemas graves si modifica el registro de manera incorrecta. En consecuencia, asegúrese de seguir estos pasos cuidadosamente. Para mayor protección, cree una copia de seguridad del registro antes de modificarlo. Después, puede restaurar el registro si se produce un problema. Para obtener más información sobre cómo hacer una copia de seguridad y restaurar el Registro, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base: 322756 Cómo hacer una copia de seguridad y restaurar el Registro en Windows.

Para resolver este problema, realice una copia de seguridad y quite las claves del Registro de certificados X509, reinicie el equipo y, a continuación, reactive el servidor de licencias de Terminal Services. Para ello, siga estos pasos.

Nota:

Realice el procedimiento siguiente en cada uno de los servidores de terminal.

  1. Asegúrese de que se ha realizado una copia de seguridad correcta del registro de Terminal Server.

  2. Inicie el Editor del Registro.

  3. Busque la siguiente subclave del registro y haga clic en ella:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\TermService\Parameters

  4. En el menú Registro, haga clic en Exportar archivo del Registro.

  5. Escriba export-parameters en el cuadro Nombre de archivo y, a continuación, haga clic en Guardar.

    Nota:

    Si tiene que restaurar esta subclave del Registro en el futuro, haga doble clic en el archivo Exported-parameters.reg que guardó en este paso.

  6. En la subclave registro Parámetros , haga clic con el botón derecho en cada uno de los valores siguientes, haga clic en Eliminary, a continuación, haga clic en para confirmar la eliminación:

    • Certificado
    • Certificado X509
    • Id. de certificado X509
  7. Salga del registro Editor y reinicie el servidor.

  8. Reactivar el servidor de licencias de Terminal Services mediante el método de conexión telefónica en el Asistente para licencias.

    Nota:

    Si activa el servidor de licencias de Terminal Services mediante la opción Teléfono , el servidor de licencias usa otra forma de certificado.