Help and Support
 

powered byLive Search

启动计算机时出现“Stop 0x0000007B INACCESSIBLE_BOOT_DEVICE”错误信息

文章编号:329898
最后修改:2004年2月13日
修订:3.0
重要说明:本文包含有关修改注册表的信息。修改注册表之前,一定要备份注册表,并且一定要知道在发生问题时如何还原注册表。有关如何备份、还原和编辑注册表的信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:
256986 (http://support.microsoft.com/kb/256986/EN-US/) Microsoft Windows 注册表说明
本页

症状

当您尝试启动计算机时,可能出现以下错误信息:
Stop 0x0000007B INACCESSIBLE_BOOT_DEVICE

回到顶端

原因

如果安装了 Iomega IomegaWare 3.1 版程序,可能会出现此问题。

回到顶端

解决方案

警告:注册表编辑器使用不当可导致严重问题,可能需要重新安装操作系统。Microsoft 不能保证您可以解决因注册表编辑器使用不当而导致的问题。使用注册表编辑器需要您自担风险。
要解决此问题,请按照出现的顺序使用以下方法。

回到顶端

方法 1

第 1 部分:通过故障恢复控制台恢复系统

1.通过使用 Windows 2000 CD 作为启动盘启动计算机。

注意:您可能必须在基本输入输出系统 (BIOS) 设置中更改启动计算机的磁盘。有关 BIOS 的信息,请参阅计算机随附的文档。
2.提示您执行此操作时,请按 R 键选择“修复”,然后按 C 键选择“故障恢复控制台”。
3.键入 cd windows\system32\config,然后按 Enter 键更改文件夹。
4.键入 ren system system.old,然后按 Enter 键。
5.键入 copy windows\repair\system,然后按 Enter 键。
6.键入 exit,然后按 Enter 键。
7.正常启动计算机,不要从 Windows CD 启动。
8.如果无法正常启动计算机,请转到方法 2。如果可正常启动计算机,请转到此方法的第 2 部分。

第 2 部分:编辑注册表

1.单击“开始”,单击“运行”,键入 regedt32,然后单击“确定”。
2.单击以下注册表项:

HKEY_LOCAL_MACHINE
3.在“文件”菜单上,单击“加载配置单元”,然后加载 Windows\System32\Config\System.old 配置单元。
4.提示您指定一个名称时,键入 Test
5.找到并随后单击以下注册表项,其中 <xxx> 表示编号,如 001、002 以及其他编号:

ControlSet<xxx>\Control\Class\{4D36E965-E325-11CE-BFC1-08002BE10318}
ControlSet<xxx>\Control\Class\{4D36E967-E325-11CE-BFC1-08002BE10318}
6.删除步骤 5 中每个注册表项的 LOWERFILTERS 项。
7.在 ControlSet<xxx>\Services 下,将 iomdisk, Iomega Activity Disk2, IomegaAccess 和 ZipToA 的初始值更改为 4(禁用)。
8.在“文件”菜单上,单击“卸载配置单元”,然后卸载 Windows\System32\Config\System.old 配置单元。
9.在“文件”菜单上,单击“退出”以退出注册表编辑器。

第 3 部分:恢复系统

1.通过使用 Windows 2000 CD 作为启动盘启动计算机。

注意:您可能必须在 BIOS 设置中更改启动计算机的磁盘。有关 BIOS 的信息,请参阅计算机随附的文档。
2.提示您执行此操作时,按 R 键选择“修复”,然后按 C 键选择“故障恢复控制台”。
3.键入 cd windows\system32\config,然后按 Enter 键更改文件夹。
4.键入 ren system system.xxx,然后按 Enter 键。
5.键入 ren system.old system,然后按 Enter 键。
6.键入 exit,然后按 Enter 键。

第 4 部分:删除 IomegaWare

正常启动计算机(不要从 Windows CD 启动),然后删除 IomegaWare 程序。

回到顶端

方法 2

如果在执行方法 1 中步骤 1-7 后无法正常启动计算机,请按以下步骤执行操作。

第 1 部分:撤消系统恢复

1.通过使用 Windows 2000 CD 作为启动盘启动计算机。

注意:您可能必须在 BIOS 设置中更改启动计算机的磁盘。有关 BIOS 的信息,请参阅计算机随附的文档。
2.提示您执行此操作时,请按 R 键选择“修复”,然后按 C 键选择“故障恢复控制台”。
3.键入 cd windows\system32\config,然后按 Enter 键更改文件夹。
4.键入 ren system system.xxx,然后按 Enter 键。
5.键入 ren system.old system,然后按 Enter 键。

第 2 部分:复制驱动程序

1.键入 cd windows\system32\drivers,然后按 Enter 键。
2.键入 ren IomDisk.sys IomDisk.old,然后按 Enter 键。
3.键入 copy atapi.sys iomDisk.sys,然后按 Enter 键。

第 3 部分:禁用 Iomega 服务

1.键入 listsvc,然后找到以下 Iomega 服务:
?iomdisk
?Iomega Activity Disk2
?IomegaAccess
?ZipToA
2.键入 disable 服务名称,禁用上述各项服务。

第 4 部分:执行原位 Windows 升级

执行 Windows 2000 原位升级,然后使用“控制面板”中的“添加或删除程序”工具删除 IomegaWare。

有关如何执行 Windows 2000 原位升级的其他信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:
292175 (http://support.microsoft.com/kb/292175/EN-US/) How to Perform an In-Place Upgrade of Windows 2000

回到顶端

更多信息

有关 Windows 2000 故障恢复控制台的其他信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:
229716 (http://support.microsoft.com/kb/229716/EN-US/) Windows 2000 故障恢复控制台的说明

回到顶端


这篇文章中的信息适用于:
?Microsoft Windows 2000 Advanced Server
?Microsoft Windows 2000 Server
?Microsoft Windows 2000 Professional Edition

回到顶端

关键字:?
kberrmsg kbprb KB329898

回到顶端

Microsoft和/或其各供应商对于为任何目的而在本服务器上发布的文件及有关图形所含信息的适用性,不作任何声明。 所有该等文件及有关图形均"依样"提供,而不带任何性质的保证。Microsoft和/或其各供应商特此声明,对所有与该等信息有关的保证和条件不负任何责任,该等保证和条件包括关于适销性、符合特定用途、所有权和非侵权的所有默示保证和条件。在任何情况下,在由于使用或运行本服务器上的信息所引起的或与该等使用或运行有关的诉讼中,Microsoft和/或其各供应商就因丧失使用、数据或利润所导致的任何特别的、间接的、衍生性的损害或任何因使用而丧失所导致的之损害、数据或利润不负任何责任。

文章翻译

 

Related Support Centers

Other Support Options

  • Need More Help?
    Contact a Support professional by E-mail, Online or Phone.
  • Customer Service
    For non-technical assistance with product purchases, subscriptions, online services, events, training courses, corporate sales, piracy issues, and more.
  • Newsgroups
    Pose a question to other users. Discussion groups and Forums about specific Microsoft products, technologies, and services.