Messaggio di errore "Impossibile accedere a Outlook.pst - 0x80040116" quando si avvia Outlook 2000 o si apre un file delle cartelle personali

Traduzione articoli Traduzione articoli
Identificativo articolo: 329910 - Visualizza i prodotti a cui si riferisce l?articolo.
Espandi tutto | Chiudi tutto

In questa pagina

Sintomi

Quando si avvia Microsoft Outlook 2000 o si tenta di aprire un file delle cartelle personali (pst), Ŕ possibile che venga visualizzato il messaggio di errore riportato di seguito, dove Outlook.pst Ŕ il nome del file pst:
Impossibile accedere a Outlook.pst - 0x80040116.
Se si esegue l'UtilitÓ di ripristino Posta in arrivo (Scanpst.exe), il problema non viene risolto e lo strumento Scanpst.exe potrebbe segnalare che non Ŕ stato trovato alcun errore.

Cause

Questo problema pu˛ verificarsi se l'indice del file con estensione pst Ŕ danneggiato.

Risoluzione

Per risolvere questo problema, eseguire lo strumento di troncamento da 2 GB (2 GB Truncation Tool), eseguire l'UtilitÓ di ripristino Posta in arrivo, quindi aprire il file ripristinato.

NOTA: data l'esistenza di varie versioni di Microsoft Windows, la procedura descritta di seguito potrebbe risultare diversa da computer a computer. In questo caso, fare riferimento alla documentazione del prodotto per completare la procedura.

Parte 1: Esecuzione dello strumento di troncamento da 2 GB

  1. Lo strumento di troncamento da 2 GB (Pst2gb.exe) Ŕ disponibile per il download nell'Area download Microsoft (informazioni in lingua inglese):
    http://www.microsoft.com/downloads/details.aspx?familyid=B33B1DFF-6F50-411D-BBDF-82019DDA602E&displaylang=en
  2. Estrarre il file 2gb152.exe in una cartella vuota. Dovrebbero essere visualizzati i seguenti cinque file:
    • Msstdfmt.dll
    • Msvbvm60.dll
    • Pst2gb.exe
    • Readme.rtf
    • Readme.txt
  3. Fare clic sul pulsante Start e scegliere Cerca.
  4. Scegliere Opzioni cartella dal menu Strumenti, quindi fare clic sulla scheda Visualizza.
  5. Selezionare Visualizza cartelle e file nascosti, deselezionare le caselle di controllo Nascondi le estensioni dei file per i tipi di file conosciuti e Nascondi i file protetti di sistema (consigliato), fare clic su per confermare che si desidera visualizzare i file protetti di sistema, quindi scegliere OK.
  6. In Scegliere il tipo di oggetto da cercare fare clic su Tutti i file e le cartelle.
  7. Nella casella Nome del file o parte del nome digitare *.pst.
  8. Nell'elenco Cerca in fare clic su UnitÓ disco rigido locali (C:), quindi scegliere Trova.
  9. Prendere nota del percorso del file con estensione pst che si desidera ripristinare. Per impostazione predefinita, il nome del file Ŕ Outlook.pst.
  10. Fare clic sul pulsante Start, scegliere Esegui, digitare percorso\pst2gb.exe -s, quindi scegliere OK, dove percorso Ŕ il percorso completo del file Pst2gb.exe estratto nel passaggio 2. Se, ad esempio, i file dello strumento di troncamento da 2 GB sono stati estratti nella cartella C:\File, digitare c:\file\pst2gb.exe -s, quindi scegliere OK.
  11. Scegliere Continua, quindi Sfoglia.
  12. Selezionare il file pst che si desidera ripristinare, quindi scegliere Apri. Per impostazione predefinita, il nome del file Ŕ Outlook.pst.
  13. Fare clic su Crea, digitare un nuovo nome di file univoco per il file pst, ad esempio Outlook-2, nella casella Nome file, quindi fare clic su Salva.
  14. Nella finestra di dialogo Oversized PST Recovery Tool (Strumento di ripristino PST di dimensioni eccessive) fare clic su Start (Avvia).
  15. Dopo avere eseguito lo strumento, scegliere OK, quindi fare clic su Close (Chiudi).

Parte 2: Esecuzione dell'UtilitÓ di ripristino Posta in arrivo

  1. Fare clic sul pulsante Start e scegliere Cerca.
  2. In Scegliere il tipo di oggetto da cercare fare clic su Tutti i file e le cartelle.
  3. Nella casella Nome del file o parte del nome digitare scanpst.exe.
  4. Nell'elenco Cerca in fare clic su UnitÓ disco rigido locali (C:), quindi scegliere Trova.
  5. Nell'elenco dei file trovati fare doppio clic sul file Scanpst.exe.
  6. Fare clic su Sfoglia, quindi aprire la cartella contenente il nuovo file pst creato utilizzando lo strumento di troncamento da 2 GB.
  7. Fare clic sul nuovo file pst creato, quindi su Apri.
  8. Nella finestra di dialogo UtilitÓ di ripristino Posta in arrivo fare clic su Avvia.
  9. Dopo che il file Ŕ stato analizzato, fare clic su Correggi per correggere gli errori nel file.

    NOTA: questa procedura pu˛ richiedere alcune ore.
  10. Dopo la visualizzazione del messaggio "Correzione completata", scegliere OK.
  11. Riavviare il computer.

Parte 3: Apertura del file ripristinato in Outlook 2000

  1. Avviare Outlook 2000.
  2. Scegliere Apri dal menu File, quindi fare clic su File delle cartelle personali (.pst).
  3. Aprire la cartella contenente il nuovo file pst creato e ripristinato.
  4. Fare clic sul nuovo file pst, quindi scegliere OK.

    NOTA: se il file si apre correttamente, sarÓ presente nell'elenco di file in Cartelle personali recuperate.
  5. Copiare i dati da ogni cartella in Cartelle personali recuperate alle cartelle "Outlook oggi - (Cartelle personali)".

Informazioni

Per ulteriori informazioni sugli argomenti correlati, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
296088 OL: Strumento di troncamento per i file PST e OST con dimensioni eccedenti i limiti
Per informazioni su come ottenere lo strumento WinZip, visitare il seguente sito Web WinZip (informazioni in lingua inglese):
http://www.winzip.com
Microsoft fornisce informazioni per contattare altri produttori allo scopo di facilitare l'individuazione del supporto tecnico. Queste informazioni sono soggette a modifica senza preavviso. Microsoft non si assume alcuna responsabilitÓ sull'accuratezza delle informazioni relative al contatto con altri produttori.

I prodotti di terze parti citati in questo articolo sono forniti da produttori indipendenti. Microsoft non rilascia alcuna garanzia implicita o esplicita relativa alle prestazioni o all'affidabilitÓ di tali prodotti.

ProprietÓ

Identificativo articolo: 329910 - Ultima modifica: mercoledý 21 maggio 2008 - Revisione: 6.2
Le informazioni in questo articolo si applicano a
  • Microsoft Outlook 2000 Standard Edition
Chiavi:á
kbcorrupt kbrepair kb3rdparty kberrmsg kbprb KB329910
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.

Invia suggerimenti

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com