Při spuštění počítače se spustí program Poznámkový blok s textem „[.ShellClassInfo] LocalizedResourceName=@%SystemRoot%\System32\Shell32.dll,-21787“

Překlady článku Překlady článku
ID článku: 330132 - Produkty, které se vztahují k tomuto článku.
Rozbalit všechny záložky | Minimalizovat všechny záložky

Na této stránce

Příznaky

Po spuštění počítače se spustí program Poznámkový blok a na ploše systému Windows se zobrazí jeden nebo více textových dokumentů, které obsahují následující řádky:
[.ShellClassInfo] LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-21787

Příčina

K tomuto chování může dojít, pokud platí následující podmínky:
  • V jedné nebo více následujících složkách se vyskytuje soubor Desktop.ini (jednotka je jednotka, na které je nainstalován systém Windows):
    • jednotka:\Documents and Settings\All Users\Start Menu\Programs\Startup
    • jednotka:\Documents and Settings\All Users\Start Menu\Programs
    • jednotka:\Documents and Settings\All Users\Start Menu
    a
  • Soubor Desktop.ini obsahuje následující řádky:
    [.ShellClassInfo] LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-21787

Řešení

Chcete-li tento problém vyřešit, použijte jednu z následujících metod:

Chcete-li, abychom metodu 1 provedli za vás, přejděte k části Automatická oprava. Chcete-li tyto potíže vyřešit sami, přejděte k části Manuální oprava.

Automatická oprava



Chcete-li tyto potíže odstranit automaticky, klikněte na tlačítko nebo odkaz Opravit. V dialogovém okně Stažení souboru klikněte na položku Spustit a postupujte podle kroků v průvodci opravou.


Fix this problem
Microsoft Fix it 50641


Poznámky
  • Tento průvodce může být k dispozici pouze v angličtině. Tato automatická oprava však funguje i pro ostatní jazykové verze systému Windows.
  • Pokud právě nejste u počítače, který má tyto potíže, můžete opravu uložit na jednotku USB Flash nebo na disk CD a spustit ji v příslušném počítači později.

Poté přejděte k části Byly potíže vyřešeny?.



Manuální oprava

Metoda 1: Odstranění souboru Desktop.ini

  1. Spusťte program Průzkumník Windows.
  2. V nabídce Nástroje klepněte na příkaz Možnosti složky a klepněte na kartu Zobrazení.
  3. V poli Upřesnit nastavení zrušte zaškrtnutí políček Skrýt příponu souborů známých typů a Skrýt chráněné soubory operačního systému (pokud již není jejich zaškrtnutí zrušené) a klepněte na tlačítko OK.
  4. Odstraňte všechny výskyty souboru Desktop.ini, který obsahuje řádky popsané výše v tomto článku v části Příznaky. Postup:
    1. Vyhledejte každou z následujících složek, klepněte pravým tlačítkem myši na soubor Desktop.ini (pokud se ve složce vyskytuje) a potom klepněte na příkaz Otevřít:
      • jednotka:\Documents and Settings\All Users\Start Menu\Programs\Startup
      • jednotka:\Documents and Settings\All Users\Start Menu\Programs
      • jednotka:\Documents and Settings\All Users\Start Menu
      kde jednotka je jednotka, na které je nainstalován systém Windows.
    2. Ověřte, zda soubor obsahuje následující řádky:
      [.ShellClassInfo] LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-21787
      Pokud ano, klepněte na něj pravým tlačítkem myši, klepněte na příkaz Odstranit a potom po zobrazení výzvy k potvrzení odstranění klepněte na tlačítko Ano.
  5. Restartujte počítač a ověřte, zda je problém vyřešený.

Metoda 2: Použití Nástroje pro konfiguraci systému (Msconfig.exe) pro zakázání položky Po spuštění

  1. Klepněte na tlačítko Start a potom na příkaz Spustit.
  2. Do pole Otevřít zadejte příkaz msconfig a klepněte na tlačítko OK.
  3. Klepněte na kartu Po spuštění.
  4. Zrušte zaškrtnutí políček vedle všech položek Plocha ve sloupci Položka při spuštění, které mají ve sloupci Umístění uvedeno Common Startup a jsou umístěné v některém z následujících umístění (jak je uvedeno ve sloupci Příkaz):
    • jednotka:\Documents and Settings\All Users\Start Menu\Programs\Startup
    • jednotka:\Documents and Settings\All Users\Start Menu\Programs
    • jednotka:\Documents and Settings\All Users\Start Menu
  5. Klepnutím na tlačítko OK ukončete Nástroj pro konfiguraci systému.
  6. Restartujte počítač a ověřte, zda je problém vyřešený.

Byly potíže vyřešeny?

  • Ověřte, zda jsou potíže vyřešeny. Pokud ano, v této části již pro vás nejsou žádné potřebné informace. Pokud potíže přetrvávají, můžete kontaktovat podporu.
  • Uvítáme vaše názory. Chcete-li nám sdělit svůj názor nebo nahlásit potíže s tímto řešením, uveďte poznámky v blogu Fix it for me (Automatická oprava) nebo nám odešlete e-mail.

Další informace

Další informace o postupu při řešení potíží systému Windows XP pomocí Nástroje pro konfiguraci systému naleznete v následujícím článku znalostní báze Microsoft Knowledge Base:
310560 Řešení potíží s chybami konfigurace v operačním systému Windows XP pomocí Nástroje pro konfiguraci systému

Vlastnosti

ID článku: 330132 - Poslední aktualizace: 30. listopadu 2012 - Revize: 3.0
Informace v tomto článku jsou určeny pro produkt:
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
Klíčová slova: 
kbprb kbfixme kbmsifixme KB330132

Dejte nám zpětnou vazbu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com