기술 자료: 330132 - 이 문서가 적용되는 제품 보기.
모두 확대 | 모두 축소

이 페이지에서

현상

컴퓨터를 시작하면 메모장이 시작되고 다음과 같은 행이 포함되어 있는 하나 이상의 텍스트 문서가 Windows 바탕 화면에 나타납니다.
[.ShellClassInfo] LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-21787

원인

다음과 같은 경우 이 문제가 발생할 수 있습니다.
  • Desktop.ini 파일이 다음 폴더 중 하나 이상에 있습니다. 여기서 drive는 Windows가 설치된 드라이브입니다.
    • drive:\Documents and Settings\All Users\Start Menu\Programs\Startup
    • drive:\Documents and Settings\All Users\Start Menu\Programs
    • drive:\Documents and Settings\All Users\Start Menu
  • Desktop.ini 파일에 다음과 같은 행이 포함되어 있습니다.
    [.ShellClassInfo] LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-21787

해결 방법

이 문제를 해결하려면 다음 방법 중 하나를 사용하십시오.

Microsoft에서 방법 1를 수행하도록 하려면 "해결 지원" 절로 이동하십시오. 이 문제를 직접 해결하려면 "직접 해결" 절로 이동하십시오.

해결 지원



이 문제를 자동으로 해결하려면 Fix it 단추나 링크를 클릭합니다. 파일 다운로드 대화 상자에서 실행을 클릭하고 Fix it 마법사의 단계를 따릅니다.


Fix this problem
Microsoft Fix it 50641


참고
  • 이 마법사는 영어로만 제공될 수도 있습니다. 그러나 다른 언어 버전의 Windows에서도 자동 해결 기능을 사용할 수 있습니다.
  • 현재 문제가 있는 컴퓨터에서 작업하고 있지 않은 경우 Fix it 솔루션을 플래시 드라이브 또는 CD에 저장한 후 문제가 있는 컴퓨터에서 실행하십시오.

그런 다음 "문제가 해결되었습니까?" 절로 이동하십시오.



직접 해결

방법 1: Desktop.ini 파일 삭제

  1. Windows 탐색기를 시작합니다.
  2. 도구 메뉴에서 폴더 옵션을 클릭한 다음 보기 탭을 클릭합니다.
  3. 고급 설정 상자에서 알려진 파일 형식의 파일 확장명 숨기기 확인란과 보호된 운영 체제 파일 숨기기 확인란의 선택을 취소한 다음 확인을 클릭합니다.
  4. 이 문서의 "현상" 절에 설명되어 있는 행이 포함되어 있는 Desktop.ini 파일을 모두 삭제합니다. 디버그 로깅을 설정하려면 다음과 같이 하십시오.
    1. 아래의 폴더를 각각 찾아서 해당 폴더에 Desktop.ini 파일이 있으면 이 파일을 마우스 오른쪽 단추로 클릭한 다음 열기를 클릭합니다.
      • drive:\Documents and Settings\All Users\Start Menu\Programs\Startup
      • drive:\Documents and Settings\All Users\Start Menu\Programs
      • drive:\Documents and Settings\All Users\Start Menu
      여기서 drive는 Windows가 설치된 드라이브입니다.
    2. 파일에 다음과 같은 행이 포함되어 있는지 확인합니다.
      [.ShellClassInfo] LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-21787
      파일에 이 행이 포함되어 있으면 해당 파일을 마우스 오른쪽 단추로 클릭하고, 삭제를 클릭한 다음 삭제할 것인지 묻는 메시지가 나타나면 를 클릭합니다.
  5. 컴퓨터를 다시 시작하고 문제가 해결되었는지 확인합니다.

방법 2: 시스템 구성 유틸리티(Msconfig.exe)를 사용하여 시작 항목 해제

  1. 시작을 클릭한 다음 실행을 클릭합니다.
  2. 열기 상자에 msconfig를 입력한 다음 확인을 클릭합니다.
  3. 시작 탭을 클릭합니다.
  4. 시작 항목 열에서 위치 열에 Common Startup이라고 나와 있고, 또한 명령 열에 다음 위치 중 한 곳에 있는 것으로 나와 있는 desktop 항목 옆의 확인란 선택을 취소합니다.
    • drive:\Documents and Settings\All Users\Start Menu\Programs\Startup
    • drive:\Documents and Settings\All Users\Start Menu\Programs
    • drive:\Documents and Settings\All Users\Start Menu
  5. 확인을 클릭하여 시스템 구성 유틸리티를 종료합니다.
  6. 컴퓨터를 다시 시작하고 문제가 해결되었는지 확인합니다.

문제가 해결되었습니까?

  • 문제가 해결되었는지 확인합니다. 문제가 해결되었다면 이 절에서 설명한 작업이 끝난 것이지만 문제가 해결되지 않은 경우에는 기술 지원 서비스에 문의할 수 있습니다.
  • 의견을 보내 주셔서 감사합니다. 의견을 보내거나 이 해결 방법에 대한 문제점을 보고하려면 "Fix it for me" 블로그에 의견을 남겨 주시거나 전자 메일을 보내 주십시오.

추가 정보

Windows XP에서 시스템 구성 유틸리티를 사용하여 문제를 해결하는 방법에 대한 자세한 내용은 다음 문서 번호를 클릭하여 Microsoft 기술 자료 문서를 참조하십시오.
310560 Windows XP에서 시스템 구성 유틸리티를 사용하여 문제를 해결하는 방법

속성

기술 자료: 330132 - 마지막 검토: 2012년 11월 30일 금요일 - 수정: 3.0
본 문서의 정보는 다음의 제품에 적용됩니다.
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
키워드:?
kbprb kbfixme kbmsifixme KB330132

피드백 보내기

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com