La fonctionnalité d'exécution automatique ou de lecture automatique ne fonctionne pas lorsque vous insérez un CD dans le lecteur

Traductions disponibles Traductions disponibles
Numéro d'article: 330135 - Voir les produits auxquels s'applique cet article
Agrandir tout | Réduire tout

Sommaire

Symptômes

Lorsque vous insérez un CD-ROM dans le lecteur de CD, la fonctionnalité de lecture automatique ou d'exécution automatique peut ne pas fonctionner ou être indisponible. Toutefois, votre lecteur de CD peut fonctionner correctement dans tous les autres cas.

Cause

Ce problème peut se produire si une ou plusieurs des conditions suivantes sont remplies :
  • Une version de Roxio Easy CD Creator antérieure à la version 5.02d est installée sur votre ordinateur.
  • La fonctionnalité de lecture automatique est désactivée dans le Registre.
  • Votre lecteur de CD-ROM utilise un pilote obsolète.
  • L'option de sécurité Ne permettre l'accès au CD-ROM qu'aux utilisateurs connectés localement est activée.
  • Le lecteur de CD utilise un pilote obsolète.
  • Le lecteur de CD-ROM n'est pas compatible avec Windows XP.

Résolution

Pour résoudre ce problème, suivez les méthodes décrites dans cette section dans l'ordre dans lequel elles apparaissent jusqu'à ce que le problème soit résolu.

Il vous sera peut-être plus facile de suivre ces étapes si vous imprimez d'abord l'article.

Méthode 1 : Déterminez la version de Easy CD Creator qui est installée sur votre ordinateur, puis désinstallez-la

Remarque Si Easy CD Creator n'est pas installé sur votre ordinateur, passez à la méthode 2.

La version 5.02d de Easy CD Creator ainsi que les versions antérieures peuvent entrer en conflit avec la fonctionnalité de lecture automatique ou d'exécution automatique. Pour déterminer la version de Easy CD Creator qui est installée sur votre ordinateur et la désinstaller, procédez comme suit :
  1. Déterminez la version de Easy CD Creator qui est installée sur votre ordinateur. Pour cela, procédez comme suit :
    1. Démarrez Easy CD Creator
    2. Dans le menu Aide, sélectionnez À propos de Easy CD Creator pour voir quelle version est installée sur l'ordinateur.
    Si la version installée est la version 5.02d ou une version antérieure, passez à l'étape 2 pour la désinstaller. Si la version installée est ultérieure à la version 5.02d, passez à la méthode 2.
  2. Désinstallez le Easy CD Creator à l'aide de la fonctionnalité Ajout/Suppression de programmes. Pour cela, procédez comme suit :
    1. Cliquez sur Démarrer, puis sur Exécuter.
    2. Tapez control appwiz.cpl dans la zone Ouvrir, puis appuyez sur Entrée. La fenêtre Ajout/Suppression de programmes s'affiche.
    3. Sélectionnez Roxio Easy CD Creator dans la liste des programmes installés, puis cliquez sur Supprimer.
    4. Suivez les instructions qui s'affichent à l'écran pour désinstaller le programme.
  3. Faites un essai pour déterminer si le problème est résolu.
Si cette méthode résout le problème, vous avez terminé.

Si le problème persiste, passez à la méthode 2.

Méthode 2 : Vérifiez que la lecture automatique est activée

Important Cette section, méthode ou tâche contient une procédure de modification du Registre. Toutefois, des problèmes graves peuvent se produire si vous modifiez le Registre de façon incorrecte. Par conséquent, veillez à suivre ces étapes scrupuleusement. Pour plus de protection, effectuez une sauvegarde du Registre avant de le modifier. Vous serez alors en mesure de le restaurer en cas de problème. Pour plus d'informations sur la procédure de sauvegarde et de restauration du Registre, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :
322756 Comment faire pour sauvegarder et restaurer le Registre dans Windows
Il se peut que la fonctionnalité de lecture automatique ne soit pas activée. Pour activer la lecture automatique, procédez comme suit :
  1. Cliquez sur Démarrer, puis sur Exécuter.
  2. Tapez regedit, puis cliquez sur OK.
  3. Recherchez la sous-clé de Registre suivante et cliquez dessus :
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\CDRom
  4. Double-cliquez sur Autorun et regardez dans la zone Données de la valeur si la valeur zéro ou un s'affiche.
    • Si la valeur pour Autorun est 1, passez à l'étape 5.
    • Si la valeur pour Autorun est 0, cliquez avec le bouton droit sur Autorun, puis cliquez sur Modifier. Dans la zone Données de la valeur, tapez 1, puis cliquez sur OK.
  5. Recherchez la sous-clé de Registre suivante et cliquez dessus :
    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
  6. Double-cliquez sur NoDriveTypeAutoRun pour afficher sa valeur. Si la valeur est 0xb5, la fonctionnalité d'exécution automatique pour les CD-ROM est désactivée. Pour activer la fonctionnalité d'exécution automatique, procédez comme suit :
    1. Cliquez avec le bouton droit sur NoDriveTypeAutoRun.
    2. Cliquez sur Modifier.
    3. Dans la zone Données de la valeur, tapez 91.
    4. Sélectionnez Hexadécimal, puis cliquez sur OK.
  7. Quittez l'Éditeur du Registre.
Faites un essai pour déterminer si le problème est résolu. Si le problème est résolu, vous avez terminé.

Si le problème n'est pas résolu, passez à la méthode 3.

Méthode 3 : Veillez à ce que le CD-ROM soit disponible uniquement pour les utilisateurs connectés localement

Important Cette section, méthode ou tâche contient une procédure de modification du Registre. Toutefois, des problèmes graves peuvent se produire si vous modifiez le Registre de façon incorrecte. Par conséquent, veillez à suivre ces étapes scrupuleusement. Pour plus de protection, effectuez une sauvegarde du Registre avant de le modifier. Vous serez alors en mesure de le restaurer en cas de problème. Pour plus d'informations sur la procédure de sauvegarde et de restauration du Registre, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :
322756 Comment faire pour sauvegarder et restaurer le Registre dans Windows
L'option Ne permettre l'accès au CD-ROM qu'aux utilisateurs connectés localement est peut-être désactivée. Pour activer cette option, procédez comme suit :
  1. Cliquez sur Démarrer, puis sur Exécuter.
  2. Dans la zone Ouvrir, tapez regedit, puis cliquez sur OK.
  3. Recherchez la sous-clé de Registre suivante et cliquez dessus :
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon
  4. Dans le volet de navigation, sous Données, si la valeur pour allocatecdroms est 0, passez à l'étape 5.
  5. Dans le volet de navigation, sous Données, si la valeur pour allocatecdroms est 1, cliquez avec le bouton droit sur allocatecdroms, puis cliquez sur Modifier.
  6. Dans la zone Données de la valeur, tapez 0, puis cliquez sur OK.
  7. Quittez l'Éditeur du Registre.
  8. Faites un essai pour déterminer si le problème est résolu.
Si cette méthode résout le problème, vous avez terminé.

Si le problème persiste, passez à la méthode 4.

Méthode 4 : Assurez-vous que le pilote du lecteur de CD-ROM est à jour

Si le pilote du lecteur de CD n'est pas à jour, la fonctionnalité de lecture automatique peut ne pas fonctionner. Pour résoudre ce problème, procédez comme suit :
  1. Cliquez sur Démarrer, cliquez avec le bouton droit sur Poste de travail, puis cliquez sur Propriétés.
  2. Sous l'onglet Matériel, cliquez sur Gestionnaire de périphériques.
  3. Dans le Gestionnaire de périphériques, développez Lecteurs de CD-ROM/DVD-ROM, puis cliquez avec le bouton droit sur le lecteur de CD que vous souhaitez mettre à jour.
  4. Cliquez sur Mettre le pilote à jour pour démarrer l'Assistant Mise à jour du matériel, puis suivez les instructions qui apparaissent à l'écran pour installer le dernier pilote pour votre lecteur de CD.
  5. Faites un essai pour déterminer si le problème est résolu.
Si cette méthode résout le problème, vous avez terminé.

Si le problème persiste, passez à la méthode 5.

Méthode 5 : Assurez-vous que le lecteur de CD est compatible avec Windows XP

Si le lecteur de CD n'est pas compatible avec Windows XP, remplacez le lecteur par un modèle compatible. Si le lecteur est compatible et que les méthodes présentées dans cet article ne vous ont pas aidé, reportez-vous à la section « Étapes suivantes ».

Plus d'informations

Pour plus d'informations sur une rubrique connexe, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft.
314855 Le CD-ROM ne s'exécute pas automatiquement dans Windows XP
Les produits tiers mentionnés dans le présent article proviennent de sociétés indépendantes de Microsoft. Microsoft exclut toute garantie, implicite ou autre, concernant les performances ou la fiabilité de ces produits.

ÉTAPES SUIVANTES

Si ces méthodes ne vous ont pas aidé, il est possible que vous souhaitiez demander de l'aide à une personne de votre entourage ou que vous souhaitiez utiliser le site Web des services de support technique Microsoft pour trouver d'autres solutions. Les services offerts sur ce site comprennent notamment :
  • Base de connaissances offrant des fonctions de recherche : recherchez des informations de support technique et des outils d'auto-assistance pour les produits Microsoft.
  • Centres de solutions : consultez les questions les plus fréquentes spécifiques au produit et les points principaux du support.
  • Autres options de support : posez vos questions en ligne, contactez les services de support client Microsoft ou envoyez vos commentaires.
Si ces problèmes persistent, vous pouvez contacter le support :
http://support.microsoft.com/contactus?ln=fr#tab0

Propriétés

Numéro d'article: 330135 - Dernière mise à jour: vendredi 7 juin 2013 - Version: 7.1
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Édition familiale
Mots-clés : 
kbexpertisebeginner kbexpertiseinter kbregistry kbenv kb3rdparty kbprb KB330135
L'INFORMATION CONTENUE DANS CE DOCUMENT EST FOURNIE PAR MICROSOFT SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. L'UTILISATEUR ASSUME LE RISQUE DE L'UTILISATION DU CONTENU DE CE DOCUMENT. CE DOCUMENT NE PEUT ETRE REVENDU OU CEDE EN ECHANGE D'UN QUELCONQUE PROFIT.

Envoyer des commentaires

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com