AutoRun funkciu alebo funkciu AutoPlay nefunguje, keď vložíte disk CD-ROM do jednotky CD-ROM

Preklady článku Preklady článku
ID článku: 330135 - Zobraziť produkty, ktorých sa tento článok týka.

Aby naďalej prijímať aktualizácie zabezpečenia pre systém Windows, uistite sa, že používate systém Windows XP s aktualizáciou Service Pack 3 (SP3). Ďalšie informácie nájdete na tejto webovej stránke spoločnosti Microsoft: Podpora sa končí pre niektoré verzie systému Windows

Rozbaliť všetko | Zbaliť všetko

Na tejto stránke

Príznaky

Po vložení disku CD-ROM do jednotky CD-ROM, funkcie AutoPlay alebo AutoRun funkciu nemusia fungovať alebo nemusia byť dostupné. Však vaše CD-ROM môže pracovať správne v každej iným spôsobom.

Príčina

Tento problém sa môže vyskytnúť, ak jeden alebo viac z nasledujúcich podmienok sú pravdivé:
  • Roxio Easy CD Creator, ktorá je staršia než verzia verzia 5.02d je nainštalovaný v počítači.
  • Funkciu Automatické prehrávanie je vypnutá databázy Registry.
  • Jednotka CD-ROM používa zastaraný ovládač.
  • The Obmedziť CD-ROM access to locally logged on user možnosť zabezpečenia zapnutá.
  • CD-ROM používa zastaraný ovládač.
  • Ovládač pre jednotku CD-ROM nie je kompatibilná so systémom Windows XP.

Riešenie

Ak chcete vyriešiť tento problém, postupujte podľa metód, ktoré sú opísané v tejto časti v poradí v akom sú uvedené, kým sa problém vyriešil.

Ste môžu ľahšie nasledovať kroky, ak si tento článok vytlačíte.

Metóda 1: Zistiť, ktorú verziu programu Easy CD Creator je nainštalovaný v počítači, a potom ho odinštalovať

Poznámka Ak v počítači nie je nainštalovaný Easy CD Creator, prejdite na metódu 2.

Easy CD Creator verzie 5.02d a staršej verzie môže spôsobiť konflikty s funkciu AutoRun alebo automatické prehrávanie. Chcete zistiť, ktorú verziu programu Easy CD Creator je nainštalovaný na vašom počítači a odinštalovať, postupujte nasledovne:
  1. Zistiť, ktorú verziu programu Easy CD creator je nainštalovaný na počítači. Chcete urobiť, postupujte nasledovne:
    1. Štart Easy CD Creator.
    2. Na pomoc menu zvoľte O Easy CD Creator zistiť, ktorá verzia je nainštalovaná v počítači.
    Ak je nainštalovaná verzia 5.02d alebo staršej, prejdite na krok 2 odinštalovať to. Ak verzia nainštalovaná je neskorší než verzia 5.02d, prejdite na metódu 2.
  2. Odinštalovať Easy CD Creator pomocou funkcie Pridanie alebo odstránenie programov. Chcete urobiť, postupujte nasledovne:
    1. Kliknite na tlačidlo Štart, a potom kliknite na tlačidlo Spustiť.
    2. Typ Control appwiz.cpl v Otvorené políčko a potom stlačte kláves ENTER. Zobrazí sa okno Pridanie alebo odstránenie programov.
    3. Vyberte Roxio Easy CD Creator v zozname aktuálne nainštalovaných programov a kliknite na Odstrániť.
    4. Postupujte podľa pokynov zobrazených na obrazovke na odinštalovanie programu.
  3. Testovaním zistite, či je problém vyriešený.
Ak táto metóda rieši problém, všetko je hotové.

Ak táto metóda nevyriešilo problém, prejdite na metódu 2.

Metóda 2: Uistite sa, že je zapnuté automatické prehrávanie

Dôležité Táto sekcia, metóda alebo úloha obsahuje kroky, ktoré vám povedať, ako upraviť databázu registry. Avšak, môžu spôsobiť vážne problémy ak databázu registrov upravíte nesprávne. Preto sa uistite, že ste postupovali správne. Doporučujeme zálohovať databázu registrov skôr, ako zmeníte jej hodnoty. Potom, môžete obnoviť databázu registrov, ak sa vyskytne problém. Ďalšie informácie o zálohovaní a obnovení databázy registrov nájdete po kliknutí na nasledovné číslo článku publikovaného v Microsoft Knowledge Base:
322756 Ako zálohovať a obnoviť databázu registry v systéme Windows
Funkcia AutoPlay je dostupná možno nie je aktivovaný. Ak chcete zapnúť automatické prehrávanie, postupujte nasledovne:
  1. Kliknite na tlačidlo Štart, a potom kliknite na tlačidlo Spustiť.
  2. Typ regedit, a potom kliknite na tlačidlo ok.
  3. Vyhľadajte a potom kliknite na nasledujúci podkľúč databázy registry:
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\CDRom
  4. Dvakrát kliknite na Autorun a uvidíme, či nula alebo jeden je zobrazené v Hodnota údajov box.
    • Ak hodnota pre Autorun je 1, prejdite na krok 5.
    • Ak hodnota pre Autorun je 0, kliknite pravým tlačidlom myši Autorun, a potom kliknite na tlačidlo Upraviť. V hodnota údajov box, zadajte 1, a potom kliknite na tlačidlo ok.
  5. Vyhľadajte a potom kliknite na nasledujúci podkľúč:
    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
  6. Dvakrát kliknite na NoDriveTypeAutoRun vidieť svoju hodnotu. Ak je hodnota 0xb5, funkciu AutoRun pre CD-ROM je vypnutý. Ak chcete zapnúť na AutoRun funkciu, postupujte nasledovne:
    1. Kliknite pravým tlačidlom myši NoDriveTypeAutoRun.
    2. Kliknite na tlačidlo Upraviť.
    3. V Hodnota údajov poľa zadajte 91.
    4. Vyberte Šestnástkové číslo, a potom kliknite na tlačidlo ok.
  7. Editor databázy Registry výstupu.
Testovaním zistite, či je problém vyriešený. Ak sa problém nevyrieši, ste skončili.

Ak problém nie je vyriešený, prejdite na metódu 3.

Metóda 3: Skontrolujte, či CD-ROM je dostupné iba pre používateľov, ktorí sa prihlasujú lokálne

Dôležité Táto sekcia, metóda alebo úloha obsahuje kroky, ktoré vám povedať, ako upraviť databázu registry. Avšak, môžu spôsobiť vážne problémy ak databázu registrov upravíte nesprávne. Preto sa uistite, že ste postupovali správne. Doporučujeme zálohovať databázu registrov skôr, ako zmeníte jej hodnoty. Potom, môžete obnoviť databázu registrov, ak sa vyskytne problém. Ďalšie informácie o zálohovaní a obnovení databázy registrov nájdete po kliknutí na nasledovné číslo článku publikovaného v Microsoft Knowledge Base:
322756 Ako zálohovať a obnoviť databázu registry v systéme Windows
The Obmedziť CD-ROM access to locally logged on user only možnosť môže byť vypnuté. Chcete zapnúť túto možnosť, postupujte nasledovne:
  1. Kliknite na tlačidlo Štart, a potom kliknite na tlačidlo Spustiť.
  2. V Otvorené poľa zadajte regedit, a potom kliknite na tlačidlo ok.
  3. Vyhľadajte a potom kliknite na nasledujúci podkľúč databázy registry:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon
  4. Na navigačnej table podľa Údaje, ak hodnota allocatecdroms je 0, prejdite na krok 5.
  5. Na navigačnej table podľa Údaje, ak hodnota allocatecdroms je 1, pravým tlačidlom myši allocatecdroms, a potom kliknite na tlačidlo Upraviť.
  6. V Hodnota údajov poľa zadajte 0, a potom kliknite na tlačidlo ok.
  7. Editor databázy Registry výstupu.
  8. Testovaním zistite, či je problém vyriešený.
Ak táto metóda rieši problém, všetko je hotové.

Ak táto metóda nevyriešilo problém, prejdite na metódu 4.

Metóda 4: Uistite sa, že ovládač jednotky CD-ROM je aktuálny

Ak ovládač pre CD-ROM nie je aktuálny, funkcie AutoPlay nemusí pracovať. Ak chcete vyriešiť tento problém, postupujte nasledovne:
  1. Kliknite na tlačidlo Štart, kliknite pravým tlačidlom myši Môj počítač, a potom kliknite na tlačidlo Vlastnosti.
  2. Na Hardvér karte, kliknite na tlačidlo Správca zariadení.
  3. V Správcovi zariadení rozbaľte DVD/CD-ROM drives, a potom kliknite pravým tlačidlom myši CD disk, ktorý chcete aktualizovať.
  4. Kliknite na tlačidlo Aktualizácia ovládača spustite sprievodcu aktualizáciou hardvéru, a potom postupujte podľa pokynov na obrazovke nainštalujte najnovší ovládač pre CD mechaniky.
  5. Testovaním zistite, či je problém vyriešený.
Ak táto metóda rieši problém, všetko je hotové.

Ak táto metóda nevyrieši problém, prejdite na metódu 5.

Metóda 5: Uistite sa, že jednotka CD je kompatibilný so systémom Windows XP

Ak CD-ROM nie je kompatibilná so systémom Windows XP, nahradiť jednotku CD s kompatibilným modelom. Ak disk je kompatibilný a metód v tomto článku vám nepomohlo, prejdite do časti "Ďalšie kroky".

Ďalšie informácie

Pre Ďalšie informácie o súvisiacej téme, kliknite na tlačidlo nasledujúci článok číslo zobrazíte článok v databáze Microsoft Knowledge Base:
314855CD-ROM nemusí fungovať automaticky v systéme Windows XP
Produkty nezávislých výrobcov, že táto článok pojednáva, vyrábajú spoločnosti, ktoré sú nezávislé od Microsoft. Microsoft robí žiadna záruka, implikovaných alebo inak, týkajúce sa výkonnosť alebo spoľahlivosť týchto výrobkov.

ĎALŠIE KROKY

Ak tieto metódy vám nepomohlo, možno budete chcieť opýtať, niekto viete o pomoc, alebo môžete tiež použiť Microsoft zákaznícky podporu služby webové stránky nájsť iné riešenia. Niektoré služby, ktoré Microsoft zákaznícky podporu služby webové stránky poskytuje patria:
  • Databáza Knowledge Base: Vyhľadávanie informácií technickej podpory a svojpomocných nástrojov pre produkty spoločnosti Microsoft.
  • Centrá riešení: Zobrazenie výrobkovo často kladené otázky a tipy služby technickej podpory.
  • Ďalšie možnosti podpory: Použite Web položiť otázku, kontaktujte službu podpory zákazníkov spoločnosti Microsoft alebo poskytnúť spätnú väzbu.
Ak máte neustále problémy, môžete kontaktovať technickú podporu:
http://support.Microsoft.com/contactus

Vlastnosti

ID článku: 330135 - Posledná kontrola: 21. novembra 2012 - Revízia: 2.0
Informácie v tomto článku sa týkajú nasledujúcich produktov:
  • Microsoft Windows XP Professional Edition
  • Microsoft Windows XP Home Edition
Kľúčové slová: 
kbexpertisebeginner kbexpertiseinter kbregistry kbenv kb3rdparty kbprb kbmt KB330135 KbMtsk
Strojovo preložené
DÔLEŽITÉ: Tento článok bol preložený pomocou softvéru na strojový preklad od spoločnosti Microsoft, nie prekladateľom. Spoločnosť Microsoft ponúka články preložené prekladateľmi aj strojovo preložené články, vďaka čomu máte možnosť prístupu ku všetkým článkom databázy Knowledge Base vo svojom jazyku. Strojovo preložený článok však nie je vždy perfektný. Môže obsahovať chyby týkajúce sa slovnej zásoby, syntaxe alebo gramatiky, podobne ako cudzinec môže robiť chyby, keď rozpráva vašim jazykom. Spoločnosť Microsoft nenesie zodpovednosť za akékoľvek nepresnosti, chyby alebo škody spôsobené akýmkoľvek nepresným prekladom obsahu alebo jeho použitím zo strany zákazníkov. Spoločnosť Microsoft softvér na strojový preklad pravidelne aktualizuje.
Pokiaľ chcete vidieť anglickú verziu článku, kliknite sem: 330135

Odošlite odozvu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com