Numéro d'article: 330174 - Dernière mise à jour: mercredi 21 octobre 2009 - Version: 5.0

Vous recevez un message d'erreur lorsque vous enregistrez ou déplacez des documents dans Windows XP : « L'écriture différée a échoué »

Sommaire

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Symptômes

Lorsque vous enregistrez ou déplacez des documents volumineux, ou bien tentez de gérer vos fichiers sous Windows XP, vous recevez le message d'erreur suivant par intermittence :
L'écriture différée a échoué
Cet article est destiné aux utilisateurs de niveau intermédiaire et expérimentés.

Cause

Cette erreur s'affiche en général si la fonctionnalité « Activer le cache d'écriture sur le disque  est activée pour votre disque.

Toutefois, si elle ne l'est pas, cette erreur peut quand même se produire car le contrôleur de disque dur UDMA (Ultra Direct Memory Access) est configuré de l'une des manières suivantes :
  • Vous utilisez un câble de connecteur à 40 fils pour connecter le lecteur UDMA au contrôleur à la place du câble à 80 fils et 40 broches requis.
  • Les paramètres BIOS sont configurés de manière à forcer l'accélération des modes UDMA.
Pour plus d'informations sur l'échec d'écriture différée, consultez la section « Informations sur l'échec d'écriture différée ».

Résolution

Pour résoudre ce problème, vérifiez tout d'abord si la fonctionnalité « Activer le cache d'écriture sur le disque » est activée. Si elle est activée, désactivez-la. Pour ce faire, procédez comme suit :

Remarque Si vous désactivez la fonctionnalité « Activer le cache d'écriture sur le disque », les performances de votre disque peuvent diminuer et affecter celles du système de votre ordinateur. Il peut donc être utile de surveiller les performances du système après avoir effectué la procédure décrite dans cette section.

Pour désactiver l'option Activer le cache d'écriture sur le disque, procédez comme suit :
  1. Cliquez sur Démarrer, puis sur Poste de travail.
  2. Cliquez avec le bouton droit sur le disque dur, puis cliquez sur Propriétés.
  3. Cliquez sur l'onglet Matériel.
  4. Sélectionnez le disque dur, puis cliquez sur Propriétés.
  5. Cliquez sur l'onglet Stratégies.
  6. Désactivez la case à cocher Activer le cache d'écriture sur le disque, puis cliquez sur OK.
  7. Cliquez sur OK pour fermer la boîte de dialogue Propriétés du disque local (C:).
  8. Répétez les étapes 3 à 5 pour chaque disque dur installé sur votre ordinateur.
Si le message d'erreur ne s'affiche plus, vous avez terminé.

Dans le cas contraire ou si la fonctionnalité est déjà désactivée, consultez la section « Dépannage avancé ». Cette section est destinée aux utilisateurs expérimentés. Si vous ne maîtrisez pas le dépannage avancé, contactez le support technique. Pour plus d'informations sur la procédure à suivre, reportez-vous au site Web de Microsoft à l'adresse suivante :
http://support.microsoft.com/contactUS/ (http://support.microsoft.com/contactUS/)

DÉPANNAGE AVANCÉ

Vérifiez que le contrôleur de disque dur est configuré correctement

Pour cela, vérifiez la connexion des câbles et les paramètres BIOS. Essayez tout d'abord la méthode 1.

Méthode 1 : vérifiez que vous utilisez un câble à 80 fils et 40 broches

Vérifiez que le contrôleur de disque dur UDMA utilise un câble à 80 fils et 40 broches. Pour plus d'informations sur la procédure à suivre, consultez la documentation fournie avec votre ordinateur ou contactez le fabricant de votre contrôleur de disque dur UDMA.

Si vous utilisez un câble à 80 fils et 40 broches, passez à la méthode 2.
Dans le cas contraire, procurez-vous un câble de ce type, puis effectuez un test pour savoir si cette méthode résout le message d'erreur.

Si le message d'erreur ne s'affiche plus, vous avez terminé.

Si ce n'est pas le cas, passez à la méthode 2.

Méthode 2 : vérification des paramètres BIOS

Avertissement Ne modifiez pas les paramètres BIOS à moins de parfaitement maîtriser tous les effets de ce type de modification.

Vérifiez que les paramètres BIOS ne sont pas configurés de manière à forcer l'accélération des modes UDMA. Pour plus d'informations sur la procédure à suivre, consultez la documentation fournie avec votre ordinateur ou contactez le fabricant.

Si les paramètres BIOS ne sont pas configurés pour forcer les modes UDMA principaux, consultez la section « Informations sur l'échec d'écriture différée » pour plus d'informations sur les mesures supplémentaires à prendre pour ne plus afficher le message « L'écriture différée a échoué ».
Si les paramètres BIOS sont configurés pour forcer les modes UDMA principaux, modifiez les paramètres, puis effectuez un test pour savoir si cette méthode résout le message d'erreur.

Si le message d'erreur ne s'affiche plus, vous avez terminé.

Si ce n'est pas le cas, consultez la section « Informations sur l'échec d'écriture différée ».

Informations sur l'échec d'écriture différée

Une fois la connexion des câbles et les paramètres BIOS vérifiés, vous pouvez prendre des mesures supplémentaires pour éviter que le message « L'écriture différée a échoué » ne s'affiche à nouveau.

L'écriture différée peut échouer si les données sont endommagées. Des données peuvent être endommagées si la fonctionnalité Grand cache système est activée pour l'utilisation de la mémoire sous Windows XP. Si cette fonctionnalité est activée, le nombre d'entrées de table de pages que Windows XP doit tenir à jour peut augmenter et, dans certains cas, ces entrées sont épuisées. Bien que ce problème n'existe pas sur tous les systèmes, les facteurs clés suivants peuvent endommager les données :
  • Mémoire système supérieure à 512 Mo (1 gigaoctet de RAM est courant).
  • Importants volumes de disque NTFS et plusieurs grands volumes (disques durs de 60 à 100 gigaoctets, éventuellement dans les contrôleurs RAID).
  • Carte AGP avec des exigences de ressources AGP importantes (supérieures à l'ouverture AGP par défaut).
  • Transferts de fichiers de grande taille. Ce problème se produit lorsque l'ordinateur ne dispose plus d'entrées dans la table des pages. Lorsque l'ordinateur est démarré, Windows détermine le nombre d'entrées de table de pages par défaut à assigner, en fonction de la mémoire système disponible.
Pour éviter d'endommager des données, veillez à ce que le cache système ne soit pas sélectionné pour l'utilisation de la mémoire en désactivant la fonctionnalité correspondante. Pour ce faire, consultez la section « Assurez-vous que le cache système n'est pas sélectionné pour l'utilisation de la mémoire ».

Assurez-vous que le cache système n'est pas sélectionné pour l'utilisation de la mémoire

Si vous transférez des fichiers volumineux, le système peut manquer d'entrées de table de pages et ainsi afficher le message d'erreur « L'écriture différée a échoué ». Pour éviter d'augmenter le nombre d'entrées de table de pages que Windows XP doit tenir à jour et pour éviter de les épuiser, assurez-vous que l'option de cache système n'est pas sélectionnée pour l'utilisation de la mémoire. Pour cela, procédez comme suit :
  1. Cliquez sur Démarrer, cliquez avec le bouton droit sur Poste de travail, puis cliquez sur Propriétés pour ouvrir la boîte de dialogue Propriétés système.
  2. Cliquez sur l'onglet Avancé, puis, sous Performances, cliquez sur Paramètres pour ouvrir la boîte de dialogue Options de performances.
  3. Cliquez sur l'onglet Avancé.
  4. Sous Utilisation de la mémoire, sélectionnez Programmes et cliquez sur OK.
  5. Cliquez sur OK pour fermer la boîte de dialogue Propriétés système.
Si cette procédure fonctionne, vous avez terminé.

Si ce n'est pas le cas, essayez la solution de contournement.

Solution de contournement : augmentez le nombre d'entrées de table de pages

Si le message d'erreur « L'écriture différée a échoué » s'affiche toujours après avoir essayé les méthodes de dépannage décrites dans cet article, essayez de contourner ce problème en augmentant le nombre d'entrées de table de pages disponibles sur le système. Pour ce faire, procédez comme suit :

Important Cette section, méthode ou tâche contient des étapes vous indiquant comment modifier le Registre. Toutefois, des problèmes graves peuvent se produire si vous modifiez le Registre de façon incorrecte. Par conséquent, veillez à suivre ces étapes scrupuleusement. Pour plus de protection, effectuez une sauvegarde du Registre avant de le modifier. Vous serez alors en mesure de le restaurer en cas de problème. Pour plus d'informations sur la procédure de sauvegarde et de restauration du Registre, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :
322756  (http://support.microsoft.com/kb/322756/ ) Procédure de sauvegarde et de restauration du Registre sous Windows
  1. Cliquez sur Démarrer, puis sur Exécuter, tapez regedit, puis cliquez sur OK.
  2. Localisez la clé de Registre suivante :
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management
  3. Dans le volet Détails, cliquez avec le bouton droit sur la valeur SystemPages, puis cliquez sur Modifier
    Remarque La valeur par défaut est 0 (hexadécimale)
    .
  4. Dans la zone Données de la valeur, tapez 7FFF, puis cliquez sur OK.
    Remarque Vous pouvez essayer d'utiliser d'autres valeurs :
    • 7FFF = 32 000
    • PTE BFFF = 50 000
    • PTE 24FFF = 150 000 PTE

    Remarque La valeur FFFFFFFF ne doit pas être utilisée. Si vous la définissez trop élevée, vous pourriez manquer de mémoire de réserve paginée.
  5. Quittez l'Éditeur du Registre.
  6. Redémarrez.
  7. Surveillez la mémoire \ les entrées libres de table de pages système dans Perfmon.
Si cette solution de contournement ne résout pas le message d'erreur, vous pouvez examiner les solutions présentées à la section « Problèmes similaires et solutions » ou contacter le support technique. Pour plus d'informations sur la manière de contacter le support technique, consultez la section « Étapes suivantes ».

PROBLÈMES SIMILAIRES ET SOLUTIONS

Si cet article ne traite pas votre problème, vous pouvez peut-être trouver un problème similaire ou un problème résolu par un autre article. Si vous recevez le message d'erreur « Verrouillage de fichier » ou « Accès refusé », consultez la section « Informations sur le verrouillage de fichier ou l'accès refusé ». Pour d'autres problèmes similaires, consultez la section « Plus d'informations ».

Informations sur le verrouillage de fichier ou l'accès refusé

Si vous essayez d'ouvrir un fichier stocké sur le réseau, puis d'enregistrer les modifications apportées au fichier, ou si vous ouvrez un fichier, comme par exemple un classeur Microsoft Excel, en utilisant un chemin conforme à la convention d'affectation des noms (UNC), vous risquez de recevoir un message d'erreur de verrouillage de fichier ou d'accès refusé. Pour plus d'informations sur les messages d'erreur de verrouillage de fichier ou d'accès refusé lors de l'enregistrement de fichiers dans un chemin UNC, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :
812937  (http://support.microsoft.com/kb/812937/ ) Message d'erreur de verrouillage de fichier ou d'accès refusé lorsque vous enregistrez des fichiers sur le réseau (en anglais)

Plus d'informations

Pour plus d'informations, cliquez sur les numéros ci-dessous pour afficher les articles correspondants de la Base de connaissances Microsoft.
818788  (http://support.microsoft.com/kb/818788/ ) Message d'erreur « {L'écriture différée a échoué} » lorsque vous débranchez un périphérique de stockage USB 2.0
321733  (http://support.microsoft.com/kb/321733/ ) Message d'erreur lorsque vous essayez d'écrire un fichier d'un ordinateur Windows XP ou Windows 2000 vers un serveur : « L'écriture différée a échoué »
831594  (http://support.microsoft.com/kb/831594/ ) Message d'erreur « L'écriture différée a échoué » lorsque vous essayez d'enregistrer un fichier ou lorsque vous essayez de quitter OneNote 2007 ou OneNote 2003
870894  (http://support.microsoft.com/kb/870894/ ) Un message d'erreur « L'écriture décalée a échoué » s'affiche dans Windows XP Service Pack 2 ou Windows XP Édition Tablet PC 2005
842520  (http://support.microsoft.com/kb/842520/ ) Le message d'erreur « L'écriture différée a échoué » s'affiche après l'enregistrement d'un fichier sous Windows XP (en anglais)
Si ces articles ne permettent pas de résoudre le message d'erreur, passez à la section « Étapes suivantes ».

ÉTAPES SUIVANTES

Si ces méthodes n'ont pas fonctionné sur votre ordinateur, vous pouvez utiliser le site Web Services de support client Microsoft pour trouver d'autres solutions à votre problème. Les services offerts sur ce site comprennent notamment :
  • Base de connaissances offrant des fonctions de recherche (http://support.microsoft.com/search/?adv=1)  : recherchez des informations de support technique et des outils d'auto-assistance pour les produits Microsoft.
  • Centres de solutions (http://support.microsoft.com/select/?target=hub)  : consultez les questions les plus fréquentes spécifiques au produit et les points principaux du support.
  • Groupes de discussion du Support client Microsoft (http://www.microsoft.com/communities/newsgroups/default.mspx)  : contactez vos homologues et les intervenants techniques MVP (Most Valuable Professionals) de Microsoft.
  • Autres options de support (http://support.microsoft.com/default.aspx?pr=csshome)  : posez vos questions en ligne, contactez les Services de support client Microsoft ou envoyez vos commentaires.
Si ces problèmes persistent, vous voudrez peut-être contacter le support technique :
http://support.microsoft.com/contactus (http://support.microsoft.com/contactus)

Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Édition familiale
Mots-clés : 
kbresolve kberrmsg kbprb KB330174
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