Dostanete chybové hlásenie, keď ukladania alebo premiestňovania dokumentov v systéme Windows XP: "Zlyhanie oneskoreného zápisu"

Preklady článku Preklady článku
ID článku: 330174 - Zobraziť produkty, ktorých sa tento článok týka.

Aby naďalej prijímať aktualizácie zabezpečenia pre systém Windows, uistite sa, že používate systém Windows XP s aktualizáciou Service Pack 3 (SP3). Ďalšie informácie nájdete na tejto webovej stránke spoločnosti Microsoft: Podpora sa končí pre niektoré verzie systému Windows

Rozbaliť všetko | Zbaliť všetko

Na tejto stránke

Príznaky

Ak ukladáte alebo presunúť veľkých dokumentov, alebo inak skúste správu súborov v systéme Windows XP, zobrazí prerušovane nasledovné chybové hlásenie:
Oneskorený zápis zlyhal.
Tento článok je určený pre stredne pokročilých a pokročilých používateľov.

Príčina

Táto chyba sa zvyčajne vyskytuje, keď je zapnutá funkcia "Povoliť zápis do medzipamäte na disku" na pevný disk.

Avšak, ak je vypnutý funkciu "Povoliť zápis do medzipamäte na disku", táto chyba môže nastať pretože radič pevného disku Ultra Direct Memory Access (UDMA) môže byť nakonfigurovaný jedným z nasledujúcich spôsobov:
  • Používate 40-vodičový kábel na pripojenie disku UDMA k radiču, namiesto požaduje 80-vodičového, 40-kolíkového kábla.
  • Systém BIOS je konfigurovaný na používanie rýchlejších režimov UDMA.
Ďalšie informácie o zlyhaní Oneskorený zápis, prejdite do časti "Chyba zápisu oneskorené informácie".

Riešenie

Ak chcete vyriešiť tento problém, najprv skontrolujte, či je zapnutá funkcia "Povoliť zápis do medzipamäte na disku". Ak je zapnutá, vypnite ju. Chcete urobiť, postupujte nasledovne.

Poznámka Ak vypnete funkciu "Povoliť zápis do medzipamäte na disku", pevný disk môže vykonávať pomalšie a môže ovplyvniť výkon systému počítača. Z tohto dôvodu budete chcieť sledovať výkon systému po vykonaní krokov uvedených v tomto oddiele.

Ak chcete vypnúť Povoliť ukladanie do medzipamäte na disku, postupujte nasledovne:
  1. Kliknite na tlačidlo Štart, a potom kliknite na tlačidlo Môj počítač.
  2. Kliknite pravým tlačidlom myši na pevný disk, a potom kliknite na tlačidlo Vlastnosti.
  3. Kliknite na tlačidlo Hardvér kartu.
  4. Kliknutím vyberte pevný disk, a potom kliknite na tlačidlo Vlastnosti.
  5. Kliknite na tlačidlo Podmienky kartu.
  6. Zrušte Povoliť ukladanie do medzipamäte na disku Začiarknite políčko a potom kliknite na tlačidlo ok.
  7. Kliknite na tlačidlo ok Zavrieť Lokálny Disk (C:) Vlastnosti dialógové okno.
  8. Opakujte kroky 3 až 5 pre každý pevný disk inštalovaný v počítači.
Ak tieto kroky vyriešiť chybové hlásenie, všetko je hotové.

Ak tieto kroky nevyriešia chybové hlásenie alebo ak funkcia je už vypnutý, prejdite do časti "Pokročilé tipy". Táto sekcia je určená pre skúsených používateľov počítača. Ak nie ste púšťať do pokročilého riešenia problémov, obráťte sa na podporu. Informácie o tom, ako to urobiť, nájdete na nasledujúcej webovej lokalite spoločnosti Microsoft:
http://support.Microsoft.com/contactus/

POKROČILÉ RIEŠENIE PROBLÉMOV

Uistite sa, že radič pevného disku je správne nakonfigurovaný

Uistite sa, že radič pevného disku je nakonfigurovaná správne, skontrolujte káblového pripojenia a nastavenia systému BIOS. Po prvé, skúste použiť metódu 1.

Metóda 1: Skontrolujte, či používate 80-vodičového, 40-kolíkového kábla

Uistite sa, že radič pevného disku UDMA je pomocou 80-vodičového, 40-kolíkového kábla. Informácie o tom, ako to urobiť, nájdete v dokumentácii dodanej s počítačom, alebo sa obráťte na výrobcu radiča pevného disku UDMA.

Ak používate 80-vodičového, 40-kolíkového kábla, prejdite na metódu 2.
Ak nepoužívate tento kábel, získať pomocou 80-vodičového, 40-kolíkového kábla a potom testovaním Zistite, či to rieši chybové hlásenie.

Ak to rieši chybové hlásenie, všetko je hotové.

Ak sa nevyrieši chybové hlásenie, prejdite na metódu 2.

Metóda 2: Skontrolujte nastavenia systému BIOS

Upozornenie Nemeňte nastavenie systému BIOS, ak nie ste veľmi dobre oboznámení so všetkými dôsledkami zmeny nastavenia systému BIOS.

Uistite sa, že nastavenia systému BIOS nie je konfigurovaný na používanie rýchlejších režimov UDMA. Informácie o tom, ako to urobiť, nájdete v dokumentácii dodanej s počítačom alebo kontaktujte výrobcu počítača.

Ak nie sú nakonfigurované nastavenia systému BIOS na master režimov UDMA, prejdite do časti "Oneskorené napísať zlyhanie informácie" informácie o dodatočné opatrenia, ktoré si môžete vziať zabrániť opakujúce sa hlásenie "Oneskorený napísať chyba".
Ak systém BIOS je konfigurovaný na master režimov UDMA, zmeniť nastavenia a potom testovaním Zistite, či to rieši chybové hlásenie.

Ak to rieši chybové hlásenie, všetko je hotové.

Ak sa nevyrieši chybového hlásenia, prejdite do časti "Oneskorené zápis zlyhanie informácií".

Oneskorený zápis zlyhanie informácie

Po kontrole káblového pripojenia a nastavenia systému BIOS, možno budete chcieť prijať dodatočné opatrenia na zabránenie "Oneskorený zápis" hlásenie neopakovali.

Oneskorený zápis zlyhanie môže vyskytnúť, ak údaje sú poškodené. Ak veľké vyrovnávacej pamäte systému funkcia povolená pre využitie pamäte v systéme Windows XP, môže dôjsť k poškodeniu údajov. Ak je táto funkcia zapnutá, počtu položiek stránkovacej tabuľky, ktoré systém Windows XP musí udržiavať môže zvýšiť, a v extrémnych prípadoch môže byť vyčerpané. Hoci tento problém sa nevyskytuje na všetkých systémoch, nasledujúce kľúčové faktory môžu spôsobiť poškodenie údajov:
  • Systémovej pamäte, ktorá je viac ako 512 MB (1 GB RAM je spoločná)
  • Veľké diskové zväzky NTFS a viacero veľkých zväzkov (60-100 GB disky, prípadne v diskových poliach RAID)
  • Grafická karta AGP s požiadavkami na veľké AGP prostriedkov (viac než predvolené AGP clony)
  • Prenosy veľkých súborov. Tento problém sa vyskytuje, keď v počítači nastane nedostatok položiek stránkovacej tabuľky systému. Pri spustení počítača, systém Windows Určuje predvolený počet položiek stránkovacej tabuľky na priradenie, podľa toho koľko systémovej pamäte je k dispozícii.
Aby nedošlo k poškodeniu údajov, uistite sa, že systém cache nie je vybratá pre využitie pamäte zakázaním funkcia vyrovnávacej pamäte systému. Chcete urobiť, prejdite do časti "Uistite sa, že systém Cache nie je vybratý pre využitie pamäte".

Uistite sa, že systém Cache nie je vybratý pre využitie pamäte

Ak ste prenos veľkých súborov, systém spustiť z položiek stránkovacej tabuľky systému, ktoré môžu spôsobiť chybové hlásenie "Oneskorený zápis zlyhanie". Aby sa zabránilo zvýšeniu počtu položiek stránkovacej tabuľky, ktoré systém Windows XP musí udržiavať a zabrániť tieto od vyčerpania, uistite sa, že pre využitie pamäte nie je vybratá možnosť vyrovnávacej pamäte systému. Chcete urobiť, postupujte nasledovne:
  1. Kliknite na tlačidlo Štart, kliknite pravým tlačidlom myši Môj počítač, a potom kliknite na tlačidlo Vlastnosti otvoriť Vlastnosti systému dialógové okno.
  2. Kliknite na tlačidlo Pokročilé kartu, a potom podľa Výkon, kliknite na tlačidlo nastavenia otvoriť Možností výkonu dialógové okno.
  3. Kliknite na tlačidlo Pokročilé kartu.
  4. Pod Využitie pamäte, kliknite na položku Programy, a potom kliknite na tlačidlo ok.
  5. Kliknite na tlačidlo ok Zavrieť Vlastnosti systému dialógové okno.
Ak tento postup pracoval, všetko je hotové.

Ak tento postup nefunguje pre vás, skúste riešenie.

Riešenie: Zvýšiť počet položiek stránkovacej tabuľky

Ak ste stále "Oneskorený zápis zlyhanie" chybových hlásení po pokuse metódy riešenia problémov v tomto článku, môže byť schopný obísť tento problém zvýšením počtu položiek stránkovacej tabuľky systému k dispozícii. Chcete urobiť, postupujte nasledovne.

Dôležité Táto sekcia, metóda alebo úloha obsahuje kroky, ktoré vám povedať, ako upraviť databázu registry. Avšak, môžu spôsobiť vážne problémy ak databázu registrov upravíte nesprávne. Preto sa uistite, že ste postupovali správne. Doporučujeme zálohovať databázu registrov skôr, ako zmeníte jej hodnoty. Potom, môžete obnoviť databázu registrov, ak sa vyskytne problém. Ďalšie informácie o zálohovaní a obnovení databázy registrov nájdete po kliknutí na nasledovné číslo článku publikovaného v Microsoft Knowledge Base:
322756 Ako zálohovať a obnoviť databázu registry v systéme Windows
  1. Kliknite na tlačidlo Štart, kliknite na tlačidlo Spustiť, typ regedit, a potom kliknite na tlačidlo ok.
  2. Vyhľadajte nasledovný kľúč databázy registry:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory riadenie
  3. V table s podrobnosťami kliknite pravým tlačidlom myši SystemPages hodnotu, a potom kliknite naUpraviť
    PoznámkaPredvolená hodnota je 0 (šestnástkovo)
    .
  4. V Hodnota údajov poľa zadajte 7FFF, a potom kliknite na tlačidlo ok.
    Poznámka Môžete skúsiť pomocou alternatívnej nasledovné hodnoty:
    • 7FFF = 32.000
    • PTEs BFFF = 50.000
    • PTEs 24FFF = 150.000 PTEs

    Poznámka Hodnota FFFFFFFF sa nepoužívajú. Ak nastavíte príliš vysoké, môže vám dôjdu nastránkovanej pamäte.
  5. Editor databázy Registry výstupu.
  6. Reštart
  7. Sledovať pamäte \ zadarmo položiek na stránku tabuľky systému v Perfmon.
Ak toto riešenie nedokázalo vyriešiť chybové hlásenie, môžete skontrolovať v sekcii "Podobné problémy a riešenia", alebo kontaktovať technickú podporu. Informácie o kontaktovaní technickej podpory, prejdite na časť "Ďalšie kroky".

PODOBNÉ PROBLÉMY A RIEŠENIA

Ak tento článok sa nezaoberá váš problém, zistíte, že máte podobný problém, alebo, že váš problém možno riešiť ďalší článok. Ak sa zobrazí chybové hlásenie "Súbor uzamknutý" alebo "Prístup odmietnutý", prejdite do časti "informácie o uzamknutie súboru alebo prístup bol odmietnutý". Pre viac podobné problémy, prejdite do časti "Ďalšie informácie".

Uzamknutie súboru alebo odmietnutý prístup informácie

Ak sa pokúsite otvoriť súbor, ktorý je uložený v sieti, a potom skúste uložiť zmeny v súbore, alebo ak otvoríte súbor ako zošit programu Excel pomocou univerzálne pomenovanie konvencie UNC cesta, mô?ete dosta uzamknutie súboru alebo chybové hlásenie o odmietnutí prístupu.Ďalšie informácie o uzamknutie súboru alebo prístup odmietnutý chybové hlásenia po uložení súboru na cestu UNC, kliknite na nasledovné číslo článku publikovaného v databáze Microsoft Knowledge Base:
812937Podať uzamknutia alebo prístup odmietnutý, chybové hlásenie pri ukladaní súboru prostredníctvom sieť

Ďalšie informácie

Ďalšie informácie nájdete kliknite na nasledovné čísla článkov, čím zobrazíte články v databáze Microsoft Knowledge Base:
818788Chybové hlásenie "{neúspešný odložený zápisnicu}" pri vami odpojte pamäťové zariadenie USB 2.0
321733 Chybové hlásenie pri zápise súboru na server z Windows XP-založené alebo počítač so systémom Windows 2000: "Zlyhanie oneskoreného zápisu"
831594 Pri pokuse o uloženie súboru alebo programu OneNote 2007 alebo program OneNote 2003 sa zobrazí chybové hlásenie "Oneskorený zápis zlyhal"
870894 "Zlyhanie oneskoreného zápisu" chybové hlásenie v systéme Windows XP Service Pack 2 alebo Windows XP Tablet PC Edition 2005
842520 "Oneskorený zápis zlyhal" chyba sa môže vyskytnúť po uložení súboru v systéme Windows XP
Ak tieto články vyriešiť chybové hlásenie, prejdite do časti "Ďalšie kroky".

ĎALŠIE KROKY

Ak tieto metódy nefunguje pre vás, môžete použiť Microsoft zákaznícky podporu služby webové stránky nájsť iné riešenia vášho problému. Niektoré služby, ktoré poskytujú Microsoft zákaznícky podporu služby webové stránky patria:
  • Databáza Knowledge Base: Vyhľadávanie informácií technickej podpory a svojpomocných nástrojov pre produkty spoločnosti Microsoft.
  • Centrá riešení: Zobrazenie výrobkovo často kladené otázky a tipy služby technickej podpory.
  • Ďalšie možnosti podpory: Použite Web položiť otázku, kontaktujte službu podpory zákazníkov spoločnosti Microsoft alebo poskytnúť spätnú väzbu.
Ak máte neustále problémy, môžete kontaktovať technickú podporu:
http://support.Microsoft.com/contactus

Vlastnosti

ID článku: 330174 - Posledná kontrola: 15. novembra 2012 - Revízia: 1.0
Informácie v tomto článku sa týkajú nasledujúcich produktov:
  • Microsoft Windows XP Professional Edition
  • Microsoft Windows XP Home Edition
Kľúčové slová: 
kbresolve kberrmsg kbprb kbmt KB330174 KbMtsk
Strojovo preložené
DÔLEŽITÉ: Tento článok bol preložený pomocou softvéru na strojový preklad od spoločnosti Microsoft, nie prekladateľom. Spoločnosť Microsoft ponúka články preložené prekladateľmi aj strojovo preložené články, vďaka čomu máte možnosť prístupu ku všetkým článkom databázy Knowledge Base vo svojom jazyku. Strojovo preložený článok však nie je vždy perfektný. Môže obsahovať chyby týkajúce sa slovnej zásoby, syntaxe alebo gramatiky, podobne ako cudzinec môže robiť chyby, keď rozpráva vašim jazykom. Spoločnosť Microsoft nenesie zodpovednosť za akékoľvek nepresnosti, chyby alebo škody spôsobené akýmkoľvek nepresným prekladom obsahu alebo jeho použitím zo strany zákazníkov. Spoločnosť Microsoft softvér na strojový preklad pravidelne aktualizuje.
Pokiaľ chcete vidieť anglickú verziu článku, kliknite sem: 330174

Odošlite odozvu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com