คุณได้รับข้อผิดพลาดเมื่อคุณบันทึก หรือย้ายเอกสารใน Windows XP: "การเขียนล่าช้าล้มเหลว"

การแปลบทความ การแปลบทความ
หมายเลขบทความ (Article ID): 330174 - ผลิตภัณฑ์ที่เกี่ยวข้องในบทความนี้
ขยายทั้งหมด | ยุบทั้งหมด

เนื้อหาบนหน้านี้

อาการ

เมื่อคุณบันทึก หรือย้ายเอกสารขนาดใหญ่ หรือมิฉะนั้น พยายามจัดการแฟ้มของคุณใน Windows XP คุณเป็นระยะ ๆ รับข้อความแสดงข้อผิดพลาดต่อไปนี้:
การเขียนล่าช้าล้มเหลว
บทความนี้มีไว้สำหรับผู้ใช้ระดับปานกลางถึงขั้นสูง

สาเหตุ

ข้อผิดพลาดนี้ปกติเกิดขึ้นเมื่อเปิดคุณลักษณะ "เปิดใช้งานเขียนแคชบนดิสก์" สำหรับฮาร์ดดิสก์ของคุณ

อย่างไรก็ตาม ถ้าคุณลักษณะ "เปิดใช้งานเขียนแคชบนดิสก์" ปิด ข้อผิดพลาดนี้สามารถเกิดขึ้นได้เนื่องจากตัวควบคุมฮาร์ดดิสก์ Ultra ตรงหน่วยความจำเข้า (UDMA) อาจถูกกำหนดค่าในอย่างใดอย่างหนึ่งต่อไปนี้:
  • คุณใช้สายไฟ 40 สายเพื่อเชื่อมต่อไดรฟ์ UDMA กับตัวควบคุมแทนสายเคเบิล เส้น 80, 40 pin จำเป็น
  • การตั้งค่า BIOS ถูกกำหนดค่าให้บังคับใช้โหมด UDMA ที่เร็วกว่า
สำหรับข้อมูลเพิ่มเติมเกี่ยวกับความล้มเหลวในการเขียนล่าช้า ไปที่ส่วน "ข้อมูลความล้มเหลวในการเขียน Delayed"

การแก้ไข

เมื่อต้องการแก้ไขปัญหานี้ แรกตรวจว่า คุณลักษณะ "เปิดใช้งานเขียนแคชบนดิสก์" เปิดอยู่ ถ้ามีเปิดเครื่อง ปิด เมื่อต้องการทำเช่นนี้ ให้ทำตามขั้นตอนเหล่านี้

หมายเหตุ ถ้าคุณปิดคุณลักษณะ "เปิดใช้งานเขียนแคชบนดิสก์" ฮาร์ดดิสก์ของคุณอาจทำงานช้า และอาจส่งผลกระทบต่อประสิทธิภาพของระบบโดยรวมที่คอมพิวเตอร์ของคุณ ด้วยเหตุนี้ คุณอาจต้องการตรวจสอบประสิทธิภาพของระบบหลังจากคุณทำตามขั้นตอนในส่วนนี้

เมื่อต้องการปิดการเปิดใช้งานการเขียนแคชบนดิสก์ให้ทำตามขั้นตอนเหล่านี้:
  1. คลิกเริ่มแล้ว คลิ กคอมพิวเตอร์ของฉัน
  2. คลิกขวาฮาร์ดดิสก์ และจากนั้น คลิกคุณสมบัติ
  3. คลิกแท็บฮาร์ดแวร์
  4. คลิกเลือกฮาร์ดดิสก์ และจากนั้น คลิกคุณสมบัติ
  5. คลิกแท็บนโยบาย
  6. คลิกเพื่อล้างกล่องกาเครื่องหมายเปิดใช้งานการเขียนแคชบนดิสก์และจากนั้น คลิกตกลง
  7. คลิกตกลงเพื่อปิดการLocal Disk (c:) คุณสมบัติกล่องโต้ตอบ
  8. ทำซ้ำขั้นตอนที่ 3 ถึง 5 สำหรับแต่ละฮาร์ดดิสก์ที่ติดตั้งในคอมพิวเตอร์ของคุณ
หากขั้นตอนเหล่านี้สามารถแก้ไขข้อผิดพลาด คุณทำเสร็จแล้ว

หากขั้นตอนเหล่านี้ไม่สามารถแก้ไขข้อผิดพลาด หรือคุณลักษณะมีอยู่แล้วปิด ไปที่ส่วน "แก้ไขปัญหาขั้นสูง" ส่วนนี้มีไว้สำหรับผู้ใช้คอมพิวเตอร์ขั้นสูง หากคุณไม่สะดวกในการแก้ไขปัญหาขั้นสูง ติดต่อฝ่ายสนับสนุน สำหรับข้อมูลเกี่ยวกับวิธีการทำเช่นนี้ แวะไปที่เว็บไซต์ต่อไปนี้ของ Microsoft:
http://support.microsoft.com/contactus/

การแก้ไขปัญหาขั้นสูง

ตรวจสอบให้แน่ใจว่า ตัวควบคุมฮาร์ดดิสก์ถูกกำหนดค่าอย่างถูกต้อง

เพื่อตรวจสอบให้แน่ใจว่า ตัวควบคุมฮาร์ดดิสก์ถูกกำหนดค่าอย่างถูกต้อง ตรวจสอบการเชื่อมต่อสายเคเบิลและการตั้งค่า BIOS ขั้นแรก ให้คุณลองวิธีที่ 1

วิธีที่ 1: ตรวจสอบว่า คุณกำลังใช้สายเคเบิลผิด 80 เส้น 40 pin

ตรวจสอบให้แน่ใจว่า ตัวควบคุมฮาร์ดดิสก์ UDMA ของคุณใช้สายเคเบิลผิด 80 เส้น 40 pin สำหรับข้อมูลเกี่ยวกับวิธีการทำเช่นนี้ ให้ดูเอกสารประกอบที่มาพร้อมกับคอมพิวเตอร์ของคุณ หรือติดต่อผู้ผลิตตัวควบคุมฮาร์ดดิสก์ UDMA

ถ้าคุณกำลังใช้สายเคเบิลผิด 80 เส้น 40 pin ไปที่วิธีที่ 2
ถ้าคุณไม่ได้ใช้สายเคเบิลนี้ ได้รับ และใช้สายเคเบิลผิด 80 เส้น 40 pin และทดสอบเพื่อดูว่า สามารถแก้ไขข้อผิดพลาด

ถ้าสามารถแก้ไขข้อผิดพลาด คุณทำเสร็จแล้ว

ถ้าไม่สามารถแก้ไขข้อความแสดงข้อผิดพลาดได้ ไปที่วิธีที่ 2

วิธีที่ 2: ตรวจสอบการตั้งค่า BIOS

คำเตือน เปลี่ยนการตั้งค่า BIOS เว้นแต่คุณจะเข้าใจผลกระทบทั้งหมดของการเปลี่ยนแปลงการตั้งค่า BIOS

ตรวจสอบให้แน่ใจว่า การตั้งค่า BIOS ถูกกำหนดค่าให้บังคับใช้โหมด UDMA ที่เร็วกว่าไม่ สำหรับข้อมูลเกี่ยวกับวิธีการทำเช่นนี้ ให้ดูเอกสารประกอบที่มาพร้อมกับคอมพิวเตอร์ของคุณ หรือติดต่อผู้ผลิตคอมพิวเตอร์ของคุณ

ถ้ามีการตั้งค่า BIOS ถูกกำหนดค่าให้บังคับใช้โหมด UDMA หลัก ไปที่ส่วน "Delayed เขียนข้อมูลความล้มเหลว" สำหรับข้อมูลเกี่ยวกับการวัดที่เพิ่มเติมซึ่งคุณสามารถใช้เพื่อป้องกันไม่ให้ข้อความ "ล่าช้าเขียนข้อผิดพลาด" เกิด ขึ้น
ถ้ามีการตั้งค่า BIOS ถูกกำหนดค่าให้บังคับใช้โหมด UDMA หลัก เปลี่ยนการตั้งค่า และทดสอบเพื่อดูว่า สามารถแก้ไขข้อผิดพลาด

ถ้าสามารถแก้ไขข้อผิดพลาด คุณทำเสร็จแล้ว

ถ้าไม่สามารถแก้ไขข้อความแสดงข้อผิดพลาดได้ ไปที่ส่วน "Delayed เขียนข้อมูลความล้มเหลว"

รายละเอียดความล้มเหลวการเขียนล่าช้า

หลังจากที่คุณตรวจสอบการเชื่อมต่อสายเคเบิลและการตั้งค่า BIOS คุณอาจจะใช้มาตรการเพิ่มเติมเมื่อต้องการป้องกันไม่ให้ข้อความ "ล่าช้าเขียนข้อผิดพลาด" ที่เกิดซ้ำ

มีความล้มเหลวในการเขียนล่าช้าอาจเกิดข้อมูลเสียหาย ความเสียหายของข้อมูลอาจเกิดขึ้นหากเปิดใช้งานคุณลักษณะการแคชของระบบขนาดใหญ่สำหรับการใช้งานหน่วยความจำใน Windows XP ถ้าคุณลักษณะนี้ถูกเปิดใช้งาน จำนวนรายการตารางเพที่ Windows XP ต้องเก็บรักษาอาจเพิ่ม และ ใน กรณีที่รุนแรง อาจจะหมดแล้ว แม้ว่าปัญหานี้เกิดขึ้นกับทุกระบบ ปัจจัยสำคัญต่อไปนี้อาจทำให้ข้อมูลเสียหาย:
  • หน่วยความจำระบบที่มากกว่า 512 เมกะไบต์ (1 กิกะไบต์ของ RAM เป็นปกติ)
  • ไดรฟ์ข้อมูลดิสก์ NTFS ขนาดใหญ่และขนาดใหญ่หลายไดรฟ์ (กิกะไบต์ 60-100 ฮาร์ดไดรฟ์ อาจอยู่ในอาร์เรย์ RAID)
  • กราฟิก AGP ด้วยความใหญ่ AGP ต้องการทรัพยากร (มากกว่าความไวแสง AGP ค่าเริ่มต้น)
  • การถ่ายโอนแฟ้มขนาดใหญ่ ปัญหานี้เกิดขึ้นเมื่อคอมพิวเตอร์ออกจากรายการตารางเพจของระบบ เมื่อคอมพิวเตอร์เริ่มต้น Windows กำหนดจำนวนรายการตารางเพเพื่อกำหนด เริ่มต้นขึ้นอยู่กับจำนวนหน่วยความจำระบบจะพร้อมใช้งานหรือไม่
เพื่อหลีกเลี่ยงความเสียหายของข้อมูล โปรดตรวจสอบให้แน่ใจว่า แคชของระบบที่ไม่ได้เลือกสำหรับการใช้งานหน่วยความจำ โดยการปิดใช้งานคุณลักษณะการแคชของระบบ เมื่อต้องการทำเช่นนี้ ไปที่ส่วน "ตรวจสอบให้แน่ใจว่า แคชของระบบไม่ได้ถูกเลือกสำหรับการใช้งานหน่วยความจำ"

ตรวจสอบให้แน่ใจว่า แคชของระบบไม่ได้ถูกเลือกสำหรับการใช้งานหน่วยความจำ

ถ้าคุณกำลังถ่ายโอนแฟ้มขนาดใหญ่ ระบบอาจเรียกใช้ออกจากระบบรายการตารางเพ ซึ่งอาจทำให้เกิดข้อผิดพลาด "ถูกหน่วงเวลาล้มเหลวเขียนออก" เมื่อต้อง การป้องกันการเพิ่มจำนวนรายการตารางเพที่ Windows XP ต้องเก็บรักษา และ การป้องกันเหล่านี้จากการดำเนินขั้น ตรวจสอบให้แน่ใจว่า ตัวเลือกแคชของระบบไม่ได้ถูกเลือกสำหรับการใช้หน่วยความจำ ในการดำเนินการดังกล่าว ให้ทำตามขั้นตอนต่อไปนี้
  1. คลิกเริ่มคลิกขวาที่My Computerและจากนั้น คลิกคุณสมบัติเพื่อเปิดกล่องโต้ตอบ'คุณสมบัติของระบบ'
  2. คลิกแท็บขั้นสูงและภายใต้ประสิทธิภาพการทำงานคลิกที่การตั้งค่าเพื่อเปิดกล่องโต้ตอบตัวเลือกประสิทธิภาพการทำงาน
  3. คลิกที่แท็บ'ขั้นสูง'
  4. ภายใต้การใช้หน่วยความจำคลิกเลือกโปรแกรมและจากนั้น คลิกตกลง
  5. คลิกตกลงเพื่อปิดกล่องโต้ตอบ'คุณสมบัติของระบบ'
ถ้าขั้นตอนเหล่านี้ทำงาน คุณได้เสร็จสิ้น

ถ้าขั้นตอนเหล่านี้ไม่ได้ผลสำหรับคุณ ลองวิธีแก้ปัญหานี้

วิธีแก้ปัญหา: เพิ่มจำนวนรายการตารางเพจ

ถ้าคุณยังได้รับข้อความแสดงข้อผิดพลาด "ถูกหน่วงเวลาล้มเหลวเขียนออก" หลังจากที่คุณลองใช้วิธีการแก้ไขปัญหาในบทความนี้ คุณอาจสามารถหลีกเลี่ยงปัญหานี้ โดยการเพิ่มจำนวนรายการตารางเพที่พร้อมใช้งานสำหรับระบบ เมื่อต้องการทำเช่นนี้ ให้ทำตามขั้นตอนเหล่านี้

สิ่งสำคัญ ส่วน วิธีการ หรืองานนี้ประกอบด้วยขั้นตอนที่บอกให้คุณทราบวิธีการปรับเปลี่ยนรีจิสทรี อย่างไรก็ตาม ปัญหาร้ายแรงอาจเกิดขึ้นหากคุณปรับเปลี่ยนรีจิสทรีอย่างไม่ถูกต้อง ดังนั้น ตรวจสอบให้แน่ใจว่า คุณทำตามขั้นตอนเหล่านี้อย่างระมัดระวัง สำหรับการป้องกันเพิ่มเติม ให้สำรองข้อมูลรีจิสทรีก่อนที่คุณจะปรับเปลี่ยน จากนั้นคุณจะสามารถคืนค่ารีจิสทรีได้หากเกิดปัญหา สำหรับข้อมูลเพิ่มเติมเกี่ยวกับวิธีการสำรอง และคืนค่ารีจิสทรี คลิกหมายเลขบทความต่อไปนี้เพื่อดูบทความในฐานความรู้ของ Microsoft:
322756 วิธีการสำรอง และคืนค่ารีจิสทรีใน Windows
  1. คลิกเริ่มคลิกเรียกใช้ชนิด regeditและ thenclickตกลง
  2. ค้นหารีจิสทรีคีย์ต่อไปนี้:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management
  3. ในบานหน้าต่างรายละเอียด คลิกขวาค่าSystemPagesและจากนั้น คลิกปรับเปลี่ยน
    หมายเหตุค่าเริ่มต้นคือ 0 (ฐานสิบหก)
    .
  4. ในกล่องValue dataพิมพ์ 7FFFแล้ว คลิกตกลง
    หมายเหตุ คุณอาจลองใช้ค่าอื่นต่อไปนี้:
    • 7FFF = 32000
    • PTEsBFFF = 50000
    • PTEs24FFF = 150,000 PTEs

    หมายเหตุ ไม่ควรใช้ค่า FFFFFFFF ถ้าคุณตั้งค่าสูงเกินไป คุณอาจเรียกใช้หน่วยความจำเพจพูล
  5. ออกจาก Registry Editor
  6. รีสตาร์ท
  7. ตรวจสอบหน่วยความจำ \ รายการตารางเพระบบใน Perfmon อิสระ
หากวิธีนี้ไม่สามารถแก้ไขข้อความข้อผิดพลาด คุณอาจต้องการตรวจทานแก้ไขปัญหาในส่วนของ "คล้ายปัญหาและโซลูชัน" หรือติดต่อฝ่ายสนับสนุน สำหรับข้อมูลเกี่ยวกับวิธีการติดต่อฝ่ายสนับสนุน ไปส่วน "ขั้นตอนถัดไป"

ปัญหาที่คล้ายกันและวิธีแก้ไขปัญหา

หากบทความนี้ไม่แก้ไขปัญหาของคุณ คุณอาจพบว่า คุณมีปัญหาที่คล้ายคลึงกัน หรือว่า สามารถแก้ไขปัญหาของคุณ โดยบทความอื่น ถ้าคุณได้รับข้อความแสดงข้อผิดพลาด "แฟ้มถูกล็อก" หรือ "Access Denied" ไปที่ส่วน "ข้อมูลการล็อกแฟ้มหรือการเข้าถึงถูกปฏิเสธ" สำหรับปัญหาที่คล้ายกันมาก ไปที่ส่วน "ข้อมูลเพิ่มเติม"

ข้อมูลการล็อกแฟ้มหรือการเข้าถึงถูกปฏิเสธ

ถ้าคุณพยายามที่จะเปิดแฟ้มที่เก็บอยู่บนเครือข่าย และพยายามบันทึกการเปลี่ยนแปลงไปยังแฟ้ม หรือ ถ้าคุณเปิดแฟ้มเช่นสมุดงาน Microsoft Excel โดยใช้เส้นทาง (UNC) แบบแผนการตั้งชื่อสากล คุณอาจได้รับการล็อกแฟ้มหรือการเข้าถึงถูกปฏิเสธข้อความแสดงข้อผิดพลาดสำหรับข้อมูลเพิ่มเติมเกี่ยวกับการล็อกแฟ้มหรือการเข้าถึงถูกปฏิเสธข้อผิดพลาดเมื่อคุณบันทึกแฟ้มในเส้นทาง UNC คลิกหมายเลขบทความต่อไปนี้เพื่อดูบทความในฐานความรู้ของ Microsoft:
812937 การล็อกแฟ้มหรือการเข้าถึงปฏิเสธข้อผิดพลาดเมื่อคุณบันทึกแฟ้มในเครือข่าย

ข้อมูลเพิ่มเติม

สำหรับข้อมูลเพิ่มเติม คลิกหมายเลขบทความต่อไปนี้เพื่อดูบทความในฐานความรู้ของ Microsoft:
818788 ข้อความแสดงข้อผิดพลาด "{ช้าเขียนล้มเหลว}" เมื่อคุณถอดอุปกรณ์เก็บข้อมูล USB 2.0
321733 ข้อความแสดงข้อผิดพลาดเมื่อคุณเขียนแฟ้มไปยังเซิร์ฟเวอร์ที่ใช้ Windows XP หรือคอมพิวเตอร์ที่ใช้ Windows 2000: "การเขียนล่าช้าล้มเหลว"
831594 ข้อความแสดงข้อผิดพลาด "ถูกหน่วงเวลาล้มเหลวเขียน" เมื่อคุณพยายาม จะบันทึกแฟ้ม หรือออกจาก OneNote 2007 หรือ OneNote 2003
870894 คุณได้รับข้อความแสดงข้อผิดพลาด "การเขียนล่าช้าล้มเหลว" ใน Windows XP Service Pack 2 หรือ Windows XP ข้อมูลแท็บเล็ตพีซี Edition 2005
842520 ข้อผิดพลาด "ถูกหน่วงเวลาล้มเหลวเขียน" อาจเกิดขึ้นหลังจากที่คุณบันทึกแฟ้มใน Windows XP
หากบทความเหล่านี้ไม่สามารถแก้ไขข้อผิดพลาด ให้ไปส่วน "ขั้นตอนถัดไป"

ขั้นตอนถัดไป

ถ้าวิธีการเหล่านี้ไม่ได้ผลสำหรับคุณ คุณสามารถใช้เว็บไซต์บริการสนับสนุนลูกค้าของ Microsoft เพื่อค้นหาวิธีแก้ไขปัญหาอื่น ๆ กับปัญหาของคุณ บริการบางอย่างที่เว็บไซต์บริการสนับสนุนลูกค้าของ Microsoft จัดให้มีดังนี้: หากคุณยังประสบปัญหา คุณอาจต้องติดต่อฝ่ายสนับสนุน:
http://support.microsoft.com/contactus/

คุณสมบัติ

หมายเลขบทความ (Article ID): 330174 - รีวิวครั้งสุดท้าย: 23 พฤศจิกายน 2556 - Revision: 3.0
ใช้กับ
  • Microsoft Windows XP Professional Edition
  • Microsoft Windows XP Home Edition
Keywords: 
kbresolve kberrmsg kbprb kbmt KB330174 KbMtth
แปลโดยคอมพิวเตอร์
ข้อมูลสำคัญ: บทความนี้แปลโดยซอฟต์แวร์การแปลด้วยคอมพิวเตอร์ของ Microsoft แทนที่จะเป็นนักแปลที่เป็นบุคคล Microsoft มีบทความที่แปลโดยนักแปลและบทความที่แปลด้วยคอมพิวเตอร์ เพื่อให้คุณสามารถเข้าถึงบทความทั้งหมดในฐานความรู้ของเรา ในภาษาของคุณเอง อย่างไรก็ตาม บทความที่แปลด้วยคอมพิวเตอร์นั้นอาจมีข้อบกพร่อง โดยอาจมีข้อผิดพลาดในคำศัพท์ รูปแบบการใช้ภาษาและไวยากรณ์ เช่นเดียวกับกรณีที่ชาวต่างชาติพูดผิดเมื่อพูดภาษาของคุณ Microsoft ไม่มีส่วนรับผิดชอบต่อความคลาดเคลื่อน ความผิดพลาดหรือความเสียหายที่เกิดจากการแปลเนื้อหาผิดพลาด หรือการใช้บทแปลของลูกค้า และ Microsoft มีการปรับปรุงซอฟต์แวร์การแปลด้วยคอมพิวเตอร์อยู่เป็นประจำ
ต่อไปนี้เป็นฉบับภาษาอังกฤษของบทความนี้:330174

ให้ข้อเสนอแนะ

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com