Cómo solucionar problemas de un "Código de error de detención 0x0000007E (SYSTEM_THREAD_EXCEPTION_NOT_HANDLED)" en Windows XP

Seleccione idioma Seleccione idioma
Id. de artículo: 330182 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

En esta página

Síntomas

Después de actualizar el equipo a Windows XP, puede que aparezca el siguiente mensaje de error Stop al iniciarse el equipo:
STOP: 0x0000007E (0xC0000005, 0x804E518E, 0xFC938104, 0xFC937E04)
SYSTEM_THREAD_EXCEPTION_NOT_HANDLED

WUSB54GCx86.sys- Address 92D89498 base at 92D7c000, Datestamp 45c04cc9
Nota Los parámetros y los nombres de archivo de este mensaje de error pueden variar dependiendo de la causa del error. El nombre de archivo de la segunda línea del mensaje de error, WUSB54GCx86.sys, es un ejemplo de archivo de controlador que puede que esté provocando el error.

En este artículo se explican siete método para resolver el problema. El primer método está destinado a usuarios principiantes o de nivel medio. Los otros seis métodos están destinados a usuarios avanzados.

Dado que este artículo contiene pasos que implican el reinicio del equipo, puede que le resulte más sencillo seguir los pasos si imprime primero el artículo.

Causa

Este problema puede producirse si un subproceso del sistema genera una excepción que el controlador de errores no intercepta. La causa de esta excepción puede ser alguna de las siguientes:
  • Si el problema se produce después del primer reinicio durante la instalación de Windows, o cuando el programa de instalación ha finalizado, es posible que el equipo no tenga suficiente espacio en disco duro para ejecutar Windows XP.
  • Puede que el BIOS del equipo no sea compatible con Windows XP o deba actualizarse.
  • Puede que los controladores de adaptador de vídeo no sean compatibles con Windows XP.
  • Puede que el controlador de dispositivo o algún servicio del sistema esté dañado.
  • Si el problema está relacionado con el archivo Win32k.sys, puede estar causado por un programa de control remoto de otro proveedor.

Solución

Uso de la herramienta Informe de errores de Windows

Puede usar la herramienta Informe de errores de Windows para enviarnos información acerca del error y para obtener información acerca de cualquier revisión o solución alternativa disponible. Siga estos pasos para usar la herramienta Informe de errores de Windows:
  1. Cuando aparece la ventana Informe de errores de Windows en el equipo, haga clic en Enviar informe de error para enviarnos el error.
  2. En la ventana de confirmación que aparece después de enviarnos el error, haga clic en Más información. De esto modo, le será más fácil encontrar revisiones disponibles para el problema o información acerca de cómo resolverlo.
  3. Si no hay disponible ninguna revisión o solución temporal, puede utilizar la sección "Solución avanzada de problemas" para intentar resolver este problema. Si no se siente cómodo con la solución avanzada de problemas, puede ponerse en contacto con el soporte técnico. Para obtener información acerca de cómo ponerse en contacto con el servicio de soporte técnico, visite el siguiente sitio web de Microsoft:
    http://support.microsoft.com/contactus/?ln=es#tab0

Solución avanzada de problemas

Use los métodos siguientes en el orden en que aparecen.

Método 1: asegurarse de que tiene suficiente espacio en el disco duro

Primero, asegúrese de que tiene suficiente espacio en el disco duro. El error Stop puede estar provocado por un espacio en disco duro insuficiente.

Si puede usar el modo seguro o la Consola de recuperación para iniciar el equipo, elimine cualquier archivo temporal que no necesite, archivos de caché de Internet, archivos de copia de seguridad de programas y archivos que contengan fragmentos de archivos guardados de exploraciones de disco (archivos .chk). También puede instalar Windows XP en otro disco duro que tenga más espacio libre.

Si no puede iniciar el equipo, vaya al siguiente método para actualizar el BIOS del mismo.

Para obtener más información acerca de cómo usar el modo seguro o la consola de recuperación, haga clic en los números de artículo siguientes para verlos en Microsoft Knowledge Base:
315222 Descripción de las opciones de inicio en modo seguro en Windows XP
314058 Cómo habilitar la Consola de recuperación de Windows XP para usuarios avanzados

Método 2: actualizar el BIOS del equipo

Si la liberación de espacio del disco duro no resuelve el problema, puede que sea necesario actualizar el BIOS. Use los artículos de información de contacto de los proveedores de hardware y software que aparecen en la sección "Referencias" para ponerse en contacto con el fabricante del equipo con objeto de obtener la actualización más reciente del BIOS.

Nota Al actualizar el BIOS, puede que tenga que deshabilitar temporalmente las opciones de memoria del BIOS, como almacenamiento en caché o vigilancia.

Método 3: deshabilitar o actualizar los controladores de dispositivo

Si ha actualizado correctamente el BIOS y el problema persiste, puede que tenga que actualizar o deshabilitar los controladores de adaptador de vídeo del equipo. Siga estos pasos para solucionar problemas de controladores de adaptador de vídeo:
  1. Si en el mensaje de error Stop se indica el nombre de un controlador, deshabilite o quite ese controlador.
    • Si el error se produce durante la secuencia de inicio y la partición del sistema utiliza el sistema de archivos NTFS, debe poder utilizar el modo seguro para cambiar el nombre o eliminar el controlador defectuoso.
    • Si el controlador se utiliza como parte del proceso de inicio del sistema en el modo seguro, debe iniciar el equipo con la Consola de recuperación.
  2. Si los mensajes de error Stop no indican un controlador concreto, actualice los controladores de adaptador de vídeo con la última versión.
  3. Deshabilite o quite cualquier controlador o servicio que haya agregado recientemente.
  4. Compruebe la Lista de compatibilidad de hardware (HCL) de Microsoft para determinar si los dispositivos PCI del equipo son compatibles con Windows XP. Para obtener más información acerca de HCL, visite el siguiente sitio web de Microsoft:
    http://www.microsoft.com/es-es/windows/compatibility/win8/CompatCenter/Home?Language=es-es

Método 4: quitar controladores no firmados

Si ha actualizado los controladores de adaptador de vídeo y el problema persiste, o si no puede iniciar Windows en modo seguro, puede que el problema se deba a un controlador no firmado diferente. Quite todos los controladores que no estén firmados digitalmente por Microsoft. Para obtener más información acerca de cómo hacerlo, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
316434 Cómo realizar la solución de problemas avanzados de inicio limpio en Windows XP

Método 5: quitar todos los controladores de terceros

Puede que no le sea posible determinar qué controlador de terceros provoca el error. Si al quitar los controladores no firmados no se resuelve el problema, pruebe a mover todos los archivos de controladores de terceros de la carpeta %Windir%\System32\Drivers a una ubicación distinta. Siga estos pasos para mover los archivos de controladores de terceros:
  1. Utilice la consola de recuperación para iniciar el equipo o inicie el equipo desde una instalación de Windows diferente si ha realizado una instalación paralela de Windows.
  2. Cree una carpeta temporal para guardar los archivos de controladores. Por ejemplo, puede crear la carpeta c:\ContrTemp.
  3. Mueva todos los archivos que no tengan fecha de creación 8/13/2001 para Windows XP de la carpeta %Windir%\System32\Drivers a una carpeta temporal creada en el paso 2.

    Precaución Si el equipo usa controladores IDE o SCSI de terceros para un funcionamiento correcto, debe identificar los archivos de los correspondientes controladores y mantenerlos en la carpeta %Windir%\System32\Drivers.
  4. Reinicie el equipo.
  5. Continúe con el programa de instalación de Windows. Puede devolver los archivos de controladores al equipo una vez que se identifique el controlador defectuoso.

Método 6: quitar los servicios de control remoto de terceros

Si sigue teniendo problemas tras aplicar los métodos anteriores y el mensaje de error Stop contiene el nombre de archivo Win32k.sys en lugar de un nombre de archivo de controlador, puede que el problema esté provocado por un programa de control remoto de terceros. Para quitar el servicio, utilice la Consola de recuperación para iniciar el equipo y elimine el archivo de servicio de control remoto de terceros.

PASOS SIGUIENTES

Si sigue teniendo problemas similares a los descritos en este artículo, puede que las causas de los problemas no estén incluidas en este artículo. Hemos incluido una lista de artículos que tratan de problemas similares que puede examinar para intentar resolver el problema:
315222 Descripción de las opciones de inicio en modo seguro en Windows XP
314058 Cómo habilitar la Consola de recuperación de Windows XP para usuarios avanzados
308041 Recursos para solucionar problemas de inicio en Windows XP
Para obtener información adicional acerca de otros pasos para solucionar problemas que puede utilizar, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
314063 Solucionar un error Stop 0x0000000A en Windows XP
Si estos artículos no le ayudan a resolver el problema o si experimenta síntomas distintos de los que se describen en este artículo, busque más información en Microsoft Knowledge Base. Para realizar una búsqueda en Microsoft Knowledge Base, visite el siguiente sitio web de Microsoft:
http://support.microsoft.com/?ln=es
A continuación, escriba el texto del mensaje de error que aparece o escriba una descripción del problema en el campo de búsqueda de soporte técnico (KB).

Si sigue teniendo problemas tras usar estos métodos y estos artículos, haga clic en el siguiente vínculo para ponerse en contacto con el soporte técnico:
http://support.microsoft.com/contactus?ln=es#tab0

Más información

Si se cumplen las condiciones siguientes, el problema puede deberse a una incompatibilidad del hardware con Windows XP porque todos los controladores instalados son controladores de Windows XP:
  • Recibe el error STOP 0x7E la primera vez que inicia el equipo.
  • Recibe el error STOP 0x7E después de ejecutar el programa de instalación.
  • No instaló ningún controlador del fabricante durante la instalación de Windows.
Sin embargo, si recibe el error STOP 0x7E después de haberse actualizado desde Windows 2000 Professional, o si agregó recientemente un nuevo dispositivo de hardware, el problema puede deberse a un controlador incompatible o a un dispositivo de hardware incompatible.

Referencias

Para obtener información acerca de cómo ponerse en contacto con el fabricante del equipo, haga clic en el número de artículo adecuado de la lista siguiente para verlo en Microsoft Knowledge Base:
65416 Lista de contactos de proveedores terceros de hardware y software, A-K

60781 Lista de contactos de proveedores terceros de hardware y software, L-P

60782 Lista de contactos de proveedores terceros de hardware y software, Q-Z
Para obtener más información acerca de cómo deshabilitar un servicio que impide que Windows se inicie, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
310602 Cómo deshabilitar un servicio o un dispositivo que impide que se inicie Windows
Para obtener más información acerca de los controladores del adaptador de vídeo en el modo seguro, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
292460 Cómo solucionar problemas del controlador del adaptador de vídeo en el modo a prueba de errores

Propiedades

Id. de artículo: 330182 - Última revisión: viernes, 07 de junio de 2013 - Versión: 7.1
La información de este artículo se refiere a:
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
Palabras clave: 
kbtshoot kbresolve kbenv kberrmsg kbprb KB330182

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com