Artikel-id: 330182 - Visa produkter som artikeln gäller.
Visa alla | Dölj alla

På den här sidan

Symptom

Efter uppgradering till Windows XP visas följande STOP-felmeddelande:
STOP: 0x0000007E (0xC0000005, 0x804E518E, 0xFC938104, 0xFC937E04)
SYSTEM_THREAD_EXCEPTION_NOT_HANDLED
Obs! De fyra parametrarna i det här felmeddelandet kan ha olika värde beroende på orsaken till STOP-felet.

Orsak

Det här problemet kan uppstå om en systemtråd ger upphov till ett undantag som inte kan hanteras av felhanteraren. Problemet kan uppstå om en eller flera av följande förutsättningar föreligger:
  • Om problemet uppstår efter den första omstarten under installationen av Windows, eller när installationen har slutförts, finns det kanske inte tillräckligt mycket utrymme på hårddisken för körning av Windows.
  • Om problemet uppstår efter den första omstarten under installationen av Windows, eller när installationen har slutförts, är BIOS kanske inte kompatibelt med Windows.
  • Inkompatibla drivrutiner för grafikkortet.
  • Skadat RAM-minne.
  • En skadad drivrutin eller systemtjänst.
  • Om problemet har att göra med filen Win32k.sys kan det orsakas av ett fjärrstyrningsprogram från en annan tillverkare.

Lösning

Använd följande metoder för felsökning av problemet.

Metod 1: Se till att det finns tillräckligt med utrymme på hårddisken

Se till att det finns tillräckligt med utrymme på hårddisken. Om det uppstår problem under installationen av Windows som beror på att utrymmet på hårddisken inte räcker till, måste du frigöra utrymme. Ta bort alla onödiga temporära filer, cachelagrade Internetfiler, programsäkerhetskopior och CHK-filer med sparade filfragment från diskgenomsökningar. Du kan också använda en annan hårddisk med mer ledigt utrymme för installationen.

Metod 2: Uppdatera datorns BIOS

Se till att datorns BIOS-version är aktuell. Kontakta datortillverkaren för den senaste BIOS-uppdateringen. BIOS-minnesalternativ som cachelagring eller skuggning måste kanske inaktiveras tillfälligt.

Om du vill veta mer om hur du kontaktar maskinvarutillverkare klickar du på lämpligt artikelnummer i listan nedan och läser artikeln i Microsoft Knowledge Base:
65416 Kontaktlista för andra maskin- och programvaruleverantörer, A-K (Länken kan leda till en webbplats som är helt eller delvis på engelska)

60781 Kontaktlista för andra maskin- och programvaruleverantörer, L-P (Länken kan leda till en webbplats som är helt eller delvis på engelska)

60782 Kontaktlista för andra maskin- och programvaruleverantörer, Q-Z (Länken kan leda till en webbplats som är helt eller delvis på engelska)

Metod 3: Inaktivera eller uppdatera drivrutiner

Kontrollera i Microsoft HCL (Hardware Compatibility List) om PCI-enheterna i datorn är kompatibla med Windows XP.

Om du vill veta mer om hur du skaffar den senaste listan över maskinvarukompatibilitet för Windows XP klickar du på artikelnumret nedan och läser artikeln i Microsoft Knowledge Base:
314062 Den senaste listan över maskinvarukompatibilitet med Windows XP
Uppdatera grafikkortets drivrutiner till de senaste versionerna. Om en drivrutin nämns i STOP-felmeddelandet inaktiverar eller tar du bort drivrutinen. Inaktivera eller ta bort alla drivrutiner eller tjänster som har lagts till nyligen. Om det uppstår ett fel under startsekvensen, och NTFS-filsystemet används på systempartitionen, kan du kanske använda felsäkert läge för att byta namn på eller ta bort den felaktiga drivrutinen. Om drivrutinen används som en del av systemstartprocessen i felsäkert läge, måste du starta datorn med Återställningskonsolen för att kunna använda filen.

Om problemet har att göra med filen Win32k.sys kan det orsakas av ett fjärrstyrningsprogram från en annan tillverkare. Så här tar du bort tjänsten: starta datorn med Återställningskonsolen och ta sedan bort den angivna systemtjänstfilen.

Metod 4: Ta bort osignerade drivrutiner

Om du inte kan starta Windows i felsäkert läge tar du bort alla drivrutiner som inte är digitalt signerade av Microsoft.

Om du vill veta mer om hur du gör klickar du på artikelnumret nedan och läser artikeln i Microsoft Knowledge Base:
316434 Avancerad felsökning vid start i ren miljö i Windows XP

Metod 5: Ta bort alla drivrutiner från andra tillverkare

I vissa sällsynta fall går det kanske inte att fastställa vilken drivrutin som orsakar felet. Felsök problemet genom att flytta alla filer för drivrutiner från andra tillverkare från mappen Windows\System32\Drivers till en annan plats. Gör så här:
  1. Starta datorn med hjälp av Återställningskonsolen, eller starta datorn från en annan Windows-installation om du har gjort en parallell Windows-installation.
  2. Flytta alla filer som inte är skapade för Windows XP den 13 augusti 2001 från mappen Windows\System32\Drivers. Om datorn är beroende av en drivrutin från en annan tillverkare för en IDE- eller SCSI-styrenhet måste du ta reda på vilka dessa drivrutinfiler är och låta dem vara kvar i mappen Windows\System32\Drivers.
  3. Starta om datorn.
  4. Fortsätt installationsprogrammet för Windows.
Om du vill veta mer om hur du inaktiverar en tjänst som förhindrar att Windows startar, klickar du på följande artikelnummer och läser artikeln i Microsoft Knowledge Base:
310602 Inaktivera en tjänst eller enhet som förhindrar start av Windows

Mer Information

Om följande gäller kan problemet vara maskinvaruinkompatibilitet med Windows XP, eftersom samtliga installerade drivrutiner är Windows XP-drivrutiner:
  • Felmeddelandet STOP 0x7E visas när datorn startas första gången.
  • Felmeddelandet STOP 0x7E visas när installationsprogrammet har körts.
  • Du har inte installerat några drivrutiner från andra tillverkare under installationen av Windows.
Om felmeddelandet STOP 0x7E visas efter uppgradering från Windows 2000 Professional, eller om du nyligen har lagt till en ny maskinvaruenhet, kan problemet bero på en inkompatibel drivrutin eller maskinvaruenhet.

Om du vill veta mer om närliggande ämnen klickar du på artikelnumren nedan och läser artiklarna i Microsoft Knowledge Base:
315222 Felsäkra startalternativ i Windows XP
314058 Beskrivning av Återställningskonsolen för Windows XP
308041 Resurser för felsökning av startproblem i Windows XP
Om du vill veta mer om andra åtgärder för felsökning klickar du på följande artikelnummer och läser artikeln i Microsoft Knowledge Base:
314063 Felsökning vid meddelanden med Stop 0x0000000A i Windows XP

Egenskaper

Artikel-id: 330182 - Senaste granskning: den 6 april 2007 - Revision: 2.1
Informationen i denna artikel gäller:
  • Microsoft Windows XP Professional Edition
  • Microsoft Windows XP Home Edition
Nyckelord: 
kbenv kberrmsg kbprb KB330182

Ge feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com