Artigo: 330184 - Ver produtos para os quais este artigo se aplica.
Expandir tudo | Reduzir tudo

Sintomas

Quando inicia o computador depois de actualizar para o Microsoft Windows XP, poderá receber uma das seguintes mensagens de erro ou ambas:
Boot.ini inválido
Não foi possível iniciar o Windows porque o seguinte ficheiro não existe ou está danificado:

Windows\System32\Hal.dll

Causa

Este problema pode ocorrer se o ficheiro Boot.ini estiver em falta, danificado ou contiver entradas incorrectas.

Resolução

Para resolver este problema, inicie o computador a partir do CD do Windows XP, inicie a Consola de recuperação e utilize a ferramenta Bootcfg.exe para recriar o ficheiro Boot.ini. Para tal, siga estes passos:
  1. Configure o computador para iniciar a partir da unidade de CD-ROM ou DVD-ROM. Para obter mais informações sobre como o fazer, consulte a documentação do computador ou contacte o respectivo fabricante.
  2. Introduza o CD-ROM do Windows XP na unidade de CD-ROM ou de DVD-ROM e reinicie o computador.
  3. Quando receber a mensagem "Prima qualquer tecla para arrancar a partir do CD", prima qualquer tecla para iniciar o computador a partir do CD-ROM do Windows XP.
  4. Quando receber a mensagem "Bem-vindo ao programa de configuração", prima R para iniciar a Consola de recuperação:
  5. Se tiver um computador com arranque duplo ou arranque múltiplo, seleccione a instalação que tem de utilizar a partir da Consola de recuperação.
  6. Quando lhe for pedido, introduza a palavra-passe de administrador e prima ENTER.
  7. Na linha de comandos, escreva bootcfg /list e prima ENTER. As entradas no ficheiro Boot.ini actual são apresentadas no ecrã.
  8. Na linha de comandos, escreva bootcfg /rebuild e prima ENTER. Este comando detecta a existência de instalações do Windows XP, Microsoft Windows 2000 ou Microsoft Windows NT nos discos rígidos e apresenta os resultados. Siga as instruções apresentadas no ecrã para adicionar as instalações do Windows ao ficheiro Boot.ini. Por exemplo, siga estes passos para adicionar uma instalação do Windows XP ao ficheiro Boot.ini:
    1. Quando receber uma mensagem semelhante à mensagem seguinte, prima S:
      Número total de instalações do Windows identificadas: 1

      [1] C:\Windows
      Adicionar a instalação à lista de arranque? (Sim/Não/Todas)
    2. Recebe uma mensagem semelhante à mensagem seguinte:
      Introduza o identificador de carregamento
      Este é o nome do sistema operativo. Quando receber esta mensagem, escreva o nome do sistema operativo utilizado e prima ENTER. Este será o Microsoft Windows XP Professional ou Microsoft Windows XP Home Edition.
    3. Recebe uma mensagem semelhante à seguinte:
      Introduza as opções de carregamento do SO
      Quando receber esta mensagem, escreva /fastdetect e prima ENTER.

      Nota: as instruções apresentadas no ecrã poderão divergir, dependendo da configuração do computador.
  9. Escreva exit e prima ENTER para sair da Consola de recuperação. O computador é reiniciado e a lista de arranque actualizada será apresentada quando receber a mensagem "Seleccione o sistema operativo para iniciar".

Mais Informação

Para obter informações adicionais acerca da ferramenta Bootcfg.exe, clique no número de artigo que se segue para visualizar o artigo na base de dados de conhecimento da Microsoft (KB, Microsoft Knowledge Base):
291980 Um debate sobre o comando Bootcfg e as suas utilizações
Para obter informações adicionais sobre a Consola de recuperação, clique nos números de artigo que se seguem para visualizar os artigos na base de dados de conhecimento da Microsoft (KB, Microsoft Knowledge Base):
289022 Como editar o ficheiro Boot.ini no Windows XP
307654 Como instalar e utilizar a Consola de recuperação no Windows XP

Propriedades

Artigo: 330184 - Última revisão: 10 de junho de 2013 - Revisão: 3.1
A informação contida neste artigo aplica-se a:
  • Microsoft Windows XP Professional Edition
  • Microsoft Windows XP Home Edition
Palavras-chave: 
kbenv kberrmsg kbprb KB330184

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com