Chybová zpráva STOP: c000021a (závažná chyba systému)

Překlady článku Překlady článku
ID článku: 330303 - Produkty, které se vztahují k tomuto článku.
Rozbalit všechny záložky | Minimalizovat všechny záložky

Na této stránce

Příznaky

Při pokusu o přihlášení k doméně v počítači se systémem Windows 2000 se krátce zobrazí dialogové okno Winlogon error a pak se zobrazí následující chybová zpráva Stop:
STOP: c000021a (závažná chyba systému)
Proces systému Přihlášení k systému Windows neočekávaně skončil se stavem 0xc0000005 (0x0000000 0x00000000). Systém byl vypnut.

Příčina

K tomuto problému dojde, pokud je úplný název domény (FQDN) dlouhý přesně 200 bajtů. Během přihlášení je zapsán jeden znak navíc k 200bajtovému přidělení a dojde k poškození haldy.

Řešení

Informace o aktualizaci Service Pack

Tento problém vyřešíte pomocí nejnovější aktualizace Service Pack pro systém Windows 2000. Další informace najdete v následujícím článku znalostní báze Microsoft Knowledge Base:
260910 Jak získat nejnovější aktualizaci Service Pack pro systém Windows 2000

Informace o opravě hotfix

Společnost Microsoft má nyní k dispozici podporovanou opravu, která je určena pouze k odstranění problému popsaného v tomto článku. Tuto opravu použijte pouze u počítačů, ve kterých dochází k popsanému problému. Tato oprava bude pravděpodobně dále testována. Pokud vás tedy uvedený problém příliš neobtěžuje, doporučuje společnost Microsoft, abyste počkali na další aktualizaci Service Pack pro systém Windows 2000, která bude tuto opravu obsahovat.

Potřebujete-li odstranit tento problém okamžitě, obraťte se na odbornou pomoc pro produkty společnosti Microsoft, kde můžete tuto opravu získat. Úplný seznam telefonních čísel odborné pomoci pro produkty společnosti Microsoft a informace o cenách odborné pomoci naleznete na tomto webu společnosti Microsoft:
http://support.microsoft.com/default.aspx?scid=fh;EN-US;CNTACTMS
Poznámka: Ve zvláštních případech nemusí být poplatky za poskytnutí odborné pomoci účtovány, pokud pracovník služeb odborné pomoci společnosti Microsoft potvrdí, že tato zvláštní oprava odstraní vaše potíže. Další dotazy a žádosti o odbornou pomoc, které se netýkají této zvláštní opravy, podléhají běžným sazbám za poskytnutí odborné pomoci..

Anglická verze této opravy má následující atributy souborů (nebo novější). Data a časy jednotlivých souborů jsou uvedeny ve formátu UTC (Coordinated Universal Time). Při zobrazení informací o souboru jsou data a čas převedeny na místní čas. Rozdíl mezi místním časem a časem UTC naleznete na kartě Časové pásmo na panelu Datum a čas v okně Ovládací panely.
   Datum        Čas    Verze           Velikost  Název souboru
   ---------------------------------------------------------
   24. října 2002  01:33  5.0.2195.6102   46 864   Secur32.dll

Jak potíže obejít

Tento problém lze vyřešit změnou názvu počítače tak, aby byl o jeden znak kratší. Po provedení tohoto kroku bude úplný název domény kratší než 200 znaků a k poškození haldy nedojde.

Prohlášení

Společnost Microsoft potvrzuje, že se jedná o problém v produktech této společnosti, které jsou uvedeny na začátku tohoto článku. Tento problém byl poprvé opraven v aktualizaci Microsoft Windows 2000 Service Pack 4.

Další informace

Další informace o tom, jak získat opravu hotfix pro systém Windows 2000 Datacenter Server, naleznete v následujícím článku znalostní báze Microsoft Knowledge Base:
265173 Program pro podporu serveru Datacenter a produkt Windows 2000 Datacenter Server
(Tento článek může obsahovat odkazy na anglický obsah (dosud nepřeložený).)

Vlastnosti

ID článku: 330303 - Poslední aktualizace: 31. března 2006 - Revize: 1.2
Informace v tomto článku jsou určeny pro produkt:
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows 2000 Server
Klíčová slova: 
kbqfe kbhotfixserver kbqfe kbwin2ksp4fix kbwin2000presp4fix kbfix kbbug KB330303

Dejte nám zpětnou vazbu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com