Article ID: 330327 - Last Review: November 15, 2007 - Revision: 1.6

BizDesk Keyword Searches Are Not Successful If a Keywords Catalog Property Exists

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SYMPTOMS

When you try to perform a Microsoft Commerce Server Business Desk (BizDesk) keyword search, the search is not successful, and you receive the following error message:
Object doesn't support this property or method: 'keywords.value' in catalogs/editor/edit_CatalogContent.asp

CAUSE

This problem occurs if you add a keywords property to the catalog because "keywords" is used for keyword searches.

RESOLUTION

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time      Size    File name
   ------------------------------------------------------
   10-Oct-2002  17:18     26,489  Dlg_productpicker.asp
   10-Oct-2002  17:18     66,388  Edit_catalogcontent.asp
   10-Oct-2002  17:18      6,916  Response_products.asp

WORKAROUND

To work around this problem, remove the keyword property from the catalog.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section of this article.

APPLIES TO
  • Microsoft Commerce Server 2002 Standard Edition
Keywords: 
kbautohotfix kbhotfixserver kbqfe kbbug kbfix KB330327
 

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