Excel 2002: Custom Toolbars Are Lost After You Quit Excel

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Article ID: 330345 - View products that this article applies to.
This article was previously published under Q330345
IMPORTANT: This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:
256986 Description of the Microsoft Windows Registry
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SYMPTOMS

After you add custom toolbars to Excel 2002, quit Excel 2002, and then restart Excel 2002 either manually or from embedded Excel OLE objects, the custom toolbars may not appear.

CAUSE

The problem may occur if you quit Excel 2002, and then quickly restart Excel 2002. Excel 2002 menu customizations are stored in the Excel.xlb file. When you customize a menu, and then quit Excel 2002, Excel completely rewrites the .xlb file to record the menu changes. If there are a large number of menu changes, the .xlb file may become very large, so it may take a longer amount of time to rewrite the .xlb file. When you quickly restart Excel 2002, Excel 2002 may not have had enough time to rewrite the .xlb file.

RESOLUTION

Service Pack Information

This problem is corrected in Office XP Service Pack 3.To resolve this problem, obtain the latest service pack for Microsoft Office XP. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
307841 How to obtain the latest Office XP Service Pack

Hotfix Information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

The English version of this fix should have the following file attributes or later:
   Date         Time   Size        File name
   -------------------------------------------
   26-Nov-2002  03:17  12,885,592  Excel.msp
   26-Nov-2002  04:00  15,005,792  Excelff.msp
After the hotfix is installed, the English version of this fix will have the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version      Size       File name
   -----------------------------------------------------
   25-Nov-2002  18:50  10.0.4721.0  9,177,672  Excel.exe
After you install this fix, follow the steps that are listed in the "More Information" section of this article to set the QFE_CacheXLB registry key and to turn on the fix.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. This problem was first corrected in Office XP Service Pack 3.

MORE INFORMATION

WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.

How to Turn On the Hotfix by Using the QFE_CacheXLB Registry Key

To turn on the product fix that is listed in this article, type the following registry key and value:
  1. If Excel is running, quit Excel.
  2. Click Start, and then click Run.
  3. In the Open box, type regedit, and then click OK.
  4. Locate, and then click to select the following registry key:
    HKEY_CURRENT_USER\Software\Microsoft\Office\10.0\Excel\Options\
  5. Click the Edit menu, click New, and then click DWORD value.
  6. Type the following name for the new value, QFE_CacheXLB.
  7. Press the ENTER key.
  8. Right-click the QFE_CacheXLB registry key, and then click Modify.
  9. In the Value data box, type 1.
  10. Click OK, and then quit Registry Editor.

Properties

Article ID: 330345 - Last Review: February 1, 2007 - Revision: 6.3
APPLIES TO
  • Microsoft Excel 2002 Standard Edition
Keywords: 
kbautohotfix kbqfe kbhotfixserver kbofficexppresp3fix kbenv kbui kbprb kbbug kbfix KB330345

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