При попытке запуска потока isoch, запуск не происходит или появляется сообщение об ошибке

Переводы статьи Переводы статьи
Код статьи: 330421 - Vizualiza?i produsele pentru care se aplic? acest articol.
Эта статья помещена в архив. Она предлагается "как есть" и обновляться не будет.
Развернуть все | Свернуть все

Проблема

При запуске потока isoch Вы можете столкнуться со следующими проблемами:
  • В Windows 2000 не вызывается обратный вызов isoch.
  • В Windows XP появляется сообщение об ошибке на синем экране.

Причина

Данная проблема возникает из-за того, что все запрошенные изохронные передачи используют только один изохронный пакет.

В Windows 2000 не появляется ошибка на синем экране. Однако данные, полученные во время передачи, являются неверными или драйвер перестает отвечать на системные запросы, так как никогда не получал обратный вызов isoch, уведомляющий о том, что передача по каналу прямого доступа в память была завершена.

В Windows XP перед началом передачи DMA, во время построения списка DMA Вы можете получить сообщение об ошибке на синем экране.

Решение

Данная проблема может быть решена с помощью исправления, выпущенного корпорацией Microsoft. Предлагаемое исправление включает в себя решение только для проблемы, описанной в данной статье, и должно применяться исключительно в системах, где наблюдается вышеописанная проблема. Данное исправление находится на стадии дополнительного тестирования. По этой причине, Microsoft рекомендует во всех случаях, когда проблема не представляет особой важности, отложить ее решение до выхода ближайшего пакета исправлений Service Pack для Windows 2000 или Windows XP, в который будет включено решение описанной проблемы.

Для того, чтобы получить исправление, свяжитесь со службами технической поддержки Microsoft. Полный список телефонов служб поддержки, а также информация по условиям обслуживания, доступны на веб-сервере Microsoft по следующему адресу:
http://support.microsoft.com/default.aspx?scid=fh;EN-US;CNTACTMS
Примечание: В отдельных случаях, если специалистом службы технической поддержки Microsoft будет определено, что решением проблемы является специально выпущенное исправление, оплата, предусмотренная за обращение в службы технической поддержки, может быть отменена. Дополнительные вопросы, не связанные с данным исправлением, обслуживаются в соответствии со стандартными условиями.

Английская версия данного исправления содержит версии файлов, приведенные в следующей таблице или более поздние. Дата и время для файлов указаны в формате универсального глобального времени (По Гринвичу). При просмотре Вами сведений о файле в системе происходит перевод соответствующих значений в Ваше местное время. Чтобы узнать разницу между временем по Гринвичу и местным временем, следует использовать закладку "Часовой пояс" элемента Панели управления "Дата и время".
   Дата        Время   Версия         Размер  Имя файла     Платформа
   ---------------------------------------------------------------------
   03-Окт-2001 13:56   5.0.2195.4455  22,064  sonydcam.sys  Windows 2000
   16-Окт-2002 19:40   5.0.2195.6092  37,680  ohci1394.sys  Windows 2000
   17-Окт-2002 10:20   5.1.2600.103   55,424  ohci1394.sys  Windows XP SP1
   17-Окт-2002 10:27   5.1.2600.1133  55,680  ohci1394.sys  Windows XP SP2
				

Статус

Описанное поведение является подтвержденной ошибкой в программных продуктах Microsoft, перечисленных в разделе "Информация… применима к:" данной статьи.

Свойства

Код статьи: 330421 - Последний отзыв: 21 февраля 2014 г. - Revision: 2.2
Информация в данной статье относится к следующим продуктам.
  • Microsoft Windows 2000
  • Microsoft Windows XP Professional
Ключевые слова: 
kbnosurvey kbarchive kbautohotfix kbqfe kbhotfixserver kbbug kbfix KB330421

Отправить отзыв

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com