É apresentada uma janela do serviço 'Messenger' com um anúncio da Internet

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Sintomas

Este artigo poderá conter hiperligações para conteúdo em inglês (ainda não traduzido). Pode receber um anúncio da Internet numa janela do serviço Mensageiro (Messenger). O anúncio contém texto semelhante ao seguinte:
Serviço 'Mensageiro'
Mensagem de origem para nome_do_seu_computador.nome_ISP em data hora
Texto da mensagem
Estas mensagens também são conhecidas como "mensagens publicitárias não solicitadas do serviço 'Mensageiro'".

Este artigo poderá conter hiperligações para conteúdo em inglês (ainda não traduzido).

Causa

Este problema pode ocorrer se receber uma mensagem net send proveniente de um utilizador que esteja a utilizar o serviço Mensageiro (Messenger) no Windows. O Mensageiro (Messenger) é um serviço do Windows que transmite mensagens net send e mensagens enviadas através do serviço Alerta (Alerter) entre computadores clientes e servidores. Por exemplo, os administradores da rede utilizam o serviço Mensageiro (Messenger) para enviar alertas administrativos a utilizadores da rede. O Windows e outros programas de software também podem utilizar o serviço Mensageiro (Messenger). Por exemplo, o Windows pode utilizá-lo para o informar quando um trabalho de impressão está concluído ou quando a energia do computador é interrompida e este passa a ser alimentado por uma fonte de alimentação ininterrupta (UPS, Uninterruptible Power Supply). O programa antivírus pode utilizar o serviço Mensageiro (Messenger) para lhe enviar notificações. O serviço Mensageiro (Messenger) não está relacionado com o Web browser, com o Windows Messenger ou com o MSN Messenger. Este problema pode ocorrer se se verificarem as seguintes condições:
  • O serviço Mensageiro (Messenger) está iniciado.
  • O serviço Chamada de procedimento remoto (Remote Procedure Call) está iniciado.
  • O tráfego de entrada NetBIOS (NetBIOS através de TCP/IP) e o tráfego de difusão UDP estão activados na ligação à Internet.

Resolução

Para resolver este problema, instale ou active um firewall que bloqueie o tráfego de entrada NetBIOS e o tráfego de difusão UDP. O método utilizado para resolver este problema depende do sistema operativo que está a utilizar e do modo como acede à Internet. As secções seguintes fornecem exemplos de várias configurações diferentes e métodos de resolução possíveis.

Acede directamente à Internet

Se estiver a utilizar um computador autónomo que esteja directamente ligado à Internet (através de um modem de cabo, modem DSL ou modem de acesso telefónico, por exemplo), instale um firewall e bloqueie o tráfego de entrada NetBIOS e o tráfego de difusão UDP no computador.

Está a utilizar o Windows XP

Se estiver a utilizar o Windows XP e aceder directamente à Internet (através de um modem de cabo, modem DSL ou modem de acesso telefónico, por exemplo), instale o Windows XP Service Pack 1 (SP1) e active o Firewall de ligação à Internet (ICF, Internet Connection Firewall). Por predefinição, a instalação do Windows XP SP1 permite que o Firewall de ligação à Internet (ICF, Internet Connection Firewall) bloqueie todo o tráfego de entrada (unicast, multicast e difusão). Se tiver instalado o Windows XP Service Pack 2 (SP2), o Firewall do Windows (WF, Windows Firewall) está activado por predefinição.

Para obter informações adicionais sobre como alterar o comportamento de bloqueio do ICF no Windows XP SP1, clique no número de artigo que se segue para visualizar o artigo na base de dados de conhecimento da Microsoft (KB, Microsoft Knowledge Base):
329928 ICF now blocks insolicited inbound unicast, multicast, and broadcast traffic
Para obter informações adicionais sobre como obter o Windows XP SP1, clique no número de artigo que se segue para visualizar o artigo na base de dados de conhecimento da Microsoft (KB, Microsoft Knowledge Base):
322389 Como obter o Service Pack mais recente do Windows XP
Para obter informações adicionais sobre como activar o ICF, clique no número de artigo que se segue para visualizar o artigo na base de dados de conhecimento da Microsoft (KB, Microsoft Knowledge Base):
283673 COMO: Activar ou desactivar a funcionalidade 'Firewall de ligação à Internet' do Windows XP

Está a utilizar o Windows 2000

Se estiver a utilizar o Windows 2000 e aceder à Internet directamente (através de um modem de cabo, modem DSL ou modem de acesso telefónico, por exemplo), obtenha e instale um firewall de outro fabricante que bloqueie o tráfego de entrada NetBIOS e o tráfego de difusão UDP. Para obter informações adicionais sobre firewalls, visite o seguinte Web site da Microsoft:
http://www.microsoft.com/security/articles/firewall.asp

Acede à Internet através de uma rede de pequenas dimensões gerida por si

Se a rede utilizar partilha de ligação para fornecer acesso à Internet a múltiplos computadores, instale ou active o firewall apenas na ligação partilhada à Internet.

Está a utilizar o Windows XP com a 'Partilha de ligação à Internet'

Se utilizar a Partilha de ligação à Internet (Internet Connection Sharing) no Windows XP para fornecer acesso à Internet a múltiplos computadores, instale o Windows XP SP1 no computador anfitrião da Partilha de ligação à Internet (Internet Connection Sharing) e active a Partilha de ligação à Internet (Internet Connection Sharing) apenas nesse anfitrião.

Está a utilizar o Windows com um dispositivo de hardware para partilha de ligação à Internet

Se utilizar um router ou outro dispositivo de hardware para fornecer acesso à Internet a múltiplos computadores, configure o dispositivo de partilha da ligação para bloquear o tráfego de entrada NetBIOS e o tráfego de difusão UDP. Contacte o fabricante do dispositivo de partilha de ligação para obter mais informações.

Acede à Internet através de uma rede que não é gerida por si

Se aceder à Internet através de uma rede empresarial, ou se o seu fornecedor de serviços Internet (ISP) utilizar um firewall, peça ao administrador da rede para configurar o firewall de modo a bloquear o tráfego de entrada NetBIOS e o tráfego de difusão UDP. Contacte o administrador da rede ou o ISP para obter mais informações.

Como contornar

Para contornar este problema, desactive o serviço Mensageiro (Messenger). Para tal, siga estes passos:
  1. Clique em Iniciar (Start) e clique em Painel de controlo (Control Panel) (ou aponte para Definições (Settings) e clique em Painel de controlo (Control Panel)).
  2. Faça duplo clique em Ferramentas administrativas (Administrative Tools).
  3. Faça duplo clique em Serviços (Services).
  4. Faça duplo clique em Mensageiro (Messenger).
  5. Na lista Tipo de arranque (Startup type), clique em Desactivado (Disabled).
  6. Clique em Parar (Stop) e clique em OK.
Nota:se o serviço Mensageiro (Messenger) estiver parado, as mensagens do serviço Alerta (Alerter) (notificações do software antivírus, por exemplo) não são transmitidas. Se o serviço Mensageiro (Messenger) estiver desactivado, todos os serviços que dependam explicitamente desse serviço não serão iniciados e será escrita uma mensagem de erro no registo de eventos do sistema. Consequentemente, a Microsoft recomenda que instale um firewall e que o configure para bloquear o tráfego NetBIOS e RPC em vez de desactivar o serviço Mensageiro (Messenger).

Mais Informação

O serviço Mensageiro (Messenger) utiliza as portas UDP 135, 137 e 138, as portas TCP 135, 139 e 445 e um número de porta efémero (de curta duração) maior do que 1024.

Os firewalls ajudam a impedir mensagens net send e ajudam a proteger o computador contra outros ataques maliciosos através da Internet. Estes ataques podem ser concebidos para efectuar as seguintes tarefas:
  • Aceder a informações privadas
  • Distribuir software ilegalmente através da apropriação de espaço no seu disco rígido
Para obter informações adicionais sobre este problema, visite o seguinte Web site da Microsoft:
http://www.microsoft.com/windowsxp/using/security/learnmore/stopspamv45.mspx

Propriedades

Artigo: 330904 - Última revisão: 1 de dezembro de 2007 - Revisão: 8.1
A informação contida neste artigo aplica-se a:
  • Microsoft Windows XP Professional Edition
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Tablet PC Edition
  • Microsoft Windows XP Media Center Edition
  • Microsoft Windows XP Professional x64 Edition
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows Messenger 4.6
  • Microsoft Windows Messenger 4.7
  • MSN Messenger 5.0
  • Microsoft Windows XP Home Edition Service Pack 2 (SP2)
  • Microsoft Windows XP Media Center Edition Service Pack 2 (SP2)
  • Microsoft Windows XP Professional Service Pack 2 (SP2)
  • Microsoft Windows XP Tablet PC Edition 2005
Palavras-chave: 
kbfirewall kbenv kbprb kbpubtypekc kbmsccsearch KB330904

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