Article ID: 331683 - Last Review: November 24, 2006 - Revision: 1.6

SharePoint Portal Server Stops Responding When You Create a New Folder Over an SSL Connection

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This article was previously published under Q331683
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SYMPTOMS

When you connect to the SharePoint Portal Server dashboard site over a Secure Sockets Layer (SSL) connection in Microsoft Internet Explorer and create a new folder in the Document Library, SharePoint Portal Server may stop responding (hang). When this symptom occurs, you must restart Microsoft Internet Information Services (IIS) 5.0 to restore SharePoint Portal Server functionality. Because of this, you cannot add a new folder to the Document Library in SharePoint Portal Server over an SSL connection.

CAUSE

This problem may occur if both of the following conditions exist:
  • You are assigned to the role of reader for the workspace.
  • You connect to SharePoint Portal Server over an SSL connection.
In this situation, the Msdaipp.dll component of SharePoint Portal Server incorrectly processes SSL connections.

RESOLUTION

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language. The Global version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Size     File name
----------------------------------------
11-Jun-2002  01:53  1187840  Msdaipp.dlll
				
Note Because of file dependencies, this update requires Microsoft SharePoint Portal Server 2001 Service Pack 1.

STATUS

Microsoft has confirmed that this is a problem in Microsoft SharePoint Portal Server 2001.

APPLIES TO
  • Microsoft SharePoint Portal Server 2001 Service Pack 1
Keywords: 
kbautohotfix kbhotfixserver kbqfe kbenv kbprb kbbug kbfix kbqfe kbshareptportalsvr2001presp2fix KB331683
 

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