L'installazione del cluster potrebbe non funzionare quando si aggiungono nodi

Traduzione articoli Traduzione articoli
Identificativo articolo: 331801 - Visualizza i prodotti a cui si riferisce l?articolo.
Espandi tutto | Chiudi tutto

Sintomi

Quando si aggiungono nodi a un cluster, l'installazione guidata potrebbe smettere di lavoro durante la fase di analisi. Quando si verifica questa situazione, viene generato il seguente messaggio di errore:
Data: 23/10/2002
Ora: 9:51:50 AM
Computer: NODENAME
ID operazione principale: {B8C4066E-0246-4358-9DE5-25603EDD0CA0}
ID operazione secondaria: {3BB53C9E-E14A-4196-9066-5400FB8860C9}
Stato (min, max, corrente): 0, 1, 1
Descrizione:
Verifica che tutti i nodi abbiano accesso alla risorsa quorum
Stato: 0x800713de
Impossibile individuare il disco quorum per il servizio cluster.
Informazioni aggiuntive:
Per ulteriori informazioni, visitare Guida in linea e supporto tecnico all'indirizzo
http://go.microsoft.com/fwlink/?LinkId=4441.
Questo problema si verifica solo quando si aggiungono nodi a un cluster esistente.

Cause

Questo comportamento Ŕ causato da un'interazione tra due tecnologie: nuovo Cluster Setup Wizard e la configurazione di rete (SAN) del area di archiviazione. Nuovo Cluster Setup Wizard contiene euristica per verificare che tutti i nodi del cluster dispongano dell'accesso ai dischi stessi. La procedura guidata viene eseguita come determinare se tutti i nodi del cluster riconoscono i dischi con il numero di unitÓ logica (LUN) e il stesso ID di destinazione (TID). In genere, una matrice di condivisione dei dischi cluster configurato correttamente, ci˛ avviene. Tuttavia, con una rete SAN complesse configurazione, questo potrebbe non essere vero.

Con un complesso ambiente SAN, su diversi LUN e TID lo stesso insieme di dischi pu˛ essere rilevato dai singoli nodi, ma questo pu˛ essere ancora una configurazione cluster valido. Di conseguenza, l'euristica di rilevamento del disco potrebbe erroneamente rileva che la configurazione del disco non Ŕ valida per l'installazione.

Workaround

Per risolvere questo problema, fare clic su Avanzate quando Ŕ richiesto per i nodi aggiungere al cluster e quindi fare clic su configurazione di avanzata (minima) . L'opzione Avanzate consente di escludere il rilevamento Ŕ descritto in precedenza in questo articolo dal processo di analisi che consente di continuare l'installazione di cluster. Tuttavia, se esistono problemi di configurazione del disco, il cluster potrebbe verificarsi problemi con portare in linea i dischi o con il failover di disco.

Informazioni

Un esempio una soluzione di archiviazione complesse potrebbe da una rete SAN con pi¨ opzioni tra i nodi e l'archiviazione. PoichÚ i nodi del cluster non richiedono lo stesso percorso per qualsiasi disco, i nodi possono enumerare i dischi con ID diverso. Il nodo A potrebbe, ad esempio, enumerare Disco1 come LUN 1 TID 1. PoichÚ il nodo B pu˛ essere connesso a un parametro separato e un controller nella rete SAN ed enumerare ancora lo stesso disco, il disco potrebbe essere enumerato, ad esempio, come LUN 2 TID 3.

Il log di installazione del servizio cluster (clcfgsrv.log) contiene informazioni su come i nodi enumerare i dischi. Questo Ŕ un esempio delle informazioni di file clcfgsrv.log:
17-09-2002 11:45:55.237 [INFO] Nodo1: disco SCSI trovare ' \\. \ DRIVENAME 'su degli bus 0 "e"5"della porta; TID '0' e LUN ' 0'
Si noti che un altro nodo del cluster enumera stessa unitÓ fisica in modo diverso:
17-09-2002 11:45:57.174 [INFO] Nodo2: disco SCSI trovare ' \\. \ DRIVENAME 'su degli bus 0 ' e '4' porta; TID '0' e LUN ' 0'
Il percorso del file clcfgsrv.log Ŕ systemroot%\System32\Logfiles\Cluster\Clcfgsrv.log %. ╚ possibile utilizzare il file clcfgsrv.log per determinare e confrontare il modo in cui i nodi enumerare i dischi. ╚ inoltre possibile utilizzare Gestione periferiche per determinare questo. Per determinare il TID e il LUN per un disco in Gestione periferiche, attenersi alla seguente procedura:
  1. Fare clic con il pulsante destro del mouse su Risorse del computer e quindi fare clic su ProprietÓ .
  2. Su hardware della scheda Gestione periferiche .
  3. Espandere la voce di dischi in Gestione periferiche.
  4. Fare clic con il pulsante destro del mouse un disco e quindi fare clic su ProprietÓ . La scheda Generale contiene una voce denominata percorso . Questa voce Mostra il LUN e di un TID per il disco.
╚ possibile utilizzare questi metodi per determinare se i nodi del cluster sono l'enumerazione dei dischi con diversi TID e LUN. Per ulteriori informazioni su questo argomento, vedere l'argomento "Opzioni di configurazione di archiviazione" nella Guida in linea e supporto tecnico.

ProprietÓ

Identificativo articolo: 331801 - Ultima modifica: venerdý 11 maggio 2007 - Revisione: 8.1
Le informazioni in questo articolo si applicano a:
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, 64-Bit Datacenter Edition
Chiavi:á
kbmt kbprb KB331801 KbMtit
Traduzione automatica articoli
Il presente articolo Ŕ stato tradotto tramite il software di traduzione automatica di Microsoft e non da una persona. Microsoft offre sia articoli tradotti da persone fisiche sia articoli tradotti automaticamente da un software, in modo da rendere disponibili tutti gli articoli presenti nella nostra Knowledge Base nella lingua madre dell?utente. Tuttavia, un articolo tradotto in modo automatico non Ŕ sempre perfetto. Potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli, pi¨ o meno allo stesso modo di come una persona straniera potrebbe commettere degli errori parlando una lingua che non Ŕ la sua. Microsoft non Ŕ responsabile di alcuna imprecisione, errore o danno cagionato da qualsiasi traduzione non corretta dei contenuti o dell?utilizzo degli stessi fatto dai propri clienti. Microsoft, inoltre, aggiorna frequentemente il software di traduzione automatica.
Clicca qui per visualizzare la versione originale in inglese dell?articolo: 331801
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.

Invia suggerimenti

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com