Article ID: 331940 - Last Review: September 27, 2005 - Revision: 1.4

BUG: Commerce 2002 Business Desk Cannot Properly Handle 302 Redirects

This article was previously published under Q331940
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SYMPTOMS

When you use Commerce Server 2002 Business Desk (BizDesk) in a distributed environment, you may receive the following BizDesk error message:
Error occurred in publishing, 302 Found

CAUSE

This problem occurs because Commerce Server 2002 Business Desk does not have error handling to redirect correctly when it receives a 302 error from the server.

RESOLUTION

To resolve this problem, check the HTTP status when you call the site refresh pages. If a 302 is returned, read the location from the response header, and then use this information to call the site one more time.

For these files on your Business Desk site
  • Bizdesk\Catalogs\Editor\List_Catalogs.asp
  • Bizdesk\Productionrefresh\Refresh.asp
  • Bizdesk\Profiles\RefreshProfileSvcAll.asp
insert the following code:
'After the first send, check the status, and then redirect if error 302
'is returned:
If srvXmlHttp.status = 302 Then
	sURLString = srvXmlHttp.getResponseHeader("Location")
	Set srvXmlHttp = Server.CreateObject("MSXML2.ServerXMLHTTP")
	Call srvXmlHttp.Open ("GET", sURLString, false)
	Call srvXmlHttp.Send()
End if
				

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

APPLIES TO
  • Microsoft Commerce Server 2002 Standard Edition
Keywords: 
kbhotfixserver kbqfe kbbug kbfix kbnofix kbpending KB331940
 

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