Przełączanie trybu pełnoekranowego w programie Podłączanie pulpitu zdalnego powoduje komunikat błędu "Brak pamięci"

Tłumaczenia artykułów Tłumaczenia artykułów
Numer ID artykułu: 331964 - Zobacz jakich produktów dotyczą zawarte w tym artykule porady.
Rozwiń wszystko | Zwiń wszystko

Na tej stronie

Symptomy

Jeśli przełączanie trybu pełnoekranowego w oprogramowaniu klienckim połączenie RDP (Remote Desktop) za pomocą kombinacji klawiszy CTRL + ALT + BREAK, oprogramowanie klienta RDP występuje przeciek pamięci. Na pulpicie klienta nie będzie odświeżany poprawnie lub otrzymujesz komunikat o błędzie "Brak pamięci". Na przykład nie może być odowieżany tapety pulpitu, a ikony mogą nie być wyświetlane poprawnie. Po zakończeniu pracy z oprogramowaniem klienta RDP jest zwalniana pamięć i komputer działa poprawnie. Istnieje możliwość przełączania trybu widoku od 10 do 70 (lub więcej) razy przed wystąpieniem problemu.

Przyczyna

Oprogramowanie klienta RDP przecieków pamięci podczas przełączania między sesji i pulpit. To wyczerpuje zasoby systemowe.

Rozwiązanie

Informacje dotyczące Service pack

Aby rozwiązać ten problem, należy uzyskać najnowszy dodatek service pack dla systemu Microsoft Windows XP. Aby uzyskać dodatkowe informacje kliknij numer artykułu poniżej w celu wyświetlenia tego artykułu z bazy wiedzy Microsoft Knowledge Base:
322389 Jak uzyskać najnowszy dodatek service pack dla systemu Windows XP

Informacje o poprawce

Firma Microsoft udostępniła obsługiwaną poprawkę. Jednakże ta poprawka jest przeznaczona tylko do rozwiązania problemu opisanego w tym artykule. Powinna być stosowana tylko w systemach, w których ten problem występuje. Ta poprawka może być nadal w fazie testowania. Jeśli dany system nie jest poważnie narażony na ten problem, firma Microsoft zaleca, aby poczekać na następną aktualizację oprogramowania zawierającą tę poprawkę.

eśli poprawka jest dostępna do pobrania, na początku tego artykułu z bazy wiedzy Knowledge Base jest umieszczona sekcja „Poprawka dostępna do pobrania”. Jeśli nie ma tej sekcji, skontaktuj się z działem obsługi klienta i pomocy technicznej firmy Microsoft w celu uzyskania poprawki.

Uwaga W przypadku wystąpienia dodatkowych błędów lub konieczności rozwiązania problemu może być wymagane utworzenie osobnego zlecenia usługi. Typowe opłaty za korzystanie z pomocy technicznej będą pobierane tylko w przypadku dodatkowych pytań i problemów, których nie można rozwiązać przy użyciu tej poprawki. Aby uzyskać pełną listę numerów telefonów do działu obsługi klienta firmy Microsoft lub utworzyć osobne zlecenie usługi odwiedź następującą witrynę firmy Microsoft w sieci Web:
http://support.microsoft.com/contactus/?ws=support
Uwaga Sekcja „Poprawka dostępna do pobrania” zawiera listę języków, dla których ta poprawka jest dostępna. Jeśli odpowiedni język nie jest widoczny, oznacza to, że ta poprawka nie jest dostępna dla tego języka.

Wersja anglojęzyczna tej poprawki ma atrybuty pliku (lub nowsze) wymienione w poniższej tabeli. Daty i godziny odpowiadające tym plikom są wymienione w skoordynowanego czasu uniwersalnego (UTC). Podczas przeglądania informacji o pliku, jest konwertowany na czas lokalny. Aby zobaczyć różnicę między czasem UTC i czasem lokalnym, należy użyć Strefa czasowa Karta w narzędziu Data i godzina w Panelu sterowania.
   Date         Time   Version       Size     File name
   ------------------------------------------------------
   05-Nov-2002  23:20  5.1.2600.105  503,808  Mstscax.dll

Stan

Firma Microsoft potwierdziła, że jest to problem występujący w systemie Microsoft Windows 95 i Microsoft Windows 98. Ten problem został po raz pierwszy rozwiązany w dodatku Service Pack 2 dla systemu Microsoft Windows XP.

Więcej informacji

Użytkownicy systemu Windows 95 i Windows 98 użytkownicy, którzy ten problem występuje, można pobrać usługi Podłączanie pulpitu zdalnego dla oprogramowania Microsoft Windows Server 2003 lub formantu Microsoft ActiveX usług terminalowych Zaawansowane (OCX), aby rozwiązać ten problem. Aby pobrać te elementy, odwiedź następującą witrynę firmy Microsoft w sieci Web:
http://www.microsoft.com/windowsserver2003/technologies/TerminalServices/default.mspx#downloads

Właściwości

Numer ID artykułu: 331964 - Ostatnia weryfikacja: 18 lutego 2013 - Weryfikacja: 4.0
Informacje zawarte w tym artykule dotyczą:
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
Słowa kluczowe: 
kbautohotfix kbhotfixserver kbqfe kbwinxpsp2fix kbwinxppresp2fix kbfix kbbug kbpending kbmt KB331964 KbMtpl
Przetłumaczone maszynowo
WAŻNE: Ten artykuł nie został przetłumaczony przez człowieka, tylko przez oprogramowanie do tłumaczenia maszynowego firmy Microsoft. Firma Microsoft oferuje zarówno artykuły tłumaczone przez ludzi, jak i artykuły tłumaczone maszynowo, dzięki czemu każdy użytkownik może uzyskać dostęp do całej zawartości bazy wiedzy Knowledge Base we własnym języku. Prosimy jednak pamiętać, że artykuły przetłumaczone maszynowo nie zawsze są doskonałe. Mogą zawierać błędy słownictwa, składni i gramatyki, przypominające błędy robione przez osoby, dla których język użytkownika nie jest językiem ojczystym. Firma Microsoft nie odpowiada za wszelkie nieścisłości, błędy lub szkody spowodowane nieprawidłowym tłumaczeniem zawartości oraz za wykorzystanie tej zawartości przez klientów. Oprogramowanie do tłumaczenia maszynowego jest często aktualizowane przez firmę Microsoft.
Anglojęzyczna wersja tego artykułu to: 331964

Przekaż opinię

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com