Help and Support
 

powered byLive Search
Hotfix Download Available

Bugcheck 0x000000FE Under Stress with USB 2.0 Hard Disks

Article ID:331988
Last Review:August 29, 2007
Revision:4.2
This article was previously published under Q331988
On This Page

SYMPTOMS

When a computer that is running Windows XP is accessing USB 2.0 hard disks under heavy stress conditions, you may receive a bugcheck 0xFE message similar to the following:
BUGCODE_USB_DRIVER (fe)
In a USB Driver bugcheck, the first parameter is a USB bugcheck code that has the following arguments:
Argument 1: 00000002, BAD_URB. The USB client driver has submitted a USB Request Block (URB) that is still attached to another Input/Output (I/O) request packet (IRP) that is still pending in the USB driver.
Argument 2: 8162ea78, Address of the pending IRP.
Argument 3: 81707950, Address of the IRP that is passed in.
Argument 4: 8156db7c, Address of the URB that caused the error.

Back to the top

CAUSE

This behavior occurs because in the NT Kernel two threads try to start an I/O operation on the same packet.

Back to the top

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Microsoft Windows XP. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
322389 (http://support.microsoft.com/kb/322389/EN-US/) How to obtain the latest Windows XP service pack

Back to the top

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language. The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

   Date         Time   Version        Size       File name     SP Level
   ----------------------------------------------------------------------
   12-Nov-2002  23:21  5.1.2600.106   1,848,320  Ntkrnlmp.exe  SP1
   12-Nov-2002  23:21  5.1.2600.106   1,902,080  Ntkrnlpa.exe  SP1
   12-Nov-2002  23:21  5.1.2600.106   1,874,944  Ntkrpamp.exe  SP1
   12-Nov-2002  23:21  5.1.2600.106   1,880,064  Ntoskrnl.exe  SP1
   13-Nov-2002  00:28  5.1.2600.1143  1,892,352  Ntkrnlmp.exe  SP2
   13-Nov-2002  00:28  5.1.2600.1143  1,948,160  Ntkrnlpa.exe  SP2
   13-Nov-2002  00:28  5.1.2600.1143  1,921,024  Ntkrpamp.exe  SP2
   13-Nov-2002  00:28  5.1.2600.1143  1,924,480  Ntoskrnl.exe  SP2
				

Back to the top

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. This problem was first corrected in Microsoft Windows XP Service Pack 2.

Back to the top


APPLIES TO
Microsoft Windows XP Professional SP1
Microsoft Windows XP Professional
Microsoft Windows XP Home Edition

Back to the top

Keywords: 
kbautohotfix kbhotfixserver kbqfe kbwinxpsp2fix kbbug kbfix kbqfe kbwinxppresp2fix KB331988

Back to the top

Article Translations

 

Related Support Centers

Other Support Options

  • Need More Help?
    Contact a Support professional by Email, Online or Phone.
  • Customer Service
    For non-technical assistance with product purchases, subscriptions, online services, events, training courses, corporate sales, piracy issues, and more.
  • Newsgroups
    Pose a question to other users. Discussion groups and Forums about specific Microsoft products, technologies, and services.