Ve všech paketech odeslaných z počítače se systémem Windows 2000 je bit DF nesprávně nastaven na nulovou hodnotu (Tento článek může obsahovat odkazy na anglický obsah (dosud nepřeložený).)

Překlady článku Překlady článku
ID článku: 332001 - Produkty, které se vztahují k tomuto článku.
Tento článek byl archivován. Je nabízen v takovém stavu, v jakém je, a nebude již nadále aktualizován.
Důležité: Tento článek obsahuje informace o úpravě registru. Před úpravami je nutné registr zazálohovat. Seznamte se také s postupem při obnovení registru v případě, že nastane problém. Informace o zálohování, obnovení a úpravě registru naleznete v následujícím článku znalostní báze Microsoft Knowledge Base:
256986Popis registru systému Microsoft Windows
Rozbalit všechny záložky | Minimalizovat všechny záložky

Na této stránce

Příznaky

V systému Windows 2000 při nastavení hodnoty
SynAttackProtect
v následujícím klíči registru 2, „ není fragment"nebo DF bit nesprávně nastaven na 0 všechny pakety odeslané z počítače:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

Příčina

K tomuto problému dochází, protože možnost bit DF není při
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\SynAttackProtect
hodnota nastavena na 2 správně inicializováno.

Řešení

Informace o aktualizaci Service Pack

Tento problém vyřešíte pomocí nejnovější aktualizace service pack pro systém Windows 2000. Další informace získáte v následujícím článku znalostní báze Microsoft Knowledge Base:
260910Jak získat nejnovější aktualizaci Service Pack pro systém Windows 2000

Informace o opravě hotfix

K dispozici je podporovaná oprava hotfix od společnosti Microsoft. Tato oprava hotfix je však určena pouze k opravě problému popsanému v tomto článku. Použijte tuto opravu hotfix pouze u systémů, kde dochází k tomuto konkrétnímu problému.

Pokud je oprava hotfix k dispozici ke stažení, v horní části tohoto článku je sekce "Hotfix stažení k dispozici". Není-li tato část uvedena, vyžádejte si tuto opravu hotfix od oddělení služeb zákazníkům a podpory společnosti Microsoft.

Poznámka: Pokud vyskytnout další problémy nebo jakékoli řešení potíží je vyžadován, pravděpodobně budete muset vytvořit zvláštní požadavek na službu. Výdaje na technickou podporu se týkají dalších otázek a problémů, které nelze vyřešit pomocí této opravy konkrétní opravy hotfix. Navštivte následující web společnosti Microsoft pro získání telefonního čísla na Zákaznické centrum, nebo pokud chcete vytvořit samostatnou žádost o podporu:
http://support.microsoft.com/contactus/?ws=support
Poznámka: Zobrazí formulář "Hotfix stažení k dispozici" jazyky, pro které je oprava hotfix k dispozici. Pokud váš jazyk není zobrazen, oprava hotfix není k dispozici pro daný jazyk.Globální verze této opravy má následující atributy souborů (nebo novější). Data a časy jednotlivých souborů jsou uvedeny ve formátu UTC (Coordinated Universal Time). Pokud zobrazíte informace o souboru, bude převedena na místní čas. Rozdíl mezi místním ČASEM a najít, použijte kartu časové pásmo v ovládacím panelu Datum a čas.
   Date         Time   Version           Size     File name
   -----------------------------------------------------------
   13-Nov-2002  16:36  5.0.2195.6127     118,896  Afd.sys
   22-Nov-2002  22:29  5.0.2195.6020     105,232  Msafd.dll
   22-Nov-2002  22:28  5.0.2195.6139     313,648  Tcpip.sys
   31-Jul-2001  00:15  5.0.2195.3988      16,240  Tdi.sys
   22-Nov-2002  22:29  5.0.2195.4874      17,680  Wshtcpip.dll

Prohlášení

Společnost Microsoft potvrzuje, že se jedná o problém v produktech této společnosti, které jsou uvedeny na začátku tohoto článku. Tyto potíže byly poprvé opraveny aktualizací Microsoft Windows 2000 Service Pack 4.

Jak potíže obejít

Upozornění: Použijete-li Editor registru nesprávně, můžete způsobit vážné problémy, které mohou vyžadovat přeinstalaci operačního systému. Společnost Microsoft nemůže zaručit, že potíže vzniklé v důsledku nesprávného použití Editoru registru budete moci vyřešit. Editor registru používáte na vlastní nebezpečí. Chcete-li tento problém vyřešit, nastavte hodnotu
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcip\Parameters\SynAttackProtect
0 (nula) nebo 1:
  1. Klepněte na tlačítko Start a potom klepněte na příkaz Spustit.
  2. Do pole Otevřít zadejte příkaz regedit a klepněte na tlačítko OK.
  3. Vyhledejte následující klíč registru a klepněte na něj:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcip\Parameters
  4. V pravém podokně poklepejte na
    SynAttackProtect
    .
  5. V poli Údaj hodnoty zadejte hodnotu 0 nebo 1 a klepněte na tlačítko OK.
  6. Ukončete program Editor registru.

Další informace

Hodnota registru
SynAttackProtect
slouží k harden zásobník TCP/IP proti odmítnutí útoků služby. Nakonfigurujte tuto hodnotu podle úroveň ochrany, které chcete nastavit. Další informace o hodnoty registru související na TCP, které můžete konfigurovat harden zásobník TCP/IP v počítačích, které jsou přímo připojeni k Internetu klepněte na následující číslo článku databáze Microsoft Knowledge Base:
315669Postupy: Harden zásobník TCP/IP před odmítnutí umísťováním Service v systému Windows 2000

Vlastnosti

ID článku: 332001 - Poslední aktualizace: 3. února 2014 - Revize: 2.7
Informace v tomto článku jsou určeny pro produkt:
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional Edition
Klíčová slova: 
kbnosurvey kbarchive kbmt kbautohotfix kbhotfixserver kbqfe kbnetwork kbwin2ksp4fix kbprb kbbug kbfix kbwin2000presp4fix KB332001 KbMtcs
Strojově přeložený článek
Důležité: Tento článek byl přeložen pomocí software společnosti Microsoft na strojový překlad, ne profesionálním překladatelem. Společnost Microsoft nabízí jak články přeložené překladatelem, tak články přeložené pomocí software na strojový překlad, takže všechny články ve Znalostní databázi (Knowledge Base) jsou dostupné v češtině. Překlad pomocí software na strojový překlad ale není bohužel vždy dokonalý. Obsahuje chyby ve skloňování slov, skladbě vět, nebo gramatice, podobně jako když cizinci dělají chyby při mluvení v češtině. Společnost Microsoft není právně zodpovědná za nepřesnosti, chyby nebo škody vzniklé chybami v překladu, nebo při použití nepřesně přeložených instrukcí v článku zákazníkem. Společnost Microsoft aktualizuje software na strojový překlad, aby byl počet chyb omezen na minimum.
Projděte si také anglickou verzi článku:332001

Dejte nám zpětnou vazbu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com