Help and Support
 

powered byLive Search

QoS Is Not Installed When Bandwidth Throttling Is Enabled Directly in the IIS Metabase

Article ID:332087
Last Review:December 3, 2007
Revision:3.3
This article was previously published under Q332087

SYMPTOMS

When you enable bandwidth throttling through a script such as Adsutil.vbs, you may see the following in the system event log:

Event Type: Warning
Event Source: W3SVC
Event Category: None
Event ID: 1071
Date: 8/14/2002
Time: 1:36:20 PM
User: N/A
Computer: JASBRBOX
Description: The World Wide Web Publishing Service failed to enable bandwidth throttling on site '1' because Quality of Service (QoS) Packet Scheduler (PSCHED) is not installed. For more information, see Help and Support Center at http://support.microsoft.com.

Back to the top

CAUSE

Bandwidth throttling requires that Quality of Service (QoS) be installed in order to function. When you enable bandwidth throttling in the Internet Services Manager (ISM) and QoS is not installed, QoS is installed automatically. When bandwidth throttling is enabled by setting the MaxBandWidth property directly in the IIS metabase, QoS is not automatically installed. PSCHED is a component of QoS.

Note If you want to make changes to the metabase while IIS is running, you must enable Direct Metabase Editing:
1.In the ISM, right-click the server name, and then click Properties.
2.Click to select the Enable Direct Metabase Edit check box, and then click OK.

Back to the top

RESOLUTION

To resolve the issue and make sure that bandwidth throttling is enabled, install QoS:
1.On the Start menu, click Control Panel.
2.Click Network Connections.
3.Click any of the listed connections, and then click Properties.
4.Click Install.
5.Select Service, and then click Add.
6.Select QoS Packet Scheduler, and then click OK to close all open dialog boxes.

Back to the top


APPLIES TO
Microsoft Internet Information Services 6.0

Back to the top

Keywords: 
kbpending kbprb KB332087

Back to the top

Article Translations

 

Related Support Centers

Other Support Options

  • Need More Help?
    Contact a Support professional by Email, Online or Phone.
  • Customer Service
    For non-technical assistance with product purchases, subscriptions, online services, events, training courses, corporate sales, piracy issues, and more.
  • Newsgroups
    Pose a question to other users. Discussion groups and Forums about specific Microsoft products, technologies, and services.