Help and Support
 

powered byLive Search

[NT] USB キーボードデバイス接続後に英語101キーボード配列になる

文書番号:416037
最終更新日:2004年5月4日
リビジョン:1.3
この記事は、以前は次の ID で公開されていました: JP416037

概要

日本語 106/109 USB キーボードや USB テンキーボードの接続後に、英語 101/102 キーボード配列で動作することがあります。 接続した USB キーボードだけではなく、PS/2 キーボード等のシステムに接続されたキーボードは、すべて英語 101/102 配列に変更されます。

先頭へ戻る

原因

この現象は、以下の原因により発生します。
1. 英語 101/102 USB キーボードとして定義されている PnP ID を使用しているチップが 搭載されている USB キーボード デバイス. 日本語 106/109 USB キーボードの中には、英語 101/102 USB キーボード用のチップ が搭載され、英語配列キーボードと同じ PnP ID を使用しているものがあります。 このタイプの日本語 106/109 USB キーボードが接続されると、Windows 2000 は、プ ラグ アンド プレイで英語 101/102 キーボードと認識し、システムのキーボード設定 が英語 101/102 キーボード配列に変更されます。
2. keyboard.inf ファイルで定義されていない USB キーボード デバイス 接続された USB キーボード デバイスの PnP ID が keyboard.inf ファイルで定義さ れていない場合、Windows 2000 のシステムはプラグ アンド プレイでそのモデル名を 識別することができません。 このタイプの日本語 106/109 USB キーボードや USB テンキーボードが接続された場 合、汎用 HID キーボード デバイスとして扱われます。 Windows 2000 の既定では、HID キーボード デバイスに対して英語 101/102 キーボー ド配列が指定されています。
Windows 2000 のシステムは 1 つのキーボード配列しか使用しないため、再起動後に接続されている全てのキーボードが英語 101/102 キーボード配列で動作します。

先頭へ戻る

回避策

キーボード配列を日本語 106/109 キーボード配列に変更したい場合には、デバイス マネージャから以下の手順で手動で日本語 106/109 キーボードに変更してください。
1. デバイス マネージャのキーボードにある[英語 101/102 キーボードまたは Microsoft Natual PS/2 キーボード]をダブルクリックします。
2. [ドライバ] タブを選択し [ドライバの更新] をクリックします。
3. ウィザードにしたがい、「このデバイスの既知のドライバを表示してその一覧から選 択する」にチェックをして [次へ] をクリックします。
4. 「このデバイス クラスのハードウェアをすべて表示」をチェックして、[日本語キー ボード (106/109 キー) ] を選択して [次へ] をクリックします。
5. ウィザードにしたがってドライバを更新してコンピュータを再起動します。

先頭へ戻る

状況

この問題は Windows 2000 Service Pack 3 で修正されています。

先頭へ戻る

詳細

日本語 106/109 配列として定義されている PnP ID を使用しているチップが搭載されているキーボード (例 : NEC 109 USB キーボード PK-KB001) が接続された場合は、Windows 2000 がプラグ アンド プレイで日本語 106/109 USB キーボードと検出するため、日本語 106/109 キーボード配列で動作します。

先頭へ戻る


この資料は以下の製品について記述したものです。
?Microsoft Windows 2000 Server
?Microsoft Windows 2000 Professional
?Microsoft Windows 2000 Advanced Server
?Microsoft Windows 2000 Datacenter Server

先頭へ戻る

キーワード:?
kbinfo 101 usb キーボード 106 KB416037

先頭へ戻る

"Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。"

Related Support Centers

Other Support Options

  • Need More Help?
    Contact a Support professional by E-mail, Online or Phone.
  • Customer Service
    For non-technical assistance with product purchases, subscriptions, online services, events, training courses, corporate sales, piracy issues, and more.
  • Newsgroups
    Pose a question to other users. Discussion groups and Forums about specific Microsoft products, technologies, and services.