文書番号: 418912 - 最終更新日: 2004年3月24日 - リビジョン: 1.2

mailto: を使用した送信するメールへの設定が適用されない

お知らせお使いのオペレーティング システムには適用しない情報が含まれている場合があります。
この記事は、以前は次の ID で公開されていました: JP418912

目次

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概要

この資料は、Web のメール送信フォームから mailto: を使用してメールを送信する場合、送信しようとするメールに対しての設定が適用されない現象について記述されています。

現象

Web のメール送信フォームから Post メソッドを使用し mailto: で設定された宛先に送信する場合、メール本文に追加される内容が適用されない場合があります。

原因

本現象は、Windows XP において、各ユーザーの既定メールクライアントのレジストリ情報に不足がある場合に発生いたします。
Windows XP の [スタート] メニューの [プロパティ] から、[[スタート] メニュー] 内に表示されるメール クライアントの設定を行った場合や、メール クライアントをインストールした場合などに、Windows XP のレジストリに HKEY_CURRENT_USER\Software\Clients\mail というレジストリ キーが生成されますが、この際に、レジストリ情報が完全に生成されないため、今回の現象が発生します。

再現手順


以下の手順により HKEY_CURRENT_USER\Software\Clients\mail に上記で説明したキーが作成されます。
  1. Windows XP の [スタート] ボタンを右クリックし、ショートカットメニューより [プロパティ] をクリックします。
  2. [[スタート] メニュー] タブの [[スタート] メニュー] を選択し、[カスタマイズ] ボタンをクリックします。
  3. [全般] タブを選択し、[スタートメニューでの表示] で [電子メール] のチェックをオンにし、一覧から任意のアプリケーションを選択します。
  4. [OK] を 2 回クリックし、開いた画面をすべて閉じます。

上記手順を実行後、続けて以下の手順を行います 。
次のソースコードを持つ htm ファイルをInternet Explore で開き、[送信] ボタンをクリックします。
<form action="mailto:[メールアドレス]" method="POST" enctype="text/plain" name="mail">

<input type="text" size="20" name="TextBox" value="test"><br>

<input type="submit" value="送信">

</form>

* [メールアドレス] には、送信先のメールアドレスを記入

結果


新規メール メッセージ画面が開き、送信先に指定したアドレスが表示されますが、本文部分には、TextBox で指定した文字が表示されません。

状況

弊社では本現象を Windows XP の問題として認識しております。

回避策

下記の操作で、Windows レジストリキーの HKEY_LOCAL_MACHINE のメールクライアント情報を HKEY_CURRENT_USER のキーに置き換えてコピーすることで現象を回避することをご検討ください。

警告
レジストリエディタの誤った使用は、システム全般に渡る重大な問題を引き起こす可能性があります。 こうした問題を解決するためには、Windows をインストールしなおさなければいけません。 Microsoft では、レジストリエディタを使用することによって引き起こされた障害の解決については、一切保証しておりません。 レジストリエディタを使用する場合には、お客様の責任において使用してください。

レジストリ HKEY_CURRENT_USER\Software\Clients\mail に不足しているレジストリ情報を追加します。
  1. Windows の [スタート] メニューをクリックして、[ファイル名を指定して実行] をクリックします。
  2. [名前] ボックスに regedit と入力し、[OK] をクリックします。
  3. [レジストリ エディタ] 画面で、以下のキーまで移動します。
    HKEY_LOCAL_MACHINE\Software\Clients\Mail
  4. HKEY_LOCAL_MACHINE\Software\Clients\Mail のサブツリー内にコンピュータにインストールされているメール クライアントの起動情報が保存されていることを確認します。
  5. [Mail] キーを選択し、[ファイル] メニューの [エクスポート] をクリックし、任意の名前を入力し [保存] をクリックします。
  6. メモ帳 を起動し、手順 5. で保存したレジストリ ファイルを開きます。
  7. [編集] メニューから、[置換] をクリックします。
  8. [検索する文字列] ボックスに、HKEY_LOCAL_MACHINE と入力します。
  9. [置換後の文字列] ボックスに、HKEY_CURRENT_USER と入力します。
  10. [すべて置換] ボタンをクリックします。
  11. 置換の作業が終了したら、[キャンセル] ボタンをクリックして [置換] 画面を閉じます。
  12. [ファイル] メニューより [上書き保存] をクリックして保存し、メモ帳を終了します。
  13. 手順 12. で上書き保存されたレジストリ ファイルをエクスプローラで表示して、ダブルクリックします。
  14. レジストリエディタの確認画面が表示され、ダブルクリックしたレジストリファイルの情報を追加するかどうか確認されますので、[はい] をクリックします。

上記操作を行うことで、必要な情報がレジストリキーに追加されます。
再度 mailto: の動作を確認し問題なければ、上記操作で作成したレジストリファイルは削除して問題ありません。

この資料は以下の製品について記述したものです。
  • Microsoft Windows XP Professional
  • Microsoft Office FrontPage 2003
  • Microsoft FrontPage 2002 Standard Edition
キーワード:?
kbbug KB418912
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