Help and Support

文書番号: 436201 - 最終更新日: 2004年10月2日 - リビジョン: 1.5

[WinMe] TrueType フォント キャッシュが破壊される

この記事は、以前は次の ID で公開されていました: JP436201

目次

すべて展開する | すべて折りたたむ

概要

フォントを Windows Me にインストールすることなしにソフトウェア的にフォントを追加するアプリケーション ソフトウェアを使用している場合、TrueType フォント キャッシュの内容が破壊される場合があります。

現象

TrueType フォント キャッシュの内容が破壊され、結果として以下の現象が出る場合があります。
  • TrueType フォントが表示されない
  • TrueType フォントが誤った字体 (縦書きフォント等別のフォント) で表示される
  • フォントのインストールがエラーとなる
  • フォントをインストールしようとするとコンピュータが応答を停止 (ハング) する
  • ウインドウの [最大化] ボタン ・ [最小化] ボタン ・ [閉じる] ボタンが正しく表示されない
  • アプリケーションがインストール済みのフォントを正しく認識しない

原因

Windows Me においてソフトウェア的にフォントを追加するアプリケーション ソフトウェアを使用している場合、特定条件下において TrueType フォント キャッシュに正しくないキャッシュ データを書き込む場合があるためです。 弊社ではこの問題を Windows Me の日本語版の問題と認識しております。なお、この問題は Windows Me 英語版では発生しません。

解決方法

この問題を解決するには、次のいずれかの方法を実行してください。

方法 1

  1. コンピュータを再起動します。BIOS の自動テスト (POST : Power On Self Test) 完了後、CTRL キーを押し、スタートアップメニューが表示されるのを待ちます。スタートアップ メニューから [Safe Mode] を選択します。スタート アップ メニューが表示されずに起動した場合には、起動が完了するのを待って再起動から再度行ってください。
  2. Safe Mode で通常どおりに Windows Me を再起動します。

方法 2

  1. Safe Mode で起動し、ttfCache ファイルを削除します。
    Safe Mode での起動に関しては、方法 1 を参照してください。

    注意 : ttfCache ファイルの属性は [隠しファイル] になっています。隠しファイルを表示するには、エクスプローラの [表示] メニューから [オプション] - [すべてのファイルを表示] - [OK] をクリックします。

  2. 通常どおり Windows Me を再起動します。

関連情報

Windows 95 で同じ現象が発生した場合には、以下の資料を参照してください。

文書番号 : 169504? (http://support.microsoft.com/kb/169504/JA/ )
タイトル : TrueType フォントが正しく表示されない

Windows 98、98 Second Edition で同じ現象が発生した場合には、以下の資料を参照してください。

文書番号 : 415567? (http://support.microsoft.com/kb/415567/JA/ )
タイトル : W98: TrueType フォント・キャッシュが破壊される

この資料は以下の製品について記述したものです。
  • Microsoft Windows Millennium Edition
キーワード:?
kbfont kbbug KB436201
"Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。"
Retired KB Articleサポート期間が終了した「サポート技術情報」資料に関する免責事項
この資料は、マイクロソフトでサポートされていない製品について記述したものです。そのため、この資料は現状ベースで提供されており、今後更新されることはありません。