Help and Support
 

powered byLive Search

ファイルが失われているか壊れていて Windows XP を起動できない場合に回復コンソールで修復する方法

文書番号:436927
最終更新日:2005年4月12日
リビジョン:1.4
この記事は、以前は次の ID で公開されていました: JP436927
目次

概要

この資料は、ファイルが存在しないか壊れているため、Windows XP を起動できない場合に回復コンソールを利用して、修復作業を行う方法を説明しています。

先頭へ戻る

現象

Windows XP ベースのコンピュータを起動または再起動しようとすると、次のいずれかのエラー メッセージが表示されることがあります。
次のファイルが存在しないかまたは壊れているため、Windows を起動できませんでした: \WINDOWS\SYSTEM32\CONFIG\SYSTEM

次のファイルが存在しないかまたは壊れているため、Windows を起動できませんでした: \WINDOWS\SYSTEM32\CONFIG\SOFTWARE Stop: c0000218 {レジストリ ファイル エラー} レジストリは、ハイブ (ファイル) \SystemRoot\System32\Config\SOFTWARE、そのログ、または代替ファイルを読み込めません。

先頭へ戻る

原因

この問題は、Windows XP インストールのシステム ハイブやソフトウェア ハイブが失われているか、または壊れている場合に発生する可能性があります。

先頭へ戻る

解決方法

この問題を解決するために、回復コンソール ツールを使用します。 Windows XP がインストールされているコンピュータ上で回復コンソールを使用するには、Windows XP 起動ディスクまたは Windows XP CD-ROM からコンピュータを起動する必要があります。

先頭へ戻る

Windows XP CD-ROM または Windows XP 用起動ディスクからコンピュータを起動できる場合

1. Windows XP CD-ROM をコンピュータの CD-ROM ドライブに挿入した状態で、コンピュータの電源を入れます。
または、Windows XP 用起動ディスクをフロッピーディスク ドライブに挿入し、コンピュータの電源を入れます。 コンピュータの電源が入っているときは、Windows が起動していなくても CD-ROM ドライブの排出ボタンを押すことにより、CD-ROM ドライブを動かすことができます。CD-ROM ドライブの使用方法はお使いのコンピュータ製造元または CD-ROM ドライブ製造元にご確認下さい。
2.Windows XP CD-ROM から起動する場合、"Press any key to reboot from CD..." の文字が画面に現れたら、Enter キーを押します。
 起動ディスクから起動の場合、Windows Setup の画面 (青) が表示されますので、画面に指示に従い、起動ディスクの 2 枚目から 6 枚目を順次挿入し、Enter キーを押してください。
3.セットアップの開始 メニューが表示されましたら、R キー (回復コンソール) を押します。
4. キーボードの種類を特定します。日本語キーボードをお使いの場合は、半角/全角 キーを押します。
5. キーボード選択の確認で問題が無い場合、Y キーを押します。
6. どの Windows インストールにログオンしますか? メッセージ表示されたら、Windows がインストールされているドライブの番号を入力し、Enter キーを押します。
例: 1: C:\WINDOWS と表示されている場合、"1" を入力し Enter キーを押します。以下、C:\WINDOWS が選択されたと仮定します。
注 : キーボード上の Num Lock キー ランプが消えている場合は、あらかじめ Num Lock キーを押してランプをつけてから数字キーをご使用ください。
7. Administrator のパスワードを入力し、Enter キーを押します。 Administrator のパスワードが空白の場合は、何も入力せずに Enter キーを押します。

: Administrator のパスワードとは Windows XP セットアップ時に指定した管理者 (Administrator) 用パスワードです。
8. C:\WINDOWS> の後に、cd system32\config と入力して、Enter キーを押します。

重要 : 上記のコマンドを実行してエラー メッセージが表示される場合、1 つずつのフォルダに対して、ディレクトリ変更コマンド (cd) を実行してください。

例 : C:\WINDOWS> の後に cd system32 と入力して、Enter キーを押します。
続いて、C:\WINDOWS\SYSTEM32> の後に cd config と入力して、Enter キーを押します。
9.C:\WINDOWS\SYSTEM32\CONFIG> の後に、dir system と入力して、Enter キーを押します。

: コンピュータの起動時に表示されていたエラー メッセージが \WINDOWS\SYSTEM32\CONFIG\SOFTWARE であった場合は、手順 9 から手順 12 の "system" を "software" にそれぞれ置き換えて入力してください。
10.「一致するファイルがありません」メッセージが表示され、コマンドを正常に実行できない場合、手順 12. に進みます。
11. 「1ファイル XXXXXXXXX バイト」メッセージが表示され、コマンドを正常に実行できた場合、C:\WINDOWS\\SYSTEM32\CONFIG> の後に、ren system system.bak と入力して、Enter キーを押します。

: このコマンド操作では画面上には C:\WINDOWS\SYSTEM32\CONFIG> 表示のまま、特にメッセージは表示されません。
12. C:\WINDOWS\SYSTEM32\CONFIG> の後に、copy c:\windows\repair\system と入力して、Enter キーを押します。
"1個のファイルをコピーしました。" 情報メッセージが表示されます。
13. フロッピーディスク ドライブおよび CD-ROM ドライブにディスクが挿入されている場合はディスクを取り出してください。
ディスクが挿入されていないことを確認の上、C:\WINDOWS\SYSTEM32\CONFIG> の後に、exit と入力し Enter キーを押して回復コンソールを終了します。コンピュータが再起動されます。

先頭へ戻る

回復コンソールを使用できない場合

"Windows XP CD-ROM または Windows XP 用起動ディスクからコンピュータを起動できる場合" に記載している方法で回復コンソールが使用できず、さらに FAT ファイル システム (NTFS ファイル システム以外) を使用している場合は、以下の手順に従います。
1.次のいずれかのオペレーティング システムの起動ディスクをフロッピーディスク ドライブに挿入し、コンピュータを起動します。
? Microsoft Windows Millennium Edition (Me)
?Microsoft Windows 98
?Microsoft Windows 95
2. A:\ の後に、C:\WINDOWS と入力します。

: フロッピーディスク ドライブが A:\ ドライブ とします。
3.この資料の手順 1 Windows XP CD-ROM または Windows XP 用起動ディスクからコンピュータを起動できる場合の 8.(cd sytem32\config と入力して、Enter キーを押す) からの手順に従います。
4.この作業を完了したら、起動ディスクを取り外し、コンピュータを再起動します。

先頭へ戻る

詳細

Windows XP 起動ディスクの作成方法

Windows XP には添付されていないため、 Windows XP 用起動ディスクを作成するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。なお、Windows XP 用起動ディスクを作成するにはインターネットに接続されているコンピュータが必要になります。
310994 (http://support.microsoft.com/kb/310994/JA/) Windows XP セットアップ ブート ディスクの入手方法
880413 (http://support.microsoft.com/kb/880413/JA/) CD-ROM から起動できないコンピュータに Windows XP をセットアップする方法

先頭へ戻る

回避策

Windows XP CD-ROM からコンピュータを起動できない場合

Windows XP CD-ROM からコンピュータを起動するには、コンピュータの基本入出力システム (BIOS) を CD-ROM ドライブから起動するように設定する必要があります。BIOS の設定で CD-ROM からコンピュータを起動できない場合で、フロッピーディスクから起動することができる場合は Windows XP 用起動ディスクを作成してください。

BIOS の設定はお使いのコンピュータ製造元、またはお使いのマザー ボードの製造元にご確認下さい。

先頭へ戻る

Windows XP が最初からインストールされたコンピュータ (Preinstall PC) をお使いの場合

Windows XP が最初からインストールされたコンピュータ (Preinstall PC) で、CD-ROM から起動できない、または Administrator でログオンできない場合は、回復コンソールを使用するためにあらかじめ "Windows XP 起動ディスクの作成方法" を確認の上 Windows XP 起動ディスクを作成してください。

なお、Windows XP 用起動ディスクを作成するにはインターネットに接続されているコンピュータが必要になります。

一部のPreinstall PCをお使いの場合、c:\windows\repair\system が存在せず、「解決方法」の手順12. にてエラーが発生する場合があります。この場合には、本回避策は適用できません。

先頭へ戻る

関連情報

セットアップ時の回復コンソールの使用方法を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
307654 (http://support.microsoft.com/kb/307654/JA/) [HOW TO] Windows XP での回復コンソールのインストールおよび使用方法

先頭へ戻る


この資料は以下の製品について記述したものです。
?Microsoft Windows XP Professional
?Microsoft Windows XP Home Edition

先頭へ戻る

キーワード:?
ファイルが失われている 回復コンソール 起動できない kbhowto KB436927

先頭へ戻る

"Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。"

Related Support Centers

Other Support Options

  • Need More Help?
    Contact a Support professional by E-mail, Online or Phone.
  • Customer Service
    For non-technical assistance with product purchases, subscriptions, online services, events, training courses, corporate sales, piracy issues, and more.
  • Newsgroups
    Pose a question to other users. Discussion groups and Forums about specific Microsoft products, technologies, and services.