Calcul automatique de l'âge

Numéro d'article: 463685 - Voir les produits auxquels s'applique cet article
Ancien nº de publication de cet article : F13685
Agrandir tout | Réduire tout

Résumé

QUESTION:
Comment calculer automatiquement l'âge d'une personne en fonction de sa
date de naissance ?

Résolution

Dans le tableur ou la Base de Données de Works pour Windows, vous pouvez
calculer automatiquement, par rapport à la date du jour, l'âge d'une
personne en fonction de sa date de naissance.

Pour cela, utilisez la formule suivante :

=SI(<champ><>"";ENT((MAINTENANT()-<champ>)/365,24);"")

où <champ> est le nom du champ (Base de Données) ou la référence de la
cellule (feuille de calcul) contenant la date de naissance.


Exemple pour la Base de Données :
---------------------------------
"Anniversaire" est le nom du champ contenant la date de naissance.

=SI(Anniversaire<>"";ENT((MAINTENANT()-Anniversaire)/365,24);"")

L'affichage en mode liste de la Base de Données donnera :
(dans notre exemple, la date du jour est le 19/06/1995)

Anniversaire Age

15/05/1985 10
28/02/1960 35
18/08/1970 24
20/09/1980 14


Exemple pour le tableur :
-------------------------
A1 contient la date de naissance.
B2 contient la formule =SI(A1<>"";ENT((MAINTENANT()-A1)/365,24);"")
Le résultat donnera :
(dans notre exemple, la date du jour est le 19/06/1995)

A B

1 15/05/1985 10

Vous pouvez utiliser la commande Recopier vers le bas du menu Edition
afin de recopier la formule sur autant de lignes que vous le désirez.

Remarque :
La formule donnée ci-dessus fait référence à la date système (date du
jour) en utilisant la fonction MAINTENANT().
Vous pouvez également utiliser cette formule pour calculer un nombre
d'années entre deux dates.
Dans ce cas vous remplacerez la fonction MAINTENANT() par le nom du champ
ou la cellule contenant la date de référence pour le calcul.

Propriétés

Numéro d'article: 463685 - Dernière mise à jour: lundi 26 juin 1995 - Version: 1.0
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Works 3.0 Standard
Mots-clés : 
calcul util KB463685
L'INFORMATION CONTENUE DANS CE DOCUMENT EST FOURNIE PAR MICROSOFT SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. L'UTILISATEUR ASSUME LE RISQUE DE L'UTILISATION DU CONTENU DE CE DOCUMENT. CE DOCUMENT NE PEUT ETRE REVENDU OU CEDE EN ECHANGE D'UN QUELCONQUE PROFIT.
Exclusion de responsabilité concernant les contenus obsolètes dans la Base de connaissances
Cet article concerne des produits pour lesquels Microsoft n'offre plus de support. Il est par conséquent fourni « en l'état » et ne sera plus mis à jour.

Envoyer des commentaires

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com