Recherche de valeur selon 2 critères

Numéro d'article: 465704 - Voir les produits auxquels s'applique cet article
Ancien nº de publication de cet article : F15704
Agrandir tout | Réduire tout

Symptômes


Je désire rechercher une valeur dans une matrice ou une base de données
selon deux critères.
Comment dois-je procéder ?


Résolution


Si la valeur recherchée est une valeur texte la formule sera la suivante:

{=INDEX(plage3;MAX(SI((crit1=plage1)*(crit2=plage2);LIGNE(plage3);0)))}
C'est une formule matricielle validée par la commande CTRL+SHIFT+ENTREE.

plage3 est la plage dans laquelle je recherche ma valeur.
crit1 et crit2 sont mes deux critères et correspondent chacun à une
référence de cellules.
plage1 est la plage dans laquelle je recherche la valeur correspondant à
crit1.
plage2 est la plage dans laquelle je recherche la valeur correspondant à
crit2.


Si la valeur recherchée est une valeur numérique, la formule ci-dessus
fonctionnera mais on peut aussi utiliser une autre formule matricielle
(validée par la commande CTRL+SHIFT+ENTREE) qui est:
{=SOMME(SI((crit1=plage1)*(crit2=plage2);plage3;0))}


EXEMPLE :

J'ai la base de données suivante en A1:D5 :
Nom Prénom Ville Note
Dupont Marie Paris 10
Durant Paul Marseille 15
Dupont Pierre Lyon 14
Durant Jacques Lille 18

en A8: Dupont
en B8: Pierre

en C8: je désire obtenir la ville correspondante à l'élève Dupont Pierre
La formule va être la suivante:
{=INDEX(C1:C5;MAX(SI((A8=A1:A5)*(B8=B1:B5);LIGNE(C1:C5);0)))}
Le résultat de la formule est Lyon.

en D8: je désire obtenir la note correspondante à l'élève Dupont Pierre
La formule va être la suivante:
{=SOMME(SI((A8=A1:A5)*(B8=B1:B5);D1:D5;0))}
Le résultat de la formule est 14.




MOTS-CLES :

La liste de(s) mot(s) suivant(s) permet une recherche plus efficace de
cette fiche technique :

condition conditions tableau

Propriétés

Numéro d'article: 465704 - Dernière mise à jour: mardi 23 août 2005 - Version: 1.3
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Excel 5.0 pour Macintosh
  • Microsoft Excel 5.0a pour Macintosh
  • Microsoft Excel 95 Standard
  • Microsoft Excel 95a
  • Microsoft Excel 5.0 Standard
  • Microsoft Excel 5.0 Standard
  • Microsoft Excel 5.0c
Mots-clés : 
kbhowto kbusage KB465704
L'INFORMATION CONTENUE DANS CE DOCUMENT EST FOURNIE PAR MICROSOFT SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. L'UTILISATEUR ASSUME LE RISQUE DE L'UTILISATION DU CONTENU DE CE DOCUMENT. CE DOCUMENT NE PEUT ETRE REVENDU OU CEDE EN ECHANGE D'UN QUELCONQUE PROFIT.
Exclusion de responsabilité concernant les contenus obsolètes dans la Base de connaissances
Cet article concerne des produits pour lesquels Microsoft n'offre plus de support. Il est par conséquent fourni « en l'état » et ne sera plus mis à jour.

Envoyer des commentaires

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com