Cómo recuperar documentos dañados

Id. de artículo: 550341 - Ver los productos a los que se aplica este artículo
Este artículo se publicó anteriormente con el número E10342
Expandir todo | Contraer todo

Resumen

El hecho de manejar un documento que esté dañado puede provocar errores o comportamientos inusuales en Microsoft Word principalmente porque ante este tipo de fallos la aplicación intenta solventarlos por sí misma cayendo en un mal funcionamiento.

La mejor forma de protegerse contra las consecuencias que puede originar un documento dañado es tener siempre una copia de seguridad del mismo.

Este artículo ofrece procedimientos para identificar, recuperar o prevenir la corrupción de documentos de Word para Windows.

Más información

IDENTIFICACIÓN DE UN DOCUMENTO CORRUPTO

Documentos corruptos a menudo manifiestan un comportamiento que no forma parte del diseño del programa (por ejemplo, repaginación infinita, formato y diseño incorrecto del documento, caracteres ilegibles en pantalla, mensajes de error durante el proceso, cuelgues del sistema cuando se carga o se visualiza el documento o cualquier otro comportamiento insólito que no puede ser atribuido al funcionamiento normal del programa).

Estas características también pueden ser causadas por factores diferentes a la corrupción de ficheros. Para excluir otros factores, seguir los siguientes pasos:
  1. Comprobar si existe un comportamiento similar en otros documentos.
  2. Comprobar si existe un comportamiento similar en otras aplicaciones.
  3. Comprobar características similares en otros programas.
  4. Probar el documento en otro ordenador e intentar duplicar el comportamiento.
  5. Instalar un controlador de impresora diferente e intentar reproducir este comportamiento.
  6. Renombrar las plantillas adjuntas al documento e intentar reproducir el problema.
  7. Cambiar otros componentes del sistema (como controladores de vídeo o fuentes) e intentar reproducir este comportamiento. Por ejemplo, si se está usando una versión de fabricante del controlador de vídeo, cambiar al controlador de vídeo de Microsoft Windows utilizando el programa de instalación de Windows.
  8. Deshabilitar cualquier programa de terceros que se estén ejecutando (por ejemplo, programas residentes tipo TSRs, administrador de fuentes, protectores de pantalla).
Si el problema sucede sólo con un único documento después de comprobar los pasos descritos arriba, el documento probablemente esté corrupto.

PRUEBAS A HACER CUANDO EL DOCUMENTO SE ABRE BIEN PERO SE COMPORTA DE FORMA EXTRAÑA

Existen diferentes técnicas que se pueden utilizar para tratar de corregir un documento corrupto. El método a utilizar dependerá de la naturaleza y de la gravedad del comportamiento manifiesto. Aunque muchos de los métodos descritos posteriormente tienen éxito, no todos los documentos corruptos pueden ser recuperados. La creación de copias de seguridad de los documentos es la mejor manera de recuperar un documento corrupto.



MÉTODO 1: Convertir el documento a otro formato y luego volver a recuperarlo a formato Word:

Este es el método más fácil y completo para recuperar documentos; procure intentar este método el primero de todos. Guardar el documento en formato RTF. Este formato protege el formato del documento de Word para Windows. Después de guardarlo en formato RTF, reabrir el documento en Word para Windows y convertirlo desde el formato RTF. Si este método tiene éxito, la corrupción del fichero ha sido eliminada durante la conversión. Si la corrupción persiste después de abrir el documento guardado en formato RTF, tratar de guardar el archivo en los siguientes formatos:
Formatos de otros procesadores de textos.

Sólo Texto.
NOTA: Guardar archivos con formato Sólo Texto normalmente corrige el problema de corrupción, pero todo el formato del documento se pierde. Este método requiere reformatear todo el documento, por lo que sólo se deberá utilizar cuando otros formatos de archivos fallan al intentar corregir el problema.



MÉTODO 2: Copiar todo excepto la última marca de párrafo a un nuevo documento:

Word para Windows asocia una amplia variedad de formatos con la última marca de párrafo del documento, sobre todo formato de sección y estilos. Si se copia todo excepto esta última marca de párrafo a un nuevo documento la corrupción puede quedar en el documento original, y no asociarse al nuevo documento. En este nuevo documento será necesario volver a dar este formato de estilo y sección.

NOTA: Se puede seleccionar todo excepto la última marca de párrafo presionando las teclas CTRL+FIN, y seguidamente CTRL+MAYUSCULAS+INICIO.



MÉTODO 3: Copiar las porciones NO corruptas del documento a un nuevo documento:

A veces se puede determinar la localización de la corrupción del fichero en el documento. En estos casos, copiar todo excepto la parte corrupta a un nuevo archivo, y seguir los siguientes pasos para reconstruir el documento:
  1. Después de copiar las partes NO corruptas al nuevo archivo, guardar el archivo corrupto con formato Sólo Texto.
  2. Abrir el fichero en formato Sólo texto. Copiar el texto de este fichero y pegarlo en el archivo que contiene las porciones no corruptas del documento.
  3. Dar formato de nuevo a las secciones que se han pegado en el paso 2, y guardar el documento recuperado.


PRUEBAS A HACER CUANDO EL DOCUMENTO NO SE PUEDE ABRIR

Existen diferentes técnicas que se pueden utilizar para tratar de abrir un documento que no se abría. El método a usar depende de la naturaleza y la gravedad de la corrupción del documento.

MÉTODO 1: Abrir el documento de Word dañado en modo borrador.

A veces (no siempre, debido a la naturaleza del documento dañado) se puede abrir un documento con éxito en modo borrador cuando no se puede abrir en otros modos. Una vez abierto el archivo, se podrá recuperar o reparar el archivo.

Para cambiar al modo borrador en Word, elegir la opción Normal, en el menú Ver. Después seleccionar Opciones en el menú Herramientas, elegir la ficha Ver y activar la opción Fuente de Borrador

-o-

Desde Word 6.0/7.0 ejecutar la siguiente macro que abre el documento dañado y activa el modo borrador.

   Sub Main

      ActualizarPantalla 0
      ArchivoAbrir.Nombre = "FICHERO.DOC"  
      HerramOpcionesVer.FuentesBorrador = 1
      ActualizarPantalla 1

   End Sub
NOTA: En la macro anterior, FICHERO.DOC deberá ser sustituido por el nombre del fichero corrupto.

Usando esta macro, se podrá abrir el documento dañado que de otra manera no es posible debido al daño que afecta a especificar impresora, diseño de página o actualizaciones de pantalla en Word. Por ejemplo, si el Error de protección General (GPF) ocurre en Word antes de que el documento se abra, se puede evitar este error abriendo el documento con esta macro.



MÉTODO 2: Insertar el documento como un fichero al final de un documento nuevo.

La marca de final de párrafo contiene información general sobre el documento. Si el documento está dañado, se podría recuperar el texto si llegará a ser posible acceder a ese final de párrafo.

Para acceder al documento, pero obviando el final de párrafo, siga los siguientes pasos:
  1. Crear un documento nuevo.
  2. En el menú insertar, elegir fichero.
  3. En el cuadro de diálogo de Insertar fichero, localizar y seleccionar el documento dañado y pulsar aceptar.


MÉTODO 3: Abrir el documento mediante vínculos (vinculando un fichero en buenas condiciones a un documento vacío y después cambiando la fuente del vínculo al documento dañado). Este procedimiento sólo funcionará con Word para Windows versiones 2.0, 7.0 y 97 (no versión 6.0).

Seguir los siguientes pasos:
  1. Crea un nuevo documento. En este nuevo documento escribir lo siguiente: Esta es una prueba. Guardar el documento con el nombre PRUEBA.DOC.
  2. En el menú Edición, elegir Seleccionar Todo.
  3. En el menú Edición, seleccionar Copiar.
  4. En el menú Archivo, seleccionar Nuevo.
  5. En el menú Edición, seleccionar Pegado Especial.
  6. Seleccionar cualquiera de las opciones de formato RTF o Texto sin formato y elegir Pegar con vínculo. Seleccionar "Aceptar".
  7. En el menú Edición, seleccionar Vínculos.
  8. Cuando el cuadro de diálogo de Vínculos aparece, seleccionar el nombre del archivo del primer documento vinculado y seleccionar el botón "Cambiar Fuente" (en Word 2.x el botón es "Cambiar vínculo").
  9. El cuadro diálogo Abrir pregunta sobre cuál es el fichero al que se quiere cambiar el vínculo. Seleccionar el documento que no se puede abrir en Word (el documento dañado) y seleccionar el botón "Abrir".
  10. Hacer clic en el botón "Aceptar" del cuadro de diálogo Vínculos (en Word 2.x, introducir la ruta y el nombre del archivo y "Aceptar").
  11. Los datos y texto del documento dañado que aparecerán serán aquellos datos y texto que se haya podido recuperar. Desde el menú Edición, seleccionar Vínculos y seleccionar el botón "Romper vínculo" (en Word 2.x, "Cancelar el vínculo").
Ahora ya es posible dar de nuevo formato al documento y guardar el texto recuperado. Este método funciona porque al vincular parte de la información de la cabecera del archivo no se lee. Esto permite abrir el archivo si esta parte de la cabecera es el área dañada del documento.



MÉTODO 4: Abrir el archivo en Microsoft Write o Microsoft Wordpad para eliminar la información de la cabecera del archivo.
  1. Ir al Administrador de Programas de Microsoft Windows. Desde el menú Archivo, seleccionar Ejecutar.
  2. En la línea de comando escribir Wordpad en Windows 95 o Write en Windows 3.1, y elegir el botón "Aceptar" para iniciar la aplicación.
  3. En el menú Archivo, seleccionar Abrir.

    NOTA: En Windows 95, el archivo puede abrirse sin necesidad de convertirlo ó limpiarlo. Si es este el caso, guardar el archivo con un nombre nuevo y abrirlo en Word 7.0.
  4. En el cuadro Nombre de fichero, teclear la ruta y el nombre del archivo del documento corrupto de Word para Windows. Seleccionar el botón "Aceptar". Por ejemplo, si el documento se llama PRUEBA.DOC y se encuentra en el directorio de Word para Windows en la unidad C, se debería escribir lo siguiente:
    C:\WINWORD\PRUEBA.DOC
    Aparecerá un cuadro de diálogo que preguntará si se quiere convertir el archivo. Seleccionar el botón "No Convertir".
  5. Ahora el documento se ha abierto como un archivo de texto. Los caracteres binarios deberían aparecer al principio y al final del documento. Borrar estos caracteres.
  6. Desde el menú Archivo, seleccionar Guardar Como. En el cuadro Nombre de archivo escribir un nuevo nombre con la extensión.DOC. Antes de seleccionar el botón "Aceptar" comprobar el nombre del directorio en el cual será guardado para localizarlo después fácilmente desde Word para Windows.
  7. En el menú Archivo, seleccionar Salir.
  8. Iniciar Word para Windows. En el menú Archivo, seleccionar Abrir.
  9. En el cuadro Nombre de Archivo, teclear la ruta y el nombre del archivo nuevamente creado y seleccionar el botón "Aceptar".
  10. En el cuadro de diálogo de Convertir Archivo, seleccionar la opción Texto MS-DOS. Seleccionar el botón "Aceptar" y abrir el fichero de texto en Word para Windows.
  11. En el menú Archivo, seleccionar Guardar Como.
  12. En Word para Windows 2.0, seleccionar "Documento de Word (*.doc) en el cuadro "Guardar archivo como". En Word para Windows 1.x, elegir el botón Opciones y seleccionar "Normal" en el cuadro "Formato de Archivo".
  13. Escribir el nombre nuevo con la extensión.DOC en el cuadro "Nombre de fichero" y seleccionar el botón "Aceptar". Este archivo ahora está en formato Normal de Word para Windows. Ahora ya es posible reabrirlo y reemplazar cualquier gráfico, campo o formato necesario.
NOTA: Microsoft Wordpad 1.0 puede leer y escribir en documentos de Word 6.0 y posteriores, convirtiendo el fichero automáticamente y conservando todo el formato del documento que Wordpad soporte. Los documentos que normalmente no se pueden abrir, sí que se suelen poder abrir desde WordPad. Las tablas se suelen convertir a texto separado por tabuladores pero suelen conservar por lo menos la estructura de filas/columnas.



MÉTODO 5: Eliminar la información de la cabecera del fichero.

Se recomienda usar este método sólo si el resto de los métodos fallan. Cuando no se puede abrir ningún documento corrupto en Word para Windows (normalmente porque la corrupción está en la cabecera del fichero) se puede eliminar esta cabecera de fichero y abrir el documento como Sólo texto. Cuando se elimina la cabecera del fichero, todo el formato del mismo es perdido.
  1. Desde el prompt del MS-DOS, teclear lo siguiente y entonces presionar INTRO (ó ENTRAR):
    copy con+FICHERO.DOC NUEVO.DOC
    donde FICHERO.DOC es el nombre del archivo corrupto y NUEVO.DOC es el nombre del nuevo archivo. (Esto produce que la palabra "CON" aparezca en la pantalla y el cursor parpadee).
  2. Presionar la tecla de espaciado doce veces.
  3. Presionar la tecla F6 y pulsar INTRO (ó ENTRAR).
  4. Iniciar Word para Windows y abrir el nuevo fichero (NUEVO.DOC).
  5. Borrar los caracteres extraños que aparecen al principio y final del fichero. Normalmente el texto aparecerá intacto en la mitad del archivo.
  6. Reformatear el documento y guardarlo en formato de Word para Windows.

    NOTA: Si el archivo fue guardado en Word para Windows con la opción "Permitir guardar rápidamente" seleccionada, el texto aparecerá en bloques discontinuos. Este texto se deberá reordenar y reformatear. Con esta opción de guardado activada, a intervalos regulares van guardando los cambios del documento (este método es más rápido y gasta menos memoria que guardar el documento completo). Para más información sobre cómo deshabilitar la característica de 'Permitir guardar rápidamente', consulte el siguiente artículo de La Knowledge Base de Microsoft:
    71999 Disabling the Fast Save Feature in Word for Windows

Referencias

Para más información sobre cómo recuperar el texto de cualquier fichero convertido de Word 97 consulte el siguiente artículo de la Knowledge Base de Microsoft:
156573 WD97: How to recover text from Any File

Propiedades

Id. de artículo: 550341 - Última revisión: viernes, 20 de mayo de 2005 - Versión: 3.2
La información de este artículo se refiere a:
  • Microsoft Word 1.0 Standard Edition
  • Microsoft Word 2.0 Standard Edition
  • Microsoft Word 6.0 Standard Edition
  • Microsoft Word 2.0a
  • Microsoft Word 6.X-7.X, versión 1.x 2.x 6.0x 7.x 2.0b
  • Microsoft Word 2.0c
  • Microsoft Word 6.0a
  • Microsoft Word 6.0c
  • Microsoft Word 1.1 Standard Edition
  • Microsoft Word 1.1 Standard Edition
  • Microsoft Word 2.0c
  • Microsoft Word 95a
  • Microsoft Word 95a
Palabras clave: 
corrupto dañado documento q87856 KB550341
Renuncia a responsabilidad de los contenidos de la KB sobre productos a los que ya no se ofrece asistencia alguna
El presente artículo se escribió para productos para los que Microsoft ya no ofrece soporte técnico. Por tanto, el presente artículo se ofrece "tal cual" y no será actualizado.

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com