Artigo: 555146 - Última revisão: terça-feira, 22 de Junho de 2004 - Revisão: 1.0

Como pode recriar ficheiro STM no Exchange 2000 / 2003

Author: Yuval Sinay MVP
Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.
Expandir tudo | Reduzir tudo

Sintomas

Quando é executado comando ESEUTIL /P ou eseutil /mh, poderá obter erro que indicam que o ficheiro *.STM não corresponde ao ficheiro *.EDB que reside no servidor.
Normalmente, neste caso, o serviço Information Store não pode montar o arquivo local e-mail / pública.

Causa

Existe algumas razões para *.STM ficheiro danos:
 
software anti-vírus a. periodicamente pesquisa o *.EDB ou / e ficheiro *.STM.
 
b. O *.EDB ou / e tamanho *.STM aumenta significativamente.
 
problema de hardware c..
 

Resolução

Utilizando as instruções apresentadas neste guia podem perder dados importantes, e assim deve apenas ser utilizado como um último reordena. Trata-se recomendar que efectue cópia segurança as bases de dados antes de implementar estas instruções. Sempre considere a utilização de uma cópia de segurança válida em vez destas instruções.
 
A quantidade dos dados que é possível que perca depende o software cliente de correio - se toda a gente utilizarem o Outlook (protocolo de MAPI), seguida, vão existir muito pouca dados do utilizador no ficheiro.STM. É possível que perca algumas nas mensagens que ainda não foi entregue ainda de trânsito. Se os clientes ligar através de POP3 ou IMAP seguida, a maior parte dos respectivos material vai ser no ficheiro.STM, e a respectiva perda irá ser catastrófica aos mesmos. Se os clientes utilizarem o Outlook Web Access, as mensagens serão no ficheiro.EDB, mas serão no ficheiro.STM anexos enviados.
 
 
1. Pare qualquer software antivírus no servidor.
 
2. Parar o serviço Microsoft Exchange System Attendant " ".
 
     Nota: esta fase impede os utilizadores a utilizar o servidor.
 
3. Vá para " Iniciar "-> " Executar " e escrever " regedit " e prima no botão " Entrar ".
 
Navegue para: 4.

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeIS\VirusScan]
 
    No lado direito da tela altere o valor de " activar " de 1 para 0.
 
Executar comando eseutil /mh a Verity a necessidade de recriar do ficheiro *.STM: 5.
 
       eseutil /mh Files\Exchsrvr\MDBDATA\priv1.edb C:\Program " "

       eseutil /mh Files\Exchsrvr\MDBDATA\pub1.edb C:\Program " "

    Nota: se os ficheiros *.EDB residem em Outros locais, poderá ter de alterar o caminho para este ficheiros na eseutil /mh frase.
 
6. Execute ESEUTIL comando /createstm /p para criar do ficheiro *.STM:
 
            Se o ficheiro *.STM arquivo privadas da caixa de correio pode necessitar de recriar, utilize o comando que se segue:
 
            eseutil /p /createstm Files\Exchsrvr\MDBDATA\priv1.edb C:\Program " "
 
       Se o ficheiro *.STM arquivo público pode necessitar de recriar, utilize o comando que se segue:
 
      eseutil /p /createstm Files\Exchsrvr\MDBDATA\pub1.edb C:\Program " "
 
7. Vá para " Iniciar "-> " Executar " e escrever " regedit " e prima no botão " Entrar ".
 
Navegue para: 8.

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeIS\VirusScan]
 
    No lado direito da tela altere o valor de " activar " de 0 para 1.
 
9. Iniciar serviço Microsoft Exchange System Attendant " ".
 
10. Abra Exchange " gestor de sistema ". Navegue para o arquivo armazenar / Public da caixa de correio problemático.
 
11. Execute " Agente de Limpeza da caixa de correio " em cada loja da caixa de correio e escolher " Restabelecer ligação todas as caixas de correio ".
 
Abrir o arquivo armazenar / Public problemática da caixa de correio, clique com o botão direito do clique no arquivo armazenar / Public da caixa de correio e escolher " Propriedades " 12. opcional:
         Prima no separador " base de dados " e marcar a caixa de verificação " Esta base de dados pode ser substituída por um restauro ".
 
13. Montar o arquivo armazenar / Public da caixa de correio.
 
   Nota: se você iniciar " Microsoft Exchange System Attendant " serviço na fase 9, deve o arquivo armazenar / pública da caixa de correio
                ser montagem automaticamente.
 
14. Inicie o software anti-vírus que se encontrava parar nas fase 1.
 
15. Efectuar cópia de segurança completa às bases de dados do Exchange e o servidor local.

Mais Informação

XADM: o Exchange 2000 Server o Eseutil da linha de comandos parâmetros
http://support.microsoft.com/default.aspx?scid=kb;EN-US;317014
 
Como para utilizar o utilitário Eseutil com vista a testar log de transacções ficheiros para danificar no Exchange 2000 Server e no Exchange Server 2003
http://support.microsoft.com/default.aspx?scid=kb;EN-US;248122
 
XADM: Exchange e software anti-vírus
http://support.microsoft.com/default.aspx?scid=kb;[LN];328841
 
XADM: Ramificações de a executar o /P ESEUTIL ou comando /R /D EDBUTIL
http://support.microsoft.com/?id=259851
 
Exchange Server 2003 de recuperação de desastres Planning Guide pré-visualização:
http://www.microsoft.com/downloads/details.aspx?FamilyId=784BBEA2-28DD-409A-8368-F9914E993B28&displaylang=en

A informação contida neste artigo aplica-se a:
  • Microsoft Exchange Server 2003 Enterprise Edition
  • Microsoft Exchange 2000 Enterprise Server
  • Microsoft Exchange 2000 Server Standard Edition
Palavras-chave: 
kbpubtypecca kbpubmvp kbhowto KB555146 KbMtpt kbmt
Tradução automáticaTradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine translation ou MT), não tendo sido portanto revisto ou traduzido por humanos. A Microsoft tem artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais. O objectivo é simples: oferecer em Português a totalidade dos artigos existentes na base de dados do suporte. Sabemos no entanto que a tradução automática não é sempre perfeita. Esta pode conter erros de vocabulário, sintaxe ou gramática? erros semelhantes aos que um estrangeiro realiza ao falar em Português. A Microsoft não é responsável por incoerências, erros ou estragos realizados na sequência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza actualizações frequentes ao software de tradução automática (MT). Pedíamos-lhe o favor de preencher o formulário existente no fundo desta página caso tenha encontrado erros neste artigo e tenha possibilidade de colaborar no processo de aperfeiçoamento desta ferramenta. Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 555146  (http://support.microsoft.com/kb/555146/en-us/ )
Community Solutions ContentCOMMUNITY SOLUTIONS CONTENT DISCLAIMER
MICROSOFT CORPORATION AND/OR ITS RESPECTIVE SUPPLIERS MAKE NO REPRESENTATIONS ABOUT THE SUITABILITY, RELIABILITY, OR ACCURACY OF THE INFORMATION AND RELATED GRAPHICS CONTAINED HEREIN. ALL SUCH INFORMATION AND RELATED GRAPHICS ARE PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND. MICROSOFT AND/OR ITS RESPECTIVE SUPPLIERS HEREBY DISCLAIM ALL WARRANTIES AND CONDITIONS WITH REGARD TO THIS INFORMATION AND RELATED GRAPHICS, INCLUDING ALL IMPLIED WARRANTIES AND CONDITIONS OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, WORKMANLIKE EFFORT, TITLE AND NON-INFRINGEMENT. YOU SPECIFICALLY AGREE THAT IN NO EVENT SHALL MICROSOFT AND/OR ITS SUPPLIERS BE LIABLE FOR ANY DIRECT, INDIRECT, PUNITIVE, INCIDENTAL, SPECIAL, CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER INCLUDING, WITHOUT LIMITATION, DAMAGES FOR LOSS OF USE, DATA OR PROFITS, ARISING OUT OF OR IN ANY WAY CONNECTED WITH THE USE OF OR INABILITY TO USE THE INFORMATION AND RELATED GRAPHICS CONTAINED HEREIN, WHETHER BASED ON CONTRACT, TORT, NEGLIGENCE, STRICT LIABILITY OR OTHERWISE, EVEN IF MICROSOFT OR ANY OF ITS SUPPLIERS HAS BEEN ADVISED OF THE POSSIBILITY OF DAMAGES.