Windows ouvre une session et se déconnecte immédiatement

Cet article décrit un problème dans lequel vous ne pouvez pas vous connecter au système et vous êtes invité à entrer le nom d’utilisateur et le mot de passe à plusieurs reprises.

Produit concerné : Windows Server 2003
Numéro de la base de connaissances d’origine : 555648

Symptômes

Windows se connecte et se déconnecte immédiatement lorsque vous essayez de vous connecter à Windows. Lorsque vous tapez le nom d’utilisateur et le mot de passe, la boîte de dialogue Nom d’utilisateur et Mot de passe s’affiche à nouveau. Vous essayez d’y entrer, mais en vain.

Cause

Vous ne pouvez pas vous connecter au système à l’aide du mode normal ou du mode sans échec. Cela se produit uniquement lorsque le service Winlogon tente de charger l’interpréteur de commandes Windows par défaut (explorer.exe) et l’interpréteur de commandes utilisateur (userinit.exe) à partir du Registre. Ce service recherche Explorer.exe et Userinit.exe dans le chemin d’accès suivant du Registre :

HKLM\Software\Microsoft\Windows NT\CurrentVersion\Winlogon

Résolution

Modifiez ces valeurs et tapez le chemin d’accès correct de l’interpréteur de commandes :

Shell = explorer.exe
Userinit=X:\windows\system32\userinit.exe

Remarque

Ces fichiers peuvent également être supprimés par des logiciels espions. Vous devrez peut-être les extraire à l’aide du CD-ROM Windows.

Étapes de correction de ce problème

  • Ouvrez une session sur un ordinateur en réseau.

  • Exécutez Regedit.exe.

  • Pointez votre curseur sur HKEY_LOCAL_MACHINE.

  • Sélectionnez File>Connect Remote Registry.

  • Tapez le nom de l’ordinateur (ordinateur infecté).

  • Accédez à l’emplacement suivant dans le registre de l’ordinateur de destination ou infecté :

    HKLM\Software\Microsoft\Windows NT\CurrentVersion\Winlogon

  • Modifiez ces deux valeurs dans le volet droit :

    Shell
    Userinit

  • Remplacez ces deux valeurs par

    Shell=explorer.exe
    Userinit = x:\windows\system32\userinit.exe

  • Quittez le Registre.

  • Redémarrez l’ordinateur infecté.

  • Vous devriez être en mesure de vous connecter à l’ordinateur.

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