The system cannot log you on due to the following error: The RPC server is unavailable

Article translations Article translations
Article ID: 555839 - View products that this article applies to.
Author: Yuval Sinay MVP
Expand all | Collapse all

SUMMARY

The following article will help you to resolve the error "The system cannot log you on due to the following error: The RPC server is unavailable"

SYMPTOMS

During logon to the domain the following error may appear:
 
 "The system cannot log you on due to the following error: The RPC server is unavailable"

CAUSE

 
There can be a few reasons for this problem:
 
     1. Incorrect DNS settings.
 
     2. Incorrect Time and Time zone settings.
 
     3. The "TCP/IP NetBIOS Helper" service isn't running.
 
     4. The "Remote Registry" service isn't running.
 
 

RESOLUTION

 
  1. Verity correct DNS settings.
 
               Troubleshooting "RPC Server is Unavailable" in Windows
               http://support.microsoft.com/kb/224370
 
    2. Verity correct Time and Time Zone settings.
 
    3. Verity that "TCP/IP NetBIOS Helper" is running and set to auto start after restart.
 
    4. Verity that "Remote Registry" is running and set to auto start after restart.
 
 
  •      Its recommended to reboot the computer after changing the required settings.
 
 

MORE INFORMATION

 
Using Windows Server 2003 in a Managed Environment
Windows Time Service
 
http://www.microsoft.com/technet/prodtechnol/windowsserver2003/technologies/security/ws03mngd/26_s3wts.mspx
 
 
You receive a "The RPC server is unavailable" error message when you open Disk Management in Windows XP
 
http://support.microsoft.com/kb/884564
 
Troubleshooting "RPC Server is Unavailable" in Windows
 
http://support.microsoft.com/kb/224370
 
 

Properties

Article ID: 555839 - Last Review: December 22, 2006 - Revision: 1.0
APPLIES TO
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows 2000 Enterprise Edition
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows 2000 Standard Edition
  • Microsoft Windows XP Professional
Keywords: 
kbpubmvp kbpubtypecca kbhowto KB555839
COMMUNITY SOLUTIONS CONTENT DISCLAIMER
MICROSOFT CORPORATION AND/OR ITS RESPECTIVE SUPPLIERS MAKE NO REPRESENTATIONS ABOUT THE SUITABILITY, RELIABILITY, OR ACCURACY OF THE INFORMATION AND RELATED GRAPHICS CONTAINED HEREIN. ALL SUCH INFORMATION AND RELATED GRAPHICS ARE PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND. MICROSOFT AND/OR ITS RESPECTIVE SUPPLIERS HEREBY DISCLAIM ALL WARRANTIES AND CONDITIONS WITH REGARD TO THIS INFORMATION AND RELATED GRAPHICS, INCLUDING ALL IMPLIED WARRANTIES AND CONDITIONS OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, WORKMANLIKE EFFORT, TITLE AND NON-INFRINGEMENT. YOU SPECIFICALLY AGREE THAT IN NO EVENT SHALL MICROSOFT AND/OR ITS SUPPLIERS BE LIABLE FOR ANY DIRECT, INDIRECT, PUNITIVE, INCIDENTAL, SPECIAL, CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER INCLUDING, WITHOUT LIMITATION, DAMAGES FOR LOSS OF USE, DATA OR PROFITS, ARISING OUT OF OR IN ANY WAY CONNECTED WITH THE USE OF OR INABILITY TO USE THE INFORMATION AND RELATED GRAPHICS CONTAINED HEREIN, WHETHER BASED ON CONTRACT, TORT, NEGLIGENCE, STRICT LIABILITY OR OTHERWISE, EVEN IF MICROSOFT OR ANY OF ITS SUPPLIERS HAS BEEN ADVISED OF THE POSSIBILITY OF DAMAGES.

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com