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Event ID 12014 may appear in Exchange 2007 Application Event Log

Author: Yuval Sinay MVP
Article ID:555855
Last Review:April 5, 2007
Revision:1.0

SUMMARY

The following knowledgebase will help you to resolve Event ID 12014

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SYMPTOMS

 
1.Event ID 12014 may appear in the Application event log of CAS/HUB Transport/Edge server:
 
         "Microsoft Exchange couldn't find a certificate that contains the domain name mail.domainname.com
         in the personal store on the local computer. Therefore, it is unable to offer the STARTTLS SMTP
         verb for any connector with a FQDN parameter of mail.domainname.com.
         Verify the connector configuration and the installed certificates to make sure that there is
         a certificate with a domain name for every connector FQDN."

 
2. The SMTP connector may fail to support TLS connection.
 
 

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CAUSE

 
The Exchange server, may setup to use wrong certificate or doesn't setup to use certificate.
 
The certificate should reflect the external FQDN name of the server.
 

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RESOLUTION

 
 
1. Open "Exchange Management Shell".
 
2. Write "get-ExchangeCertificate" and press on "Enter" button.
 
3. Write down the Thumbprint of the certificate that reflect the required FQDN name of the server.
 
4. Review the current certificate that use by the Exchange server and
 
         each certificate function.
 
5. Write "Enable-ExchangeCertificate -Thumbprint 2afd26617915932ad096c48eb3b847fc7457662 -Services "SMTP"
 
       and press on 'Enter" button.
 
The value of -Thumbprint obtained in stage 3.
 
6. Restart the Exchange server.
 
 
 

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MORE INFORMATION

 
Creating a Certificate or Certificate Request for TLS
 
http://technet.microsoft.com/en-us/library/aa998840.aspx

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APPLIES TO
Microsoft Exchange Server 2007
Microsoft Exchange Server 2007 Enterprise Edition
Microsoft Exchange Server 2007 Standard Edition

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Keywords: 
kbpubmvp kbpubtypecca kbhowto KB555855

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