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Article ID: 555959 - Last Review: August 13, 2007 - Revision: 1.0

"Data Cannot be Updated in Data Warehouse" error after the new Root Management Server Promotion

Author: Ka Lung Lai MVP
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SUMMARY

After the Recovery of the Operations Manager 2007 RMS. You will get the error indicate that the data cannot be updated in data warehouse.

SYMPTOMS

When you completed the promotion for a new Root Management Server on the existing Management Server. You will see the Critical Error Icon on the New Promoted Root Management Server and there are the errors indicated that the data cannot be updated in data warehouse in the Health Explorer of the New Promoted Root Management Server.

CAUSE

This issue is caused by the new Root Management Server does not have accounts specified for its Data Warehouse run as profiles.

RESOLUTION

To resolve this problem, please follow these steps:
 
1. Open Administration in the System Center Operations Manager 2007 Operations Console.
2. Under Security, click Run As Profiles.
3. In the Run As Profiles view, double-click the run as profile named Data Warehouse Account, and then click the Run As Accounts tab.
4. Click New.
5. In the Run As Account box, select Data Warehouse Action Account.
6. In the list of computers, select the management server that is generating the alert.
7. Click OK twice.
8. Repeat steps 3-7 for the following three accounts run as profiles:
Data Warehouse Configuration Synchronization Reader Account
Data Warehouse Report Deployment Account
Data Warehouse SQL Server Authentication Account
In each case, select the run as account that matches the name of the run as profile. For example, the run as profile named "Data Warehouse Configuration Synchronization Reader Account" uses the run as account named "Data Warehouse Configuration Synchronization Reader Account."
9. Restart the OpsMgr Health Service on the management server that is generating the alert.
10. In the Operations Manager event log on the management server, verify that events with ID 31554 are logged. These event will change the state of the monitors to healthy, which will resolve the alerts.
 

APPLIES TO
  • Microsoft Operations Manager 2000 Enterprise Edition
  • Microsoft Operations Manager 2000 Service Pack 1
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