Unable to enable Windows Defender application in Windows Vista

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Article ID: 555962 - View products that this article applies to.
Author: Raghu Boddu
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SUMMARY

You may experience issues enabling Windows Defender application in Windows Vista. This article explains you the troubleshooting procedure to resolve the same.

SYMPTOMS

Windows Security Center may prompt you to "Check Settings" for the Malware Protection, and when you click the "Turn on now" button, it may show an error that says "There are no new definitions available to download for Windows Defender".
 
Also, enabling Windows Defender in the "Turn Windows Features on or off" options might not enable the program.

CAUSE

This issue occrus due inconsistent WMI repository. Restarting the WMI repository will resolve the issue.

RESOLUTION

1. Click Start, type CMD in search.
2. From the results, right-click Command Prompt and Run as Administrator. Type the following command: (If you have logged in as Administrator, you can directly execute CMD)
 
winmgmt /verifyrepository
 
3. When the system returns "WMI repository is not consistent" message, run the following command:
 
winmgmt /salvagerepository
 
This will perform a consistency check on the WMI repository and resolve the issue. Restart the system, once done and try enabling Windows Defender program.

MORE INFORMATION

You may experience an error that says the winmgmt /salvagerepository is failed. Ignore this message, and run "winmgmt /salvagerepository" for 1-2 times. This error is due to Windows services.

Properties

Article ID: 555962 - Last Review: August 16, 2007 - Revision: 1.0
APPLIES TO
  • Windows Vista Ultimate
Keywords: 
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