Lotus 1-2-3 ファイルを Excel にインポートするためのヒント

文書翻訳 文書翻訳
文書番号: 61941
すべて展開する | すべて折りたたむ

目次

概要

この資料でには潜在的な問題に関する情報が含まれています。Lotus 1-2-3 ファイルを Excel にインポートするがあります。

WK4 ファイルを開く

Microsoft Excel バージョン 5.0 では、Lotus 1-2-3 WK4 ファイルを開くには、Lotus 1-2-3 WK4 ファイル コンバーターを取得する必要があります。Lotus 1-2-3 WK4 ファイルコンバーターが、「ロータス 1-2-3 WK4 ファイル コンバーターの」(WE1130) はアプリケーション ノート。 注: Microsoft Excel 7.0、および Microsoft Excel 97 を含める、Wk4 ファイル コンバーターです。Microsoft Excel 7.0 に含まれて、コンバーターを使用できます。Lotus 1-2-3 Wk4 ファイル形式を読み取れません。Microsoft Excel 97 のコンバーターWk4 形式を読み書きすることができます。

書式設定

Lotus 1-2-3 のワークシートまたはブック、Microsoft を開いたときExcel は、関連付けられたフォーマットを拡張子 .fmt、.fm3、またはいうに格納されている書式が適用されます。ファイルです。関連付けられた書式ファイルは同じフォルダーに格納されることを確認してください。.wk か。ファイルです。Microsoft Excel で、Lotus 1-2-3 ファイルを保存する場合形式 (.xls) ワークシートと一緒に保存するワークシートのデータと書式を設定します。1 つのブックのファイルです。

オブジェクト

Lotus 1-2-3 WK4 ファイルを開くと Microsoft 5.0、Excel でマクロのボタン、テキスト ボックス、線などの描画オブジェクト変換します。また、ワークシート名が、Lotus 1-2-3 として表示されます。既定値: A、B、C、および続きます。Lotus 1-2-3 WK4 ファイル コンバーターを指定しません。ワークシートに描画オブジェクトを変換します。これは、次のいずれかが含まれています項目:
   arc
   arrow
   button
   ellipse
   embedded object
   freehand
   line
   polygon
   polyline
   rectangle
   rounded rectangle
   text
				
メモ: それ以降のバージョンではこの問題は発生しません。すべてのオブジェクトがMicrosoft Excel 7.0 以降に開いたときに変換します。

グラフ

Microsoft Excel 4.0 以降では。

Lotus 1-2-3 では、バージョン 3.x およびグラフ シートにグラフを作成するか、作成する後で、グラフをワークシート上のオブジェクトとして。Lotus 1-2-3 で、バージョン 2.x を使用すると、WYSIWYG を追加で、ワークシートにグラフを配置できます。

で既定では、Excel に自動的に変換が関連付けられているグラフにLotus 1-2-3 ワークシートです。Excel4.ini には、次の設定を使用できます、ロータスを開いたときにグラフ シートを作成を抑制する、Excel5.ini ファイル1-2-3 ファイル。
   Load_Chart_Wnd=0
				
Microsoft Excel は、インプレス (.fm3) ファイルと Allways 読み取れるため(いう) 形式のファイルを含む Lotus 1-2-3 のワークシートをインポートすることができます、ワークシート上のグラフ。ロータスでは、ワークシートにグラフが表示されます。1-2-3。

Microsoft Excel 2.x および 3.x では:

インポートすると、グラフ、Microsoft Excel 2.x および 3.x が含まれているファイルを入力するプロンプトを表示します。つまり、ワークシートに格納されているワークシート上にあるグラフ。表示されたら、ファイルを Microsoft Excel のグラフに変換するかどうか。場合は、クリックしてください。 [はい]、Microsoft Excel 新しいグラフ ウィンドウを作成します。Microsoft Excel で3.x、次は、ワークシートにグラフをコピーします。

データベース

データベース、条件、および展開の定義範囲正常にインポートされ、正常に機能します。ただし、データベースの検索条件範囲データの抽出、データの検索およびデータベースを使用すると異なる方法で評価されます。機能します。たとえば、"John"の条件検索セルを持つ行だけ"John。"が含まれています。かどうかは、オフには、 計算方式 チェック ボックスを"John"を抽出条件セルを含む行を検索します。"John"; で始まる値例については、「ジョン、」を含むセル「ジョンソン、」と"Johnsen"があります。

計算

Lotus 1-2-3 ファイルを開くたびに、 [式入力 チェック ボックスが選択されています。この機能がオンになっている場合マイクロソフトExcel に Lotus 1-2-3 の構文で入力した数式を変換します。Excel 構文検索し名前の Microsoft Excel で定義されている動作が定義されている名前Lotus 1-2-3 での操作を行います。

Microsoft Excel 数式を異なる方法で計算します。Lotus 1-2-3 からは。テキストを含むセル、数式、ロータスが使用されますと1-2-3、セルに値を 0 (ゼロ) を割り当てます。Microsoft Excel では、そのことはできません。テキストと数値のエントリでは同次数式を結合します。ただし、使用する場合は、ワークシート関数では、Microsoft Excel では、値が 0 のセルに割り当てられていることテキストが含まれています。たとえば、オフにすると、 計算方式 チェック ボックスは、セル A1 とセルに 100 の値でテキストを入力します。B1 です。数式はエラー値 #value! を = A1 + B1 を返します!エラーの値です。ただし、ワークシート数式の =SUM(A1,B1) によって、値 100 を返します。

Lotus 1-2-3ブール式を 0 または 1 と 0 または 1 のセルが表示されます。たとえば、Lotus 1-2-3 では、式 2<3 displays="" 1="" in="" the="" cell="" to="" represent="" true;="" microsoft="" excel="" displays="" true="" or="" false="" in="" the=""></3>

選択した場合は、 計算方式 チェック ボックスを Microsoft Excel 0 偽、1 は True を表示します。

MOD @、@ VLOOKUP、HLOOKUP @ など一部の機能は、異なる方法で評価します。たとえば、@ VLOOKUP 関数で Lotus 1-2-3完全一致列の検索です。VLOOKUP ワークシート関数最初の列が並べ替えられ、最も近いものを検索します。 Microsoft Excel で想定しています。最初の列のルックアップ値を超えない値です。VLOOKUP4 番目の引数は、Microsoft excel の HLOOKUP ワークシート関数を含む検索の型。この引数を False に設定すると、Microsoft Excel がの検索します。完全に一致します。

Excel で数式を計算するが発生するにはLotus 1-2-3 は、次の手順を実行します。
  1. で、 ツール メニューをクリックして オプション.クリックして、 移行 タブします。
  2. クリックしてください。 計算方式をクリックして [OK].

計算の順序

数学の順序の優先順位の相違

これExcel とロータスで使用される数学演算子の表を比較します。1-2-3。
                     Lotus                 Microsoft
   Operator          1-2-3      Precedence   Excel      Precedence
   ---------------------------------------------------------------

   Exponentiation    ^             1st        ^            2nd

   Positive and      + and -       2nd        + and -      1st
   negative

   Multiplication    * and /       3rd        * and /      3rd
     and division

   Addition and      + and -       4th        + and -      4th
     Subtraction

   Comparison        = < >         5th        = < >        5th
                     <= >=                    <= >=

   Logical NOT       #not#         6th        NOT()        6th

   Logical AND       #and# and     7th        AND() and    7th
     and OR          #or#                     OR()

   String            &             7th        &            7th
   concatenation
				
メモ: Lotus 1-2-3 は、指数演算子 (^) を評価する前に、否定演算子 (-) です。Microsoft Excel は否定演算子は最初評価します。たとえばの Lotus 1-2-3、数式 = 2 ^-16、値 4 が返されますがMicrosoft Excel で 16 を返します。この違いを修正するには、かっこを使用します。評価の順序を変更します。たとえば、-16 =-(2^4) を作成します。

リンク

Microsoft Excel で開くと、Lotus 1-2-3 のコピー ファイルのことリンクを含む別のファイルには、セル、#REF を更新する可能性があります。エラー値です。Lotus 1-2-3 のコピー ファイルの外部リンクを更新するには、以下を実行します手順:
  1. Microsoft Excel をクリックします。 リンク で、 編集 メニューです。
  2. で、 リンク ダイアログ ボックスで、更新するリンクを選択します。クリックしてください。 [今すぐ更新します。.

    メモ: ソース ドキュメントを開く場合は、をクリックします。 ファイルを開く.これは、外部リンクも更新されます。
この現象を回避するには、ファイルを Microsoft Excel で保存します。ブックの書式します。

日付を変換します。

Excel と Lotus 1-2-3 は、同じの日付システムを使用します。シリアル値では、Microsoft Excel 7.0 およびそれ以前の範囲は 0 (1/1/1900) するには65380 (12/31/2078)。Lotus 1-2-3 の範囲 0 から 73050 の日付のシリアル値(12/31/2099)。Lotus 1-2-3 の日付をインポートする場合は、日付が含まれています関数で、1 年後、2078、関数、#num! します。エラーの値です。1 年で書式設定された日付を含むワークシートをインポートする場合よりも2078、Excel セル 255 のシャープ記号 (#) を入力します。

メモ: この問題を Microsoft Excel 97 であるためにはありません、9999 の年を表すことができます。

マクロ

Lotus 1-2-3 でのマクロは、ワークシート上で直接格納されます。これ別の Excel マクロを格納するからです。Microsoft Excel を格納します。マクロ (Excel 4.0) では、マクロ シート、またはモジュール シートをマクロの Visual Basic では Microsoft Excel 5.0 のアプリケーションを対象とし後で。

Microsoft Excel 4.0a およびそれ以降では。

いくつかの以前のバージョンMicrosoft Excel のバージョンは、Lotus 1-2-3 のマクロを直接実行できます。これを実行しません。(書き換え) に変換する必要がある、マクロ。開くと、Lotus 1-2-3 ファイルのことマクロが含まれているリストのすべての利用可能な 1-2-3 を参照してくださいマクロでブックの定義名のリストを見る。Lotus 1-2-3 を実行するのにはマクロは、ctrl キーを押しし、関連付けられている文字、マクロのキーを押します。たとえば、キーを押します。CTRL キーを押しながら P。

メモ: Excel 97 では、セキュリティ更新プログラム (8.0」以降) および Excel 2000Lotus 1-2-3 のマクロを実行しないでください。

Microsoft Excel 4.0 およびそれ以前では。

(書き換え) Lotus 1-2-3 のマクロを Microsoft Excel のマクロを変換するには次の操作を行います。
  1. Microsoft Excel で、Lotus 1-2-3 ワークシートを開くことマクロが含まれています。
  2. [コントロール] メニューをクリックします。 実行.[コントロール] メニューを開くには、alt キーを押しながら SPACE キーを押します。
  3. クリックしてください。 マクロの変換、し [OK].
  4. で、 翻訳 メニューをクリックして Lotus 1-2-3.変換するワークシートの名前を選択します。
  5. 変換するマクロの名前を選択します。If翻訳するには、変換した Microsoft の横にある一覧、1-2-3 のマクロをExcel のマクロをクリックして、 詳細 オプションです。
Excel 変換後のマクロを新しく作成したマクロに配置します。シートです。

関連情報

Lotus 1-2-3 ファイルを変換の詳細については、クリックして、 インデックス Microsoft Excel 97 のヘルプでをタブで、次のテキストを入力します。
Lotus 1-2-3 のファイルを変換します。
移動するのには、選択したテキスト] をダブルクリックし、 "キーの情報アップグ レート及び新規ユーザー" トピックです。

インポートについてワークシート、数式、参照、および形式の特定のバージョンのロータス1-2-3 を参照してください。 "への切り替えMicrosoft Excel から Lotus 1-2-3 は、" バージョン 4.0 では、ページ 24-31、38、または、 「ユーザーズ ガイド」 バージョン 3.0 では、ページ 41 〜 64 です。

プロパティ

文書番号: 61941 - 最終更新日: 2011年7月21日 - リビジョン: 4.0
キーワード:?
kbinfo kbmt KB61941 KbMtja
機械翻訳の免責
重要: このサポート技術情報 (以下「KB」) は、翻訳者による翻訳の代わりに、マイクロソフト機械翻訳システムによって翻訳されたものです。マイクロソフトは、お客様に、マイクロソフトが提供している全ての KB を日本語でご利用いただけるように、翻訳者による翻訳 KB に加え機械翻訳 KB も提供しています。しかしながら、機械翻訳の品質は翻訳者による翻訳ほど十分ではありません。誤訳や、文法、言葉使い、その他、たとえば日本語を母国語としない方が日本語を話すときに間違えるようなミスを含んでいる可能性があります。マイクロソフトは、機械翻訳の品質、及び KB の内容の誤訳やお客様が KB を利用されたことによって生じた直接または間接的な問題や損害については、いかなる責任も負わないものとします。マイクロソフトは、機械翻訳システムの改善を継続的に行っています。
英語版 KB:61941
Microsoft Knowledge Base の免責: Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。
サポート期間が終了した「サポート技術情報」資料に関する免責事項
この資料は、マイクロソフトでサポートされていない製品について記述したものです。そのため、この資料は現状ベースで提供されており、今後更新されることはありません。

フィードバック

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com