Funzione Somma + SE con operatori logici Eoppure O

Identificativo articolo: 638734 - Visualizza i prodotti a cui si riferisce l?articolo.
Questo articolo è stato precedentemente pubblicato con il codice di riferimento I13734
Espandi tutto | Chiudi tutto

Sommario


Se si prova ad usare in Microsoft Excel le funzioni logiche E() oppure O()
all'interno di un SOMMA + SE per verificare un intervallo con piu' di una
condizione, non si ottiene un risultato corretto. Una serie di istruzioni
SE() nidificate possono risolvere questo problema.
Tuttavia, questo articolo evidenzia un secondo metodo piu' semplice per
utilizzare la funzione =SOMMA + SE con condizioni multiple. La funzione
generica per ottenere tale risultato puo' riassumersi nella formula
seguente:
{=SOMMA(SE(TEST1*TEST2.....*TESTn))}

Informazioni


Un'istruzione SOMMA+SE viene utilizzata per contare il numero di celle
all'interno di un determinato intervallo che corrispondono ad un certo
criterio (VERO o FALSO), oppure per sommare quei valori di un intervallo a
seconda che valori corrispondenti di un altro (o il medesimo) intervallo
corrispondano a determinati criteri. Questo e' il comportamento della
funzione DB.SOMMA().

ESEMPIO
=======
L'esempio di seguito conta il numero di valori nell'intervallo A1:A10
compresi fra 1 e 10 (inclusi). Questo puo' essere realizzato mediante la
seguente funzione che fa uso di istruzioni SE() nidificate:
{=SOMMA(SE(A1:A10>=1;SE(A1:A10<=10;1;0)))}

Anche il seguente metodo funziona ed e' piu' semplice da creare e da
leggere nel caso si necessario effettuare piu' test:
{=SOMMA(SE((A1:A10>=1)*(A1:A10<=10);1;0))}

NOTA: Entrambe le formule devono essere inserite come matrice premendo
simultaneamente i tasti CTRL+SHIFT+INVIO

Con questo metodo, si moltiplicano i risultati di un test logico per un
altro test logico e vengono ritornati tutti i valori "VERO" e "FALSO" alla
nostra funzione somma. Il risultato che la funzione ritorna dipende dal
modo di calcolo applicato da Excel che e' riassunto nella tabella seguente:
VERO*VERO=1
VERO*FALSO=0
FALSO*VERO=0
FALSO*FALSO=0

Il metodo mostrato sopra conta il numero di celle nell'intervallo A1:A10
per il quale entrambi i test ritornano VERO. Per sommare i valori contenuti
in celle corrispondenti (per esempio, nell'intervallo B1:B10), quelli dove
entrambi i test sono verificati, bisogna modificare la formula come
indicato di seguito:
{=SOMMA(SE((A1:A10>=1)*(A1:A10<=10);B1:B10;0))}

Nello stesso modo si puo` implementare una condizione O() in un SOMMA + SE.
Per fare questo, modifichiamo la formula mostrata sopra sostituendo il
segno di moltiplicazione(*) con il simbolo di somma (+); cosi facendo si
ottiene la seguente formula generica.
{=SOMMA(SE((Test1)+(Test2)+...+(Testn);1;0))}

Proprietà

Identificativo articolo: 638734 - Ultima modifica: mercoledì 24 agosto 2005 - Revisione: 1.2
Le informazioni in questo articolo si applicano a:
  • Microsoft Excel 5.0 Standard Edition
  • Microsoft Excel 5.0 Standard Edition
  • Microsoft Excel 5.0 per Macintosh
  • Microsoft Excel 5.0 per Macintosh
  • Microsoft Excel 95 Standard Edition
Chiavi: 
and false function if multiple or sum true KB638734
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.
Dichiarazione di non responsabilità per articoli della Microsoft Knowledge Base su prodotti non più supportati
Questo articolo è stato scritto sui prodotti per cui Microsoft non offre più supporto. L?articolo, quindi, viene offerto ?così come è? e non verrà più aggiornato.

Invia suggerimenti

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com