PRJ: Adding New Tasks to a Project Already in Progress

Article translations Article translations
Article ID: 75674 - View products that this article applies to.
This article was previously published under Q75674
This article has been archived. It is offered "as is" and will no longer be updated.
Expand all | Collapse all

SUMMARY

When adding new tasks to projects that have already started, certain adjustments must be made to cause these tasks to be scheduled as soon as possible with respect to the current date, rather than the original project start date. Making these adjustments will aid you in avoiding possible scheduling or resource conflicts with tasks already in progress.

MORE INFORMATION

When a new task is added to a project in Microsoft Project, by default it will be scheduled with respect to the project start date shown in the dialog box that appears when you choose Project Info from the Options menu. For example, Any task that has an As Soon As Possible constraint and no predecessors will be scheduled to start on the project start date.

If you want a task to be scheduled with respect to the date it is added to the project, you can do either of the following:

  • Put a constraint of Start No Earlier Than, with a constraint date equal to the current date, on the task. This will cause the task to start as close to this constraint date as possible.

    A limitation of this method is that a task can have only one constraint. If you want a task to start as close as possible to the current date, and yet also put a different constraint such as Finish No Later Than <some later date> on the task, this method will not work. However, you can use the next method. -or-

  • An alternative to the Start No Earlier Than constraint is to add enough delay to a task to force it to start no earlier than the current date. To do this, you must first add the Delay field to one of your task tables. For example, to add the Delay field to your Entry table in the Gantt Chart view, do the following:

    Project 2010

    1.       Select to the View tab.

    2.       Click Tables, and then select Entry.

    3.       On the Gantt Chart view, right click the Start column, and choose Insert Column.

    4.       In the list box choose Leveling Delay.....

    Project 2000-2007

    1.       On the View menu, point to Table, and click Entry.

    2.       On the Gantt Chart view, right click the Start column, and choose Insert Column.

    3.       On the Column Definition dialog box for the Field name list, select Leveling Delay.

    4.       Click OK.

    Project 98

    1.       From the Table menu, choose Define Tables.

    2.       Select the Entry table and choose the Edit button.

    3.       Select the Scheduled Start line under Field Name, and then choose the Insert button.

    4.       Click the blank line created in the Field Name column, and then type "Delay".

    5.       Press the ENTER key, and then choose OK. Choose Set.
You should now see the Delay field in your table between Duration and Scheduled Start. After adding a new task to your project, you can enter an amount of delay equal to the difference between the project start date and the current date to each new task. To find the amount of delay necessary, do the following:

Project 2010

1.       Select the View tab, select the Details check box, and choose Task Form from the list.

NOTE: This will split the screen with the Gantt Chart on top and the Task Form on bottom.

2.       Create a dummy task in the project.

3.       Select this task from the Gantt Chart view.

4.       In the Task Form pane, enter Start equal to the project start date.

5.       In the Task Form pane, enter Finish equal to the current date.

Example: Start = 10/13/09 and Finish = 10/23/09

6.       Click OK.

Project 2000-2007

1.       On the Window menu, click Split.

NOTE: This will split the screen into 2 panes, Gantt Chart on top and Task Form on bottom.

2.       Create a dummy task in the project.

3.       Select this task from the Gantt Chart view.

4.       In the Task Form pane, enter Start equal to the project start date.

5.       In the Task Form pane, enter Finish equal to the current date.

Example: Start = 10/13/09 and Finish = 10/23/09

6.       Click OK.

Project 98

1.       Create a dummy task in your project.

2.       Select this task from your Gantt Chart view.

3.       From the Edit menu, choose Form.

4.       Under the Dates section, enter a Scheduled Start equal to the project start date, and enter a Scheduled Finish equal to the current date (include the start time of the current date). For example, if the start date for your project is 1/1/91 8:00 AM, and the current date is 3/4/91, enter a Scheduled Start of 1/1/91 8:00 AM and a Scheduled Finish of 3/4/91 8:00 AM.

5.       Choose the OK button.

Project calculates the duration of this dummy task using elapsed duration; this elapsed duration is equal to the amount of delay you will want to add to new tasks. Entering this value in the Delay field for any new tasks will force them to be scheduled no earlier than the current date and still allow Project to add more delay to them when leveling resources, if necessary.

After calculating this delay value, the dummy task can be deleted.

REFERENCES

"Microsoft Project for Windows Reference Guide":

  • "To slip tasks to start on the current date," page 504
  • "Editing an Existing Table," page 443
  • Delay field, page 137
  • Constraint Type/Constraint Date, page 136
"Microsoft Project Reference":

  • "To slip tasks to start on the current date," page 488
  • "Editing an Existing Table," page 430
  • Delay field, page 139
  • Constraint Type/Constraint Date, page 138

Properties

Article ID: 75674 - Last Review: February 27, 2014 - Revision: 5.0
APPLIES TO
  • Microsoft Project 98 Standard Edition
  • Microsoft Project 4.1 Standard Edition
  • Microsoft Project 1.0 Standard Edition
  • Microsoft Project 3.0 Standard Edition
  • Microsoft Project 4.0 Standard Edition
  • Microsoft Project 3.0 for Macintosh
  • Microsoft Office Project Professional 2007
  • Microsoft Office Project Professional 2003
  • Microsoft Office Project Standard 2007
  • Microsoft Office Project Standard 2003
  • Microsoft Project 2000 Standard Edition
  • Microsoft Project 2002 Standard Edition
  • Microsoft Project 2002 Professional Edition
  • Microsoft Project Professional 2010
  • Microsoft Project Standard 2010
Keywords: 
kbnosurvey kbarchive kbhowto kbusage KB75674

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com