"丢失操作系统"和"无 ROM BASIC"错误消息

文章翻译 文章翻译
文章编号: 80304 - 查看本文应用于的产品
展开全部 | 关闭全部

本文内容

症状

当您启动您的计算机时,您可能会收到以下错误消息之一:

  • 缺少操作系统
  • 非系统磁盘或磁盘错误
  • 启动错误重试按 F1
  • 没有 ROM 基本
  • 无效的媒体类型
  • 硬驱动器控制器故障

原因

缺少操作系统

引导记录签名的主引导记录与某一值在特定位置不匹配时,会发生此错误。在本例中是无效的启动扇区和该计算机不能启动。如果没有定义在分区表中没有活动分区,也可能发生此错误。

非系统磁盘或磁盘错误

该错误与生成计算机的 bios 时引导扇区或启动驱动器的主引导记录已损坏或丢失。如果启动设备已正确配置 BIOS 中也可能发生此错误。 在这种情况下该分区中的数据可能是有效且未损坏,但没有任何可引导分区。

注: 该邮件时,也会发生不可引导磁盘驱动器 A 中保持在启动过程中。如果您收到此错误,确保驱动器 A 中没有磁盘,然后重新启动计算机。

启动错误按 F1,以重试

当将硬盘缺少主启动记录或引导区或访问引导驱动器有问题时,通过计算机的 BIOS 将产生此错误。

没有 ROM 基本

如果没有活动的分区,已定义主引导记录 bios 返回错误。在某些种情况下尝试找到任何引导盘后,转到 ROM Basic 主引导代码。由于某些计算机没有 ROM Basic,所以它们将显示 NO ROM BASIC 或其他错误消息。显示该消息是依赖于计算机的 BIOS。

无效的媒体类型

当定义分区的启动扇区已损坏时显示此错误消息。使用新的未格式化的分区通常情况下收到该错误信息。但是,如果引导扇区已损坏,分区可能会出现于操作系统的系统未格式化,并且会生成此错误消息。

硬盘控制器故障

此错误消息表示硬盘控制器出现故障、 硬盘控制器不设置正确地在 BIOS,或控制器无法相互连接的驱动器。在这种情况下并不会执行下列疑难解答步骤。而是,请查阅包含与您的计算机文档或与计算机制造商联系的详细信息。

解决方案

每个上面列出的错误消息可能表明从损坏的硬盘分区的信息不正确的硬件配置的问题。以下步骤可用于帮助解决此问题。 但是,如果这些步骤不能解决问题,请与硬件制造商联系或已由合格服务专业人员来处理该驱动器。

  1. 启动计算机,使用 Windows 95 紧急启动盘 (EBD) 或使用可启动的 MS-DOS 磁盘包含 Fdisk.exe、 Format.com、 Sys.com 和 Scandisk.exe (MS-DOS 版本 6.2 x 唯一)。

    如果您的计算机不能从驱动器 A,启动,或者您接收到驱动器 A 从启动时,上面列出的某个类似的错误消息,请与计算机制造商联系。
  2. 使用 Fdisk.exe 查看硬盘上的分区,请执行以下步骤:

    1. 运行 Fdisk.exe EBD 或 MS-DOS 的启动盘。

      注: 如果已将硬盘已分区使用 Fdisk.exe,使用相应的第三方分区软件可以查看硬盘分区。有关使用第三方分区软件,请参考该软件的文档。
    2. 选择选项 4 (显示分区信息)。
    3. 如果列出了分区,请确保可引导分区被定义为活动状态 (查找在 $ 状态中的大写字母 A 列)
    4. 如果没有列出的分区使用 Fdisk.exe 建立新的分区,然后使用 Format.com 格式化要从启动磁盘的分区。

      警告: 当创建新的分区或格式化驱动器中使用 Fdisk.exe 或 Format.com 您丢失该驱动器或分区上的任何数据。
    5. 如果出现在 $ Fdisk.exe,中的所有分区,并且其中一个定义为活动状态继续执行下一步。
  3. 在硬盘上的 SYS 命令运行从 EBD 或启动 MS-DOS 磁盘。例如对于键入以下命令:
    a:\sys c:
    如果您收到消息"系统传输,从驱动器 A 中删除该磁盘并重新启动计算机。如果您重新启动计算机之后,您将收到相同的错误消息,您的硬盘可能是配置不正确或损坏。

    如果您不会收到"系统传输"消息,或者您收到一条错误消息从 EBD 或启动 MS-DOS 运行磁盘扫描磁盘 (MS-DOS 6.20 或更高版本) 以便通过键入以下命令检查硬盘上的物理损坏:
    a:\scandisk c:
    如果系统提示您执行表面扫描,选择是。如果磁盘扫描程序在硬盘上报告物理损坏,有通过限定的服务专业人员检查的硬盘)。

属性

文章编号: 80304 - 最后修改: 2006年11月16日 - 修订: 2.1
这篇文章中的信息适用于:
  • Microsoft MS-DOS 3.1
  • Microsoft MS-DOS 3.2 标准版
  • Microsoft MS-DOS 3.21 标准版
  • Microsoft MS-DOS 3.3 标准版
  • Microsoft MS-DOS 3.3a
  • Microsoft MS-DOS 4.0 标准版
  • Microsoft MS-DOS 4.01 标准版
  • Microsoft MS-DOS 5.0 标准版
  • Microsoft MS-DOS 5.0a
  • Microsoft MS-DOS 6.0 标准版
  • Microsoft MS-DOS 6.2 标准版
  • Microsoft MS-DOS 6.21 标准版
  • Microsoft MS-DOS 6.22 标准版
  • Microsoft Windows 95
关键字:?
kbmt kbdiskmemory kbfaq kbscandisk KB80304 KbMtzh
机器翻译
注意:这篇文章是由无人工介入的微软自动的机器翻译软件翻译完成。微软很高兴能同时提供给您由人工翻译的和由机器翻译的文章, 以使您能使用您的语言访问所有的知识库文章。然而由机器翻译的文章并不总是完美的。它可能存在词汇,语法或文法的问题,就像是一个外国人在说中文时总是可能犯这样的错误。虽然我们经常升级机器翻译软件以提高翻译质量,但是我们不保证机器翻译的正确度,也不对由于内容的误译或者客户对它的错误使用所引起的任何直接的, 或间接的可能的问题负责。
点击这里察看该文章的英文版: 80304
Microsoft和/或其各供应商对于为任何目的而在本服务器上发布的文件及有关图形所含信息的适用性,不作任何声明。 所有该等文件及有关图形均"依样"提供,而不带任何性质的保证。Microsoft和/或其各供应商特此声明,对所有与该等信息有关的保证和条件不负任何责任,该等保证和条件包括关于适销性、符合特定用途、所有权和非侵权的所有默示保证和条件。在任何情况下,在由于使用或运行本服务器上的信息所引起的或与该等使用或运行有关的诉讼中,Microsoft和/或其各供应商就因丧失使用、数据或利润所导致的任何特别的、间接的、衍生性的损害或任何因使用而丧失所导致的之损害、数据或利润不负任何责任。
不再更新的 KB 内容免责声明
本文介绍那些 Microsoft 不再提供支持的产品。因此本文按“原样”提供,并且不再更新。

提供反馈

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com