Gewusst wie: Drucken von VB-Formular Rahmen und Menüs

SPRACHE AUSWÄHLEN SPRACHE AUSWÄHLEN
Artikel-ID: 80409 - Produkte anzeigen, auf die sich dieser Artikel bezieht
Dieser Artikel wurde archiviert. Er wird im vorliegenden Zustand bereitgestellt und nicht mehr aktualisiert.
Alles erweitern | Alles schließen

Auf dieser Seite

Zusammenfassung

Die Methoden, ein Visual Basic bereitgestellten Formular drucken Drucken nicht den nicht-Clientbereich eines Formulars nur den Clientbereich. Dies ist ein Entwurf-Feature von Visual Basic. Des Clientbereichs des Formulars enthält Steuerelemente und Bild des Formulars. Nicht-Clientbereich umfasst des Formulars Rahmen und Menüs direkt aus Visual Basic nicht gedruckt werden kann.

Um die Client und dem nicht-Client Bereiche eines Formulars, Kopie drucken ein Bild des Formulars in die Zwischenablage, fügen es in einem Grafik-Editor wie beispielsweise Paintbrush und drucken. Zwei Methoden für diese Prozedur werden unten angezeigt.

Weitere Informationen

Die Option Drucken im Menü Datei, und die Visual Basic-Anweisung [Formular].PrintForm drucken nur des Clientbereichs des Formulars. Der Clientbereich gehören Bild und Steuerelemente des Formulars. Beide Methoden Drucken Drucken Sie keine der nicht-Clientbereich der Titelleiste, Schaltflächen Minimieren und maximieren, Rahmen und Menüs des Formulars enthält. Um dem Client und nicht-Client-Bereiche zu drucken, müssen Sie das Formular von einer Anwendung außerhalb von Visual Basic drucken. Wenn Sie ein Formular drucken möchten,
  • Untermenüelemente hat, aber Sie möchten den Untermenüs drucken

    -oder-
  • Hat der Menüs ohne Untermenüs

    -oder-
  • Hat keine Menüs
dann verwenden Sie Methode 1 unten, um das Formular drucken.

Wenn Sie ein Formular drucken, Untermenüs im Zustand abgerufen Dropdown enthält, möchten, verwenden Sie Methode 2 unten.

Methode 1

Um ein Formular ohne abgerufen Dropdown Untermenüs zu drucken, folgendermaßen Sie vor:
  1. Erstellen Sie aus der Bearbeitung Visual Basic-Umgebung des Formulars gedruckt werden sollen ein. Alle Steuerelemente, Titel, Menüs, Bilder, Ränder und usw., die Sie drucken möchten, Anordnen und Größe entsprechend.
  2. Setzen Sie Fokus zu dem Formular gedruckt werden soll.
  3. Drücken Sie ALT + DRUCK. Diese Tastenkombination ist ein Vorgang in Windows, die das aktive Fenster (das Formular in diesem Fall) in die Windows-Zwischenablage kopiert.
  4. Starten Sie aus den Windows-Programm-Manager Paintbrush (oder die Grafik-Editor Ihrer Wahl) und Maximieren Sie es.
  5. Wählen Sie im Paintbrush bearbeiten einfügen. Das Bild des Formulars sollte in Paintbrush angezeigt. Wenn das Formular für Paintbrush zu groß ist, versuchen Sie es entweder eine größere Bildschirmauflösung (z. B. 800 x 600 oder 1024 durch 768), einem anderen Editor mit einem größeren Bildschirm arbeiten oder etwas verringern der Größe des Formulars für den Druckvorgang.
  6. Sobald das Formular ordnungsgemäß in Paintbrush aus der Datei eingefügt wird im Menü Wählen Sie drucken, es zu drucken.

Methode 2

Ein Formular mit abgerufen Dropdown Untermenüs drucken, folgendermaßen Sie vor:
  1. Erstellen Sie in der Visual Basic-Umgebung Bearbeiten des Formulars gedruckt werden sollen ein. Gehören Sie alle Steuerelemente, Titel, Menüs, Bilder, Rahmen usw., dass Sie drucken und diese entsprechend der Größe anpassen möchten.
  2. Setzen Sie Fokus zu dem Formular gedruckt werden.
  3. Verschieben Sie das Formular in die obere linken Ecke des Bildschirms. Wenn die Zwischenablage sein Bild in Paintbrush einfügt, wird es in der oberen linken Ecke. Wenn das Bild für den Bildschirm Paintbrush bearbeiten zu groß ist, wird auf den rechten und unteren Rand des Bildes abgeschnitten. Platzieren in der oberen linken Ecke des Formulars können Sie sicherstellen, dass das vollständige Formular in Paintbrush passt.
  4. Wählen Sie die Menüoption nach unten gezogen wird, wird das Formular gedruckt werden soll. Die Menüoption zum sollte gesendeten angezeigt unten auf dem Bildschirm. Nur eine Option nach unten zu einem Zeitpunkt abgerufen werden kann, aber Untermenü Optionen ausgewählt werden können.
  5. Drücken Sie UMSCHALT + Druck. Diese Tastenkombination ist eine Option in Windows, die ein Abbild des gesamten Bildschirms in die Windows-Zwischenablage kopiert. Wenn Pulldown-Menüs geöffnet sind, wendet Trapping Visual Basic für die ALT-TASTE und schließt die Menüs, wodurch ALT + Druck in Methode 1 unwirksam, beim Drucken von Pulldown-Menüs auf einem Formular Tastatureingaben.
  6. Starten Sie von Programm-Manager Paintbrush (oder die Grafik-Editor Ihrer Wahl), und maximieren.
  7. Wählen Sie im Paintbrush bearbeiten einfügen. Das Formular sollte in Paintbrush angezeigt werden. Wenn das Formular für Paintbrush zu groß ist, versuchen Sie es entweder eine größere Bildschirmauflösung (z. B. 800 x 600 oder 1024 durch 768), einem anderen Editor mit einem größeren Bildschirm arbeiten oder etwas verringern der Größe des Formulars für den Druckvorgang.
  8. Mithilfe einer der Ausschneiden Tools am oberen Rand der Paintbrush Toolbox Gliederung Ihres Formulars.
  9. Wählen Sie im Menü Bearbeiten den Befehl Kopieren. Dies setzt den Grafikbereich, in den Bereich Ausschneiden in die Zwischenablage enthalten sind.
  10. Wählen Sie im Menü Datei neu, um einen neuen Editor Bildschirm aufzurufen. Ein Dialogfeld wird angezeigt, nachfragt, wenn das aktuelle Bild gespeichert werden soll. Müssen Sie Ja auswählen, oder nicht vor einem neuen Editor Bildschirm wird angezeigt.
  11. Sobald der Bildschirm-Editor leer ist, im Menü Bearbeiten Wählen Sie einfügen, um das Formular in den Editor einzufügen aus.
  12. Wählen Sie im Menü Datei drucken, um das Bild zu drucken.

Eigenschaften

Artikel-ID: 80409 - Geändert am: Dienstag, 11. Februar 2014 - Version: 2.0
Die Informationen in diesem Artikel beziehen sich auf:
  • Microsoft Visual Basic 2.0 Standard Edition
  • Microsoft Visual Basic 3.0 Professional Edition
  • Microsoft Visual Basic 2.0 Professional Edition
  • Microsoft Visual Basic 3.0 Professional Edition
  • Microsoft Visual Basic 1.0 Standard Edition
Keywords: 
kbnosurvey kbarchive kbmt KB80409 KbMtde
Maschinell übersetzter Artikel
Wichtig: Dieser Artikel wurde maschinell und nicht von einem Menschen übersetzt. Die Microsoft Knowledge Base ist sehr umfangreich und ihre Inhalte werden ständig ergänzt beziehungsweise überarbeitet. Um Ihnen dennoch alle Inhalte auf Deutsch anbieten zu können, werden viele Artikel nicht von Menschen, sondern von Übersetzungsprogrammen übersetzt, die kontinuierlich optimiert werden. Doch noch sind maschinell übersetzte Texte in der Regel nicht perfekt, insbesondere hinsichtlich Grammatik und des Einsatzes von Fremdwörtern sowie Fachbegriffen. Microsoft übernimmt keine Gewähr für die sprachliche Qualität oder die technische Richtigkeit der Übersetzungen und ist nicht für Probleme haftbar, die direkt oder indirekt durch Übersetzungsfehler oder die Verwendung der übersetzten Inhalte durch Kunden entstehen könnten.
Den englischen Originalartikel können Sie über folgenden Link abrufen: 80409
Microsoft stellt Ihnen die in der Knowledge Base angebotenen Artikel und Informationen als Service-Leistung zur Verfügung. Microsoft übernimmt keinerlei Gewährleistung dafür, dass die angebotenen Artikel und Informationen auch in Ihrer Einsatzumgebung die erwünschten Ergebnisse erzielen. Die Entscheidung darüber, ob und in welcher Form Sie die angebotenen Artikel und Informationen nutzen, liegt daher allein bei Ihnen. Mit Ausnahme der gesetzlichen Haftung für Vorsatz ist jede Haftung von Microsoft im Zusammenhang mit Ihrer Nutzung dieser Artikel oder Informationen ausgeschlossen.

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com