Cómo imprimir bordes del formulario de VB y menús

Seleccione idioma Seleccione idioma
Id. de artículo: 80409 - Ver los productos a los que se aplica este artículo
Este artículo se ha archivado. Se ofrece "tal cual" y no se volverá a actualizar.
Expandir todo | Contraer todo

En esta página

Resumen

Los métodos para imprimir un formulario proporcionado por Visual Basic impresión sólo el área de cliente, no el área no cliente de un formulario. Esto es una característica de diseño de Visual Basic. El área de cliente de un formulario incluye controles y la imagen del formulario. El área de cliente no incluye el formulario bordes y los menús, que no se puede imprimir directamente desde Visual Basic.

Para imprimir el cliente y las áreas no cliente de un formulario, copia una imagen del formulario en el Portapapeles, péguelo en un editor de gráficos, como pincel y imprimir. A continuación se proporcionan dos métodos para este procedimiento.

Más información

La opción Imprimir desde el menú archivo y la instrucción de Visual Basic [formulario].PrintForm sólo imprime el área de cliente de un formulario. El área de cliente incluye imágenes y los controles del formulario. Ambos métodos de impresión no imprimen el área no cliente, que incluye la barra de título del formulario, botones Minimizar y maximizar, bordes y los menús. Para imprimir el cliente y las áreas no cliente, debe imprimir el formulario desde una aplicación fuera de Visual Basic. Si desea imprimir un formulario que
  • Tiene elementos de submenú, pero no desea imprimir los submenús

    -o bien -
  • Tiene menús sin submenús

    -o bien -
  • No tiene menús
a continuación, utilice el método 1 siguiente para imprimir el formulario.

Si desea imprimir un formulario que contenga submenús en su estado extrajo desplegable, utilice el método 2 siguiente.

Método 1

Para imprimir un formulario sin extraer desplegable submenús, haga lo siguiente:
  1. Desde el entorno de edición de Visual Basic, cree el formulario que desee imprimir. Incluir todos los controles, títulos, menús, imágenes, bordes etc. que se desea imprimir y ajustar su tamaño correctamente.
  2. Establezca el foco en el formulario que desee imprimir.
  3. Presione ALT+IMPR PANT. Esta combinación de teclas es una operación en Windows que copia la ventana activa (el formulario en este caso) en el Portapapeles de Windows.
  4. Desde el Administrador de programas de Windows, inicie Paintbrush (o el editor de gráficos de su elección) y maximizarlo.
  5. En el menú Edición pincel, seleccione Pegar. La imagen del formulario debe aparecer en pincel. Si el formulario es demasiado grande para Paintbrush, pruebe una resolución de pantalla mayor (como 800 por 600 o 1024 por 768), otro editor con un mayor trabajo pantalla o reducir ligeramente el tamaño del formulario para el proceso de impresión.
  6. Una vez el formulario se pega correctamente en pincel, del archivo de menú, seleccione Imprimir para imprimirlo.

Método 2

Para imprimir un formulario con submenús extraen desplegable, haga lo siguiente:
  1. En el entorno de edición de Visual Basic, cree el formulario que desee imprimir. Incluir todos los controles, títulos, menús, imágenes, bordes etc. que desea imprimir y ajustar su tamaño correctamente.
  2. Establezca el foco en el formulario que se va a imprimir.
  3. Va el formulario en la esquina superior izquierda de la pantalla. Cuando el Portapapeles pega su imagen en pincel, se inicia en la esquina superior izquierda. Si la imagen es demasiado grande para la pantalla de edición de pincel, la imagen se trunca en los bordes derecho e inferior. Colocar el formulario en la esquina superior izquierda ayuda a garantizar que el formulario completo encaja en pincel.
  4. Elija la opción de menú que desea se extraer hacia abajo cuando imprima el formulario. La opción de menú debe aparecer extraída hacia abajo en la pantalla. Opción de sólo menú se puede extraer hacia abajo a la vez, pero se pueden seleccionar opciones del submenú.
  5. Presione MAYÚSCULAS+IMPR PANT. Esta pulsación de tecla es una opción en Windows que se copia una imagen de toda la pantalla en el Portapapeles de Windows. Cuando los menús están abiertos, Visual Basic aplica reventado a la tecla ALT y cierra los menús, por lo que el ALT+IMPR PANT teclado en el método 1 ineficaz cuando imprima desplegable menús en un formulario.
  6. Desde el Administrador de programas, inicie Paintbrush (o el editor de gráficos de su elección) y maximizarlo.
  7. En el menú Edición pincel, seleccione Pegar. El formulario debe aparecer en pincel. Si el formulario es demasiado grande para Paintbrush, pruebe cualquiera una mayor resolución (por ejemplo, 800 por 600 o 1024 por 768), otro editor con un mayor trabajo pantalla o reducir ligeramente el tamaño del formulario para el proceso de impresión.
  8. Mediante una de las herramientas Cortar en la parte superior del pincel en el cuadro de herramientas, esquema de su formulario.
  9. En el menú Edición, elija Copiar. Esto coloca el área de gráficos contenido en la región de cortar en el Portapapeles.
  10. En el menú Archivo, elija Nuevo para abrir una nueva pantalla de editor. Aparecerá un cuadro de diálogo preguntar si desea guardar la imagen actual. Necesitará seleccionar Sí o no antes de un nuevo editor aparecerá la pantalla.
  11. Una vez que la pantalla del editor está vacía, en el menú Edición, elija Pegar para pegar el formulario en el editor.
  12. En el menú Archivo, elija Imprimir para imprimir la imagen.

Propiedades

Id. de artículo: 80409 - Última revisión: miércoles, 12 de febrero de 2014 - Versión: 2.0
La información de este artículo se refiere a:
  • Microsoft Visual Basic 2.0 Standard Edition
  • Microsoft Visual Basic 3.0 Professional Edition
  • Microsoft Visual Basic 2.0 Professional Edition
  • Microsoft Visual Basic 3.0 Professional Edition
  • Microsoft Visual Basic 1.0 Standard Edition
Palabras clave: 
kbnosurvey kbarchive kbmt KB80409 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 80409

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com