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Access Violation in Services.exe Causes Windows NT Server to Stop Responding

Article ID:810036
Last Review:October 26, 2006
Revision:1.4

SYMPTOMS

If your Microsoft Windows NT Server 4.0-based computer stops responding, you cannot access the computer locally or from across the network, and you must restart the computer. If you examine the Dr. Watson log, an access violation error may appear in the Services.exe process. Also, the following event may be logged in the system event log:

Event Type: Error
Event Source: Server
Event ID: 2507
Description:
The security descriptor stored in the Registry for the share NETLOGON was invalid. The share was not automatically recreated.

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CAUSE

This problem occurs when the Services.exe process stops responding because of heap corruption. The heap corruption occurs becaused the Server service uses a pointer to the security descriptor when the security descriptor has already been released.

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RESOLUTION

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question. The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version          Size     File name
   --------------------------------------------------------------
   05-Nov-2002  19:46  4.0.1381.7201    73,488   Srvsvc.dll
Note Because of file dependencies, this hotfix requires Microsoft Windows NT 4.0 Service Pack 6a.

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STATUS

Microsoft has confirmed that this is a problem in Microsoft Windows NT 4.0.

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MORE INFORMATION

For additional information about the Dr. Watson log, click the following article number to view the article in the Microsoft Knowledge Base:
246084 (http://support.microsoft.com/kb/246084/) Interpreting the DrWtsn32.log File to Identify Program Crash Data

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APPLIES TO
Microsoft Windows NT Server 4.0 Standard Edition

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Keywords: 
kbhotfixserver kbqfe kbqfe kbfix kbbug KB810036

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