Comment implémenter des événements de génération dans Visual C# .NET ou Visual C# 2005

Traductions disponibles Traductions disponibles
Numéro d'article: 810230 - Voir les produits auxquels s'applique cet article
Agrandir tout | Réduire tout

Sommaire

IMPORTANT : Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, veillez à sauvegarder et assurez-vous que vous savez comment restaurer le Registre si un problème se produit. Pour savoir comment sauvegarder, restaurer et modifier le Registre, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :
256986 Description de du Registre Microsoft Windows

Résumé

Cet article étape par étape explique comment implémenter des événements de génération dans Visual C# .NET ou Visual C# 2005.

Lorsque vous utilisez les événements de génération, vous pouvez spécifier une action qui se produit à un moment spécifique pendant le processus de génération. Par exemple, vous pouvez spécifier un événement après génération pour inscrire un fichier à l'aide de regsvr32.exe. Vous pouvez également afficher et apporter une modification à un assembly généré dans le GAC (Global assembly cache) à l'aide de l'outil Gacutil.exe.

Dans Visual C# .NET ou Visual C# 2005, il existe sans méthodes directes pour spécifier les événements pre-build et après génération.


Vous pouvez utiliser un Visual Project Makefile C++ aux événements générer appliquer

Événements de génération sont une fonctionnalité intégrée de projets Visual C++ .NET. Vous pouvez implémenter ces événements dans un projet Visual C# .NET ou Visual C# 2005 en incluant un projet Visual C++ .NET Makefile dans la solution. Pour implémenter des événements Avant , vous devez effectuer les dépendants de projet Visual C++ .NET Makefile sur le projet Visual C# .NET ou Visual C# 2005. Pour implémenter post-build événements, vous devez effectuer les dépendants de projet Visual C# .NET ou Visual C# 2005 sur le projet Visual C++ .NET Makefile.

Pour ce faire, procédez comme suit :
  1. Ouvrez votre solution Visual C# .NET ou Visual C# 2005 existante.
  2. Dans le menu Fichier , pointez sur Ajouter Project , puis cliquez sur Nouveau projet .
  3. Sous types de projets , cliquez sur projets Visual C++ , sous modèles , cliquez sur projets MakeFile .
    note Dans Visual Studio 2005, « projets Visual C++ » doit être modifiés en C++ Visual.
  4. Tapez le nom de la solution, spécifiez un emplacement pour la solution et puis cliquez sur OK .
  5. Dans l' Assistant Application Makefile , cliquez sur Terminer .
  6. Dans le menu projet du projet Makefile, cliquez sur Propriétés .
  7. Dans la zone Type de configuration , sélectionnez utilitaire et puis cliquez sur OK .
  8. Dans le menu projet , cliquez sur projet Dependencies? . Pour effectuer les événements pre-build, procédez comme suit :
    1. Sous l'onglet dépendances , sélectionnez le projet Visual C# .NET approprié dans la liste de projets , puis sous Depends sur , cliquez sur le projet Visual C++ Makefile .
    2. Cliquez sur OK pour appliquer la modification. Cela garantit que le projet Visual C# .NET ou Visual C# 2005 est généré dernier.
    3. Cliquer avec le bouton droit sur le projet Visual C++ Makefile dans l'Explorateur de solutions, puis cliquez sur Propriétés .
    4. Cliquez sur Générer des événements , puis spécifiez la commande événement pre-build.
      Par exemple, pour copier le fichier avant de construction, spécifiez suivantes :
      copy c:\AddinReg.reg $(OutDir)
  9. Pour effectuer l'installation après génération, procédez comme suit :
    1. Cliquez sur le projet Visual C++ Makefile dans la liste projets , puis sélectionnez le projet Visual C# .NET ou Visual C# 2005 approprié sous Depends sur .
    2. Cliquez sur OK pour appliquer la modification. Cela garantit que le projet Visual C++ est créée en dernier.
    3. Cliquer avec le bouton droit sur le projet Visual C++ Makefile dans l'Explorateur de solutions, cliquez sur Propriétés , puis cliquez sur Générer des événements pour spécifier la commande de l'événement après génération.

Utilisation du complément PrePostBuildRules aux événements générer appliquer

  1. Ce complément fournit des règles pre-build et après génération aux niveaux du projet et de solution.
    Pour télécharger le complément, consultez le site Web de Microsoft à l'adresse suivante :

    http://download.microsoft.com/download/VisualStudioNET/Samples/7.0/NT5XP/EN-US/BuildRules.exe

    Avertissement : Si vous utilisez l'Éditeur du Registre de façon incorrecte, vous pouvez générer des graves problèmes pouvant vous obliger à réinstaller votre système d'exploitation. Microsoft ne peut pas garantit que vous pouvez résoudre les problèmes résultant de l'utilisation incorrecte de l'Éditeur du Registre. Utilisez l'Éditeur du Registre à vos risques et périls.
    Pour utiliser ce complément, procédez comme suit :
    1. Charger le fichier solution avec cette source et ensuite générer la solution.
    2. Dans le menu Outils , cliquez sur Gestionnaire de compléments . Si le Gestionnaire de compléments est déjà ouvert, fermez-le et que vous l'ouvrez de nouveau.

      note Si le nouveau complément dans apparaît dans le ajouter, dans le Gestionnaire liste des compléments, vous avez correctement inscrit le complément.
    3. Si le complément ne figure pas dans la ajouter, dans le Gestionnaire liste, effectuez la procédure pour enregistrer manuellement :
      1. Recherchez le fichier AddinReg.reg dans le dossier BuildRules .
      2. Cliquez avec le bouton droit sur AddinReg.reg , puis cliquez sur Fusionner . Cliquez sur Oui lorsque invité à ajouter les entrées dans le Registre.
      3. Vous pouvez visualiser les nouvelles entrées dans le Registre dans l'emplacement suivant :

        HKEY_CURRENT_USER\SOFTWARE\Microsoft\VisualStudio\7.0\AddIns
    4. Démarre une nouvelle instance de Visual Studio .NET ou Visual Studio 2005.
    5. Dans le menu Outils , cliquez sur la nouvelle macro complémentaire.
    6. Une boîte de dialogue qui vous pour sélectionner la solution ou le projet et ajouter des règles aux qu'il s'affiche.
    7. Lorsque vous ajoutez une règle, vous pouvez spécifier le nom Écho comme nom de programme pour afficher texte brut dans la fenêtre Sortie.

Références

Pour plus d'informations, consultez le site de Web Microsoft suivant :

Exemples d'automatisation pour Visual Studio .NET
http://www.microsoft.com/downloads/details.aspx?familyid=3ff9c915-30e5-430e-95b3-621dccd25150&displaylang=en

Propriétés

Numéro d'article: 810230 - Dernière mise à jour: mercredi 10 janvier 2007 - Version: 3.3
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Visual C# .NET 2002 Initiation
  • Microsoft Visual C# .NET 2003 Initiation
  • Microsoft Visual C++ .NET 2002 Initiation
  • Microsoft Visual C++ .NET 2003 Initiation
  • Microsoft Visual C# 2005 Express Edition
Mots-clés : 
kbmt kbdownload kbhowtomaster kbcompiler kbhowto KB810230 KbMtfr
Traduction automatique
IMPORTANT : Cet article est issu du système de traduction automatique mis au point par Microsoft (http://support.microsoft.com/gp/mtdetails). Un certain nombre d?articles obtenus par traduction automatique sont en effet mis à votre disposition en complément des articles traduits en langue française par des traducteurs professionnels. Cela vous permet d?avoir accès, dans votre propre langue, à l?ensemble des articles de la base de connaissances rédigés originellement en langue anglaise. Les articles traduits automatiquement ne sont pas toujours parfaits et peuvent comporter des erreurs de vocabulaire, de syntaxe ou de grammaire (probablement semblables aux erreurs que ferait une personne étrangère s?exprimant dans votre langue !). Néanmoins, mis à part ces imperfections, ces articles devraient suffire à vous orienter et à vous aider à résoudre votre problème. Microsoft s?efforce aussi continuellement de faire évoluer son système de traduction automatique.
La version anglaise de cet article est la suivante: 810230
L'INFORMATION CONTENUE DANS CE DOCUMENT EST FOURNIE PAR MICROSOFT SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. L'UTILISATEUR ASSUME LE RISQUE DE L'UTILISATION DU CONTENU DE CE DOCUMENT. CE DOCUMENT NE PEUT ETRE REVENDU OU CEDE EN ECHANGE D'UN QUELCONQUE PROFIT.

Envoyer des commentaires

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com