Como implementar a eventos de compilação no Visual C# .NET ou Visual C# 2005

Traduções de Artigos Traduções de Artigos
Artigo: 810230 - Ver produtos para os quais este artigo se aplica.
Expandir tudo | Reduzir tudo

Nesta página

importante : Este artigo contém informações sobre como modificar o registo. Antes de modificar o registo, certifique-se de que efectua uma cópia de segurança e de que compreende como o restaurar o registo se ocorrer um problema. Para obter informações sobre como efectuar uma cópia de segurança, restaurar e editar o registo, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
256986Descrição do registo do Microsoft Windows

Sumário

Este artigo passo a passo descreve como implementar a eventos de compilação no Visual C# .NET ou Visual C# 2005.

Quando utilizar eventos de compilação, pode especificar uma acção que ocorre num determinado momento durante o processo de criação. Por exemplo, pode especificar um evento post-build para registar um ficheiro através da utilização de regsvr32.exe. Pode também visualizar e efectuar uma alteração uma assemblagem na GAC (global assembly cache) gerada utilizando a ferramenta Gacutil.exe.

No Visual C# .NET ou Visual C# 2005, não existem nenhum método para especificar eventos pre-build e post-build directo.


Utilizar um projecto do Visual C++ Makefile para implementar criar eventos

Eventos de compilação são uma funcionalidade incorporada de projectos do Microsoft Visual C++. NET. Pode implementar estes eventos, num projecto do Visual C# .NET ou Visual C# 2005, incluindo um projecto de Visual C++ .NET Makefile na solução. Para implementar pre-build eventos, tem de efectuar o dependentes de projecto de Visual C++ .NET Makefile no projecto Visual C# .NET ou Visual C# 2005. Para implementar post-build eventos, tem de efectuar dependentes de projecto do Visual C# .NET ou Visual C# 2005 no projecto Visual C++ .NET Makefile.

Para o fazer, siga estes passos:
  1. Abra a solução do Visual C# .NET ou Visual C# 2005 existente.
  2. No menu ficheiro , aponte para Adicionar projecto e, em seguida, clique em Novo projecto .
  3. Em Project Types , clique em Projectos do Visual C++ e, em modelos , clique em Projecto MakeFile .
    Nota No Visual Studio 2005, "Projectos de Visual C++" deve ser alterados para "Visual C++."
  4. Escreva o nome para a solução, especifique uma localização para a solução e, em seguida, clique em OK .
  5. No Assistente de aplicação Makefile , clique em Concluir .
  6. No menu Project do Makefile Project, clique em Propriedades .
  7. Na caixa Tipo de configuração , seleccione utilitário e, em seguida, clique em OK .
  8. No menu projecto , clique em Project Dependencies? . Para executar os eventos pre-build, siga estes passos:
    1. No separador dependências , seleccione o projecto do Visual C# .NET adequado na lista de projectos e, em seguida, em Depends no , clique no projecto Visual C++ Makefile .
    2. Clique em OK para aplicar a alteração. Deste modo, garante que o projecto de Visual C# .NET ou Visual C# 2005 é criado pela última vez.
    3. Clique com o botão direito do rato no projecto de Visual C++ Makefile no Solution Explorer e, em seguida, clique em Propriedades .
    4. Clique em Criar eventos e, em seguida, especificar o comando de evento pre-build.
      Por exemplo, para copiar o ficheiro antes de criar, especifique o seguinte:
      copy c:\AddinReg.reg $(OutDir)
  9. Para executar o programa de configuração post-build, siga estes passos:
    1. Clique no projecto Visual C++ Makefile na lista de projectos e seleccione o projecto do Visual C# .NET ou Visual C# 2005 adequado em Depends no .
    2. Clique em OK para aplicar a alteração. Deste modo, garante que o projecto de Visual C++ é criado pela última vez.
    3. Clique com o botão direito do rato no projecto de Visual C++ Makefile no Solution Explorer, clique em Propriedades e, em seguida, clique em Criar eventos para especificar o comando de evento post-build.

Utilizar o suplemento PrePostBuildRules para implementar criar eventos

  1. Este adicionar-fornece pre-build e post-build regras níveis a solução e projecto.
    Para transferir o suplemento, consulte o seguinte Web site da Microsoft:

    http://download.microsoft.com/download/VisualStudioNET/Samples/7.0/NT5XP/EN-US/BuildRules.exe

    aviso : a utilização incorrecta do Editor de registo poderá provocar problemas graves que poderão forçar a reinstalação do sistema operativo. Microsoft não garante que os problemas resultantes da utilização incorrecta do Editor de registo possam ser resolvidos. As suas próprias risco da utilização do Editor de registo.
    Para utilizar este suplemento, siga estes passos:
    1. Carregar o ficheiro de solução com esta origem e, em seguida, criar a solução.
    2. No menu Ferramentas , clique em Gestor de suplementos . Se o Gestor de suplementos já estiver aberto, feche-a e, em seguida, abra-o novamente.

      Nota Se o suplemento novo aparecer o Adicionar - Gestor lista de suplementos, com êxito registou o suplemento.
    3. Se o suplemento não aparecer no Adicionar - Gestor lista, siga os passos para registar manualmente:
      1. Localize o ficheiro AddinReg.reg na pasta BuildRules .
      2. Clique com o botão direito do rato AddinReg.reg e, em seguida, clique em Enviar a impressão em série . Clique em Sim quando lhe for pedido para adicionar as entradas de registo.
      3. Os novos movimentos efectuados no registo podem ser vistos na seguinte localização:

        HKEY_CURRENT_USER\SOFTWARE\Microsoft\VisualStudio\7.0\AddIns
    4. Inicie uma nova instância do Visual Studio .NET ou Visual Studio 2005.
    5. No menu Ferramentas , faça clique sobre o novo suplemento.
    6. Aparece uma caixa de diálogo permite-lhe para seleccionar a solução ou projecto e adicionar regras à mesma.
    7. Quando adiciona uma regra, pode especificar o nome eco como o nome de programa para visualizar o texto não processado na janela de resultados.

Referências

Para obter informações adicionais, consulte o seguinte Web site da Microsoft:

Exemplos de automatização para o Visual Studio .NET
http://www.microsoft.com/downloads/details.aspx?familyid=3ff9c915-30e5-430e-95b3-621dccd25150&displaylang=en

Propriedades

Artigo: 810230 - Última revisão: 10 de janeiro de 2007 - Revisão: 3.3
A informação contida neste artigo aplica-se a:
  • Microsoft Visual C# .NET 2002 Standard Edition
  • Microsoft Visual C# .NET 2003 Standard Edition
  • Microsoft Visual C++ .NET 2002 Standard Edition
  • Microsoft Visual C++ .NET 2003 Standard Edition
  • Microsoft Visual C# 2005 Express Edition
Palavras-chave: 
kbmt kbdownload kbhowtomaster kbcompiler kbhowto KB810230 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine translation ou MT), não tendo sido portanto revisto ou traduzido por humanos. A Microsoft tem artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais. O objectivo é simples: oferecer em Português a totalidade dos artigos existentes na base de dados do suporte. Sabemos no entanto que a tradução automática não é sempre perfeita. Esta pode conter erros de vocabulário, sintaxe ou gramática? erros semelhantes aos que um estrangeiro realiza ao falar em Português. A Microsoft não é responsável por incoerências, erros ou estragos realizados na sequência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza actualizações frequentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 810230

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com