Como implementar eventos de compilação no Visual translation from VPE for Csharp .NET ou Visual translation from VPE for Csharp 2005

Traduções deste artigo Traduções deste artigo
ID do artigo: 810230 - Exibir os produtos aos quais esse artigo se aplica.
Expandir tudo | Recolher tudo

Neste artigo

importante : Este artigo contém informações sobre como modificar o registro. Antes de modificar o registro, certifique-se de backup e certifique-se que você saiba como restaurar o registro se ocorrer um problema. Para obter informações sobre como fazer backup, restaurar e editar o registro, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
256986Descrição do registro do Microsoft Windows

Sumário

Este artigo passo a passo descreve como implementar eventos de compilação no Visual translation from VPE for Csharp .NET ou Visual translation from VPE for Csharp 2005.

Quando você usa os eventos de compilação, você pode especificar uma ação que ocorre em uma hora específica durante o processo de compilação. Por exemplo, você pode especificar um evento de pós-compilação para registrar um arquivo usando o regsvr32.exe. Você também pode exibir e fazer uma alteração de um assembly gerado no GAC (global assembly cache) usando a ferramenta Gacutil.exe.

No Visual translation from VPE for Csharp .NET ou Visual translation from VPE for Csharp 2005, há não métodos diretos para especificar eventos Pre-Build e pós-compilação.


Usar um projeto Makefile C++ Visual para implementar eventos de compilação

Eventos de compilação são um recurso interno de projetos do Microsoft Visual C++. NET. Você pode implementar esses eventos em um projeto .NET translation from VPE for Csharp ou Visual C# 2005 Visual, incluindo um projeto Visual C++.NET Makefile na solução. Para implementar pre-build eventos, você deve fazer o dependentes de projeto do Visual C++ .NET Makefile sobre o projeto .NET translation from VPE for Csharp ou Visual C# 2005 Visual. Para implementar eventos de compilação , você deve fazer o dependentes de projeto translation from VPE for Csharp .NET ou Visual translation from VPE for Csharp 2005 Visual no projeto Visual C++.NET Makefile.

Para fazer isso, execute as seguintes etapas:
  1. Abra sua solução translation from VPE for Csharp .NET ou Visual translation from VPE for Csharp 2005 Visual existente.
  2. No menu arquivo , aponte para Adicionar projeto e em seguida, clique New Project .
  3. Em Project Types , clique em Projetos do Visual c++ e, em modelos , clique em MakeFile Project .
    Observação No Visual Studio 2005, "Visual C++ Projects" deve ser alterado para "Visual C++."
  4. Digite o nome para a solução, especifique um local para a solução e, em seguida, clique em OK .
  5. No Makefile Application Wizard , clique em Concluir .
  6. No menu Project do projeto Makefile, clique em Propriedades .
  7. Na caixa Tipo de configuração , selecione utilitário e, em seguida, clique em OK .
  8. No menu Project , clique em Project Dependencies? . Para executar os eventos Pre-Build, execute estas etapas:
    1. Na guia dependências , selecione o projeto Visual .NET translation from VPE for Csharp apropriado na lista de projetos e, em seguida, em depende de , clique em projeto Visual C++ Makefile .
    2. Clique em OK para aplicar a alteração. Isso torna-se de que o projeto do Visual .NET translation from VPE for Csharp ou Visual C# 2005 é criado pela última vez.
    3. Clique o projeto Visual C++ Makefile em Solution Explorer com o botão direito do mouse e, em seguida, clique em Propriedades .
    4. Clique em Build Events e especifique o comando de evento pré-compilação.
      Por exemplo, para copiar o arquivo antes de construção, especifique o seguinte:
      copy c:\AddinReg.reg $(OutDir)
  9. Para executar a instalação pós-compilação, execute estas etapas:
    1. Clique no projeto Visual C++ Makefile na lista de projetos e selecione apropriado Visual projeto .NET translation from VPE for Csharp ou Visual C# 2005 em depende .
    2. Clique em OK para aplicar a alteração. Isso torna-se de que o projeto Visual C++ é criado pela última vez.
    3. Clique o projeto Visual C++ Makefile em Solution Explorer com o botão direito do mouse, clique em Propriedades e, em seguida, clique em Build Events para especificar o comando de evento de pós-compilação.

Usar o suplemento PrePostBuildRules para implementar eventos de compilação

  1. Esse suplemento fornece regras de pré-compilação e pós-compilação nos níveis de solução e projeto.
    Para fazer o download o suplemento, consulte o seguinte site da Microsoft:

    http://download.microsoft.com/download/VisualStudioNET/Samples/7.0/NT5XP/EN-US/BuildRules.exe

    Aviso : se você usar o Editor do Registro incorretamente, poderá causar problemas sérios que talvez exijam a reinstalação do sistema operacional. A Microsoft não garante que você pode resolver problemas resultantes do uso incorreto do Editor do Registro. Use o Editor do registro por sua própria conta e risco.
    Para usar esse suplemento, execute estas etapas:
    1. Carregar o arquivo de solução com essa fonte e, em seguida, criar a solução.
    2. No menu Ferramentas , clique em Gerenciador de suplementos . Se o Gerenciador de suplementos já estiver aberto, feche-o e, em seguida, abra-o novamente.

      Observação Se o suplemento novo aparecer no Adicionar - Gerenciador lista de suplementos, você se registrou com êxito o add-in.
    3. Se o suplemento não for exibido no Adicionar - Gerenciador lista, siga as etapas para registrá-lo manualmente:
      1. Localize o arquivo AddinReg.reg na pasta BuildRules .
      2. Clique com o botão direito do mouse AddinReg.reg e clique em Mesclar . Clique em Sim quando solicitado a adicionar as entradas no registro.
      3. As novas entradas feitas no Registro podem ser vistas no seguinte local:

        HKEY_CURRENT_USER\SOFTWARE\Microsoft\VisualStudio\7.0\AddIns
    4. Inicie uma nova instância do Visual Studio .NET ou Visual Studio 2005.
    5. No menu Ferramentas , clique no novo suplemento.
    6. Aparece uma caixa de diálogo que permite que você selecione a solução ou projeto e para adicionar regras a ela.
    7. Quando você adiciona uma regra, você pode especificar o nome eco como o nome do programa para exibir texto bruto na janela de saída.

Referências

Para obter informações adicionais, consulte o seguinte site:

Exemplos de automação para Visual Studio .NET
http://www.microsoft.com/downloads/details.aspx?familyid=3ff9c915-30e5-430e-95b3-621dccd25150&displaylang=en

Propriedades

ID do artigo: 810230 - Última revisão: quarta-feira, 10 de janeiro de 2007 - Revisão: 3.3
A informação contida neste artigo aplica-se a:
  • Microsoft Visual C# .NET 2002 Standard Edition
  • Microsoft Visual C# .NET 2003 Standard Edition
  • Microsoft Visual C++ .NET 2002 Standard Edition
  • Microsoft Visual C++ .NET 2003 Standard Edition
  • Microsoft Visual C# 2005 Express Edition
Palavras-chave: 
kbmt kbdownload kbhowtomaster kbcompiler kbhowto KB810230 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 810230

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com